Chip stopped responding to DBM

Started by in 68HC1213 years ago 8 replies

Hi, Today I was fooling around with the Hiware debugger, trying to see the contents of the flash and for some reason it failled saying...

Hi, Today I was fooling around with the Hiware debugger, trying to see the contents of the flash and for some reason it failled saying the chip could be in secure mode, then I clicked on the menu on the "Unsecure...", it executed a brunch of commands then stopped working at all. I can't reflash it anyway I try. I have the P&E USB cable, and


ADC

Started by longnpham1964 in 68HC1214 years ago 1 reply

Hi, Can anyone please help me with using the ADC converter of the MC9S12DG256? I am able to set-up the AD register and can...

Hi, Can anyone please help me with using the ADC converter of the MC9S12DG256? I am able to set-up the AD register and can use debugger to view the ADC result register to verify it follows the input. I just need help on how to transfer value of the AD result register


Motorola AN2213 on Cosmic C.

Started by Andrew Lohmann's New Email Server in 68HC1215 years ago 4 replies

Dear Group, I came across the above application note and consequently added the a security section $ff00 - $ff10, but after doing...

Dear Group, I came across the above application note and consequently added the a security section $ff00 - $ff10, but after doing that my debugger (Cosmic Zap) flash/EEPROM programmer failed. So for now I have left this section out, but it looks important how should I incorporate it? My target


Accessing flash while running out of ram

Started by liszewski_jason in 68HC1214 years ago 2 replies

I am currently writing firmware for a project that uses the MC9S12DJ256 microcontroller. I am doing all of my developing in RAM ...

I am currently writing firmware for a project that uses the MC9S12DJ256 microcontroller. I am doing all of my developing in RAM with the NOICE debugger. Right now I am working on firmware updates that are stored in the flash and then copied from one half of the flash to the ot


I2C interface for 9S12DP256

Started by Anonymous in 68HC1214 years ago

Hello ! I'm trying to start I2C bus on 9S12DP256, with ImageCraft Compiler ICC12, P&E BDM, NoIce debugger, quartz 12 Mhz. ...

Hello ! I'm trying to start I2C bus on 9S12DP256, with ImageCraft Compiler ICC12, P&E BDM, NoIce debugger, quartz 12 Mhz. Now without any success. -:((( I analysed the soft provided in Application Note AN2318, Which run under interruptions.


IDE issues...

Started by w.se...@... in 68HC1212 years ago 4 replies

Hello, I am using P&E Dev kit (DEV9S12DP256B) for the HCS12 and ImageCraft. I am having a tough time trying to get C code to show in the...

Hello, I am using P&E Dev kit (DEV9S12DP256B) for the HCS12 and ImageCraft. I am having a tough time trying to get C code to show in the debugger. I have set the project option in ICC to "S19 with source level debugging". I have a C program that I have been able build and generate the S19 file. From there I converted this to physical addresses (using log2phy.exe) and I can


External memory

Started by Andrew Lohmann's New Email Server in 68HC1214 years ago 9 replies

Hi, Apologies for keep on bring this up on the group but, having built a new improved target, I still can't access external...

Hi, Apologies for keep on bring this up on the group but, having built a new improved target, I still can't access external ram reliably. My target is MC9S12E128. With the debugger connected I can write a small block of data fine. I can also write a MSB ok (A0=0), but when I


Re: D64 COP: the saga continues

Started by Edward Karpicz in 68HC1210 years ago

WadeA & RebeccaM Smith wrote: > > I assign EVERY vector to a routine to keep track of EVERY interrupt > that I dont actully use. There...

WadeA & RebeccaM Smith wrote: > > I assign EVERY vector to a routine to keep track of EVERY interrupt > that I dont actully use. There seems to be no help there. What does that routine do? Does it loop forever until you hotconnect with debugger that is able to connect without reset into special mode? Does NoICE supports that or does it indeed resets CPU into special chip mode? > >


Re: Metrowerks/Hiwave/PE-USB Very Slow

Started by John Hartman NoICE in 68HC1213 years ago 4 replies

>I use a combination of Metrowerks and PE-USB-ML Cable. >Lately I have noticed that response to run/stop and reset when debugging >are...

>I use a combination of Metrowerks and PE-USB-ML Cable. >Lately I have noticed that response to run/stop and reset when debugging >are very slow. I think that this has been happening for a while but now >it seems to happen at nearly every step. >When I say slow, sometimes it takes 20-25 seconds for the debugger to >stop my hardware!


HC08 debugger???

Started by James M. Knox in 68HC1212 years ago 1 reply

Only slightly off topic: We need to split up the application on an HC12-based system, with a small remote card communicating with...

Only slightly off topic: We need to split up the application on an HC12-based system, with a small remote card communicating with the main HC12 board. The communications requirements are relatively low, as is the needs for the remote board (10 bit AD/C, a few I/O lines, small amount of Flash and RAM). Probably something like the MC68HC908AP16 wo


Codewarrior HC12 V1.2 and USB Multilink ML-12 Rev C.

Started by "Guillermo F. Molina" in 68HC1211 years ago 2 replies

Hi all, Did anyone know if it is any chance to use the Hiwave debugger of the (old!) Codewarrior V1.2 with the new USB Multilink (ML-12 Rev....

Hi all, Did anyone know if it is any chance to use the Hiwave debugger of the (old!) Codewarrior V1.2 with the new USB Multilink (ML-12 Rev. C )? Thanks in advance. Best regards, G.Molina


Timer Interrupt Help

Started by scca...@yahoo.com in 68HC1211 years ago 1 reply

Hello, I\\\'ve been trying to figure this out for some time now and think I\\\'m having a little trouble with the concept in addition to some...

Hello, I\\\'ve been trying to figure this out for some time now and think I\\\'m having a little trouble with the concept in addition to some other details. I\\\'m trying to get a timer capture interrupt working on my cards12 (mc9s12d64) using ICC12 and a NoIce Debugger. At this point, I\\\'m just trying to get the interrupt working and then eventually will want to time stamp a 5V pulse coming...


Hai

Started by Srinivas Parasaram in 68HC1211 years ago

Hai friends, I am using MC9S12E128 controller with CodeWarrior V4.5, Cyclone pro debugger and powered with 3.3V . Configuration...

Hai friends, I am using MC9S12E128 controller with CodeWarrior V4.5, Cyclone pro debugger and powered with 3.3V . Configuration used is 16Mhz bus frequncy with PLL activated,and Normal Expanded wide mode with 0x4000 to 0x7fff as external address range. The multiplexed A/D bus interacts with CPLD.I am facing two problems: 1) Non initialization of global variables at...


M68hc9s12DP256 SCI

Started by iewgnip in 68HC1214 years ago 1 reply

Hi Everyone.. I'm using the s12dp256B maskset: 1K79X. I'm trying out a simple SCI code to echo what I received from the...

Hi Everyone.. I'm using the s12dp256B maskset: 1K79X. I'm trying out a simple SCI code to echo what I received from the computer and transmit back to the computer. I am using the Codewarrior debugger. Here's my code: org $C000 main: lds #$4000 ; stack sta


bootloader for 9s12c128

Started by leoundmarion in 68HC1213 years ago 5 replies

Hello! I adadpted the bootloader described in AN2153. I didn't copy it into the RAM but put it into ROM at Adress C000 to D000. ...

Hello! I adadpted the bootloader described in AN2153. I didn't copy it into the RAM but put it into ROM at Adress C000 to D000. Then I wanted to write into the PAGED Area of the RAM (e.g. 388000) If I debug the Code with my BDM Debugger step by step everything works fine, but if I let it run, the Program Conunter crashes after setting


trouble with PLL on the HC12

Started by Chris in 68HC127 years ago 13 replies

Hello; I am using an ICC12 compiler and NOICE debugger with a USB pod with an HC12 128kB chip running with a 16MHz crystal. My problem is that...

Hello; I am using an ICC12 compiler and NOICE debugger with a USB pod with an HC12 128kB chip running with a 16MHz crystal. My problem is that when I try to set the PLL up for about 40MHz, the code does not seem to work in the way it should and I can't get a LOCK - or even a TRACK signal. I have to turn off the PLLSEL bit before trying to set up the mult and divide registers and turning the...


dwarf debug information

Started by pascal_derex in 68HC1213 years ago 2 replies

Hello, I use the limited version (32k compiler) CW3 for hcs12 and the real time debugger from CW. But i can't debug the c source...

Hello, I use the limited version (32k compiler) CW3 for hcs12 and the real time debugger from CW. But i can't debug the c source file, i am just able to debug in asm. In the compiler option i have selected "compatible ELF/DWARF 2.0" (- f2O). Any suggestions? Thank you for help Regards


Weird behaviour of D64 2L86D in BDM mode

Started by Edward Karpicz in 68HC1214 years ago

Hi I have been using self made BDM programer/debugger for a while. Programming was limited to programming of small...

Hi I have been using self made BDM programer/debugger for a while. Programming was limited to programming of small bootloader only, up to 8k of top most page. Everything was fine and cool. I haven't time to play more with optional less important things as BD


pulse acc B on MC912DG128A

Started by Danny Sheen in 68HC1215 years ago

Has anyone successfully used pulse accumulator B on PT0 of the MC912DG128A? I cannot get pulse accumulator B to work. I have...

Has anyone successfully used pulse accumulator B on PT0 of the MC912DG128A? I cannot get pulse accumulator B to work. I have verified that pulses are coming in on PT0. I can also see the port value toggling with an in circuit debugger, but PAC1 and 0 do not increment. I have also ve


putchar function !

Started by the_r8_one in 68HC1214 years ago

Hi , I'm using HCS12 with a D-BUG V 4.0.0b24 ... I'm trying to send a character out though serial port. I used the debugger...

Hi , I'm using HCS12 with a D-BUG V 4.0.0b24 ... I'm trying to send a character out though serial port. I used the debugger function putchar ( equ EF84), but it causes my program to crash. Does anybody know how to solve that problem? putchar equ EF84 ...