NoICE v Cosmic Zap

Started by Andrew Lohmann's New Email Server in 68HC1214 years ago 7 replies

Hi, My Cosmic Zap debugger reports after a minite sycronisation error. I use P&E Mulitlink12 cable and have tried both the...

Hi, My Cosmic Zap debugger reports after a minite sycronisation error. I use P&E Mulitlink12 cable and have tried both the parrell port version with the XP Pro patch, and the USB version, as it is suggested that that is where the syncronisation error comes from. There has not been a


flash error

Started by koby_bens in 68HC1214 years ago 1 reply

hi! i use the E128 and codewarrior 3.1 .i am trying to write data for the flash and i can do it only if i use breakpoint after...

hi! i use the E128 and codewarrior 3.1 .i am trying to write data for the flash and i can do it only if i use breakpoint after the write(3 steps data,fcmd,cbeif). if i disable the breakpoint the debugger crash and i get message that there isn't any source reference found doe


Timer Capture Interrupts Please Help

Started by scca...@yahoo.com in 68HC1211 years ago 1 reply

Hello, I've been trying to figure this out for some time now and think I'm having a little trouble with the concept in addition to some other...

Hello, I've been trying to figure this out for some time now and think I'm having a little trouble with the concept in addition to some other details. I'm trying to get a timer capture interrupt working on my cards12 (mc9s12d64) using ICC12 and a NoIce Debugger. At this point, I'm just trying to get the interrupt working and then eventually will want to time stamp a 5V pulse coming into the c...


Trigger A occurred on HCS12 & CW6.1

Started by AndreaT in 68HC127 years ago

I'm very new to embedded systems programming and learning about scheduling. I am getting a Trigger A occurred in the command window of the...

I'm very new to embedded systems programming and learning about scheduling. I am getting a Trigger A occurred in the command window of the debugger when I hit RUN. When I step through the code it seems to reset? at asm cli at the end of the code. Please let me know if you all have any ideas. /* Started with Valvano Fixed Priority Scheduler. System should light two LEDs alternately every 500...


Using Terminal in Codewarrior - no serial port

Started by blewis999 in 68HC1212 years ago 2 replies

We are using CW and a 9sdg128B and need to I/O to a serial port... but have no phsyical serial port on the board. It seems like it should be...

We are using CW and a 9sdg128B and need to I/O to a serial port... but have no phsyical serial port on the board. It seems like it should be possible to use Terminal component in the Debugger, but it isn't obvious to me how to do so. The doc set says this component relates to the Abatron BDI... whatever that is. Has anyone any advice on how to do this please, or can it even be done? W...


Stack utilisation

Started by same...@tatatechnologies.com in 68HC1212 years ago 1 reply

Dear Group, Currently I am using OSEK RTOs for my application on HCS12 microcontroller family. Are there any means of observing...

Dear Group, Currently I am using OSEK RTOs for my application on HCS12 microcontroller family. Are there any means of observing the stack heap growth of the TASKS in the Code Warrior debugger? Warm Regards, Sameer Deshmukh Solutions Developer-Embedded Systems TATA Technologies Ltd. Pune. +91 20 5613 3228 Effort is important, but knowing where to make an effort in your l...


Oscillator from s12dp256 to s12Xdp512

Started by jpdi...@free.fr in 68HC1211 years ago 3 replies

Hye I'm trying to go from 9s12dp256 CPU to 9s12Xdp512, with the same printed board. I'm able to download and debug program (ICC12...

Hye I'm trying to go from 9s12dp256 CPU to 9s12Xdp512, with the same printed board. I'm able to download and debug program (ICC12 ImageCraft V 7 compiler and NoIce debugger) But I think the CPU run with his internal clock, not quartz : - some functions (delay) developped before are very slow - the PLL doesn't run too. When I compare data sheets, I see dp256 family : Collpitts oscil...


Re: USB BDM pods?/Freescale/SoftecMicro S12X kit iscrap

Started by Liechty Ronald-RAT109 in 68HC1213 years ago

Kim Lux Wrote: > There is a code size limit in the debugger too, right ? Same as the compiler, C code but not for assembly. Ron ...

Kim Lux Wrote: > There is a code size limit in the debugger too, right ? Same as the compiler, C code but not for assembly. Ron -- Ron Liechty Ombudsman Freescale Developer Technology ron.liechty@ron....


Why does hc12mem NOT support HC12

Started by Jeff Smith in 68HC1211 years ago 2 replies

I am flabbergasted. Common sense tells me that hc12mem is for "HC12" devices. That would be great because I started using the excellent...

I am flabbergasted. Common sense tells me that hc12mem is for "HC12" devices. That would be great because I started using the excellent combination of TBDML, NoICE Debugger, and 68HC12. Now I thought I might add hc12mem for production, but can only see how to interface it with S12! NoICE proves that TBDML can properly communicate with my MC68HC912B32.


PIFP Register - BSet Error

Started by Stefan Loos in 68HC1214 years ago 2 replies

Hi I?m new to this group. I?m from Germany so please excuse mistakes in my english. We encountered a strange behaviour...

Hi I?m new to this group. I?m from Germany so please excuse mistakes in my english. We encountered a strange behaviour modifiing bitwise the PIFP Register. We use cosmic debugger. The PIFP adress is declared as 0x25f afair (16Bit ext. adress?) The


Reset and wrong value in eeprom

Started by Pascal in 68HC1211 years ago 7 replies

Hello, I write some values in the eeprom of 9s12dt128. Before doing a hard reset (power off) if i read the content at 0x800 it is...

Hello, I write some values in the eeprom of 9s12dt128. Before doing a hard reset (power off) if i read the content at 0x800 it is correct. I do the hard reset and i follow this code with the debugger : for(;;) { /* forever: initialize the program; call the root-procedure */ if (!(_startupData.flags&STARTUP_FLAGS_NOT_INIT_SP)) { /* initialize the stack pointer */ ...


No debug information

Started by Jonathan Masters in 68HC1213 years ago 4 replies

Has anyone a suggestion as to why after recently building a CodeWarrior project, the HIWARE debugger reports "Warning: No Debug...

Has anyone a suggestion as to why after recently building a CodeWarrior project, the HIWARE debugger reports "Warning: No Debug Information". The file loads, but no source debugging works. Short of making the project, I am unaware that I did anything to provoke this.


Flash Error

Started by sindhoor_hegde in 68HC1212 years ago 1 reply

Hi all, I am using PK-HCS12E128 development board and Codewarrior V3.1 evaluation version for developping a Virual EEPROM on the Flash. I am...

Hi all, I am using PK-HCS12E128 development board and Codewarrior V3.1 evaluation version for developping a Virual EEPROM on the Flash. I am facing a problem. Whenever i write in to the flash(i am using 0x5000 location)my debugger writes a single WORD in to the flash and then it halts. In the Command window i see "unknown event" followed by "halted". when i run the


HC12D60A, EEprom and Flash programming

Started by bitjockey1 in 68HC1215 years ago 2 replies

Hello, I am using CW to develop and app using the HC12D60A MCU. I have settings in EEprom that I don't want overwritten when...

Hello, I am using CW to develop and app using the HC12D60A MCU. I have settings in EEprom that I don't want overwritten when the debugger is started. I have the section declared as "NO_INIT" in my flash.prm file, but the EEprom still gets initialized to FF's on


eeprom erasure

Started by scott_roset in 68HC1215 years ago 1 reply

When I try to compile a program using codewarrior and a P&E board, I recieve this message, "The debugger is going to mass erase the...

When I try to compile a program using codewarrior and a P&E board, I recieve this message, "The debugger is going to mass erase the non volatile memory (eeprom and flash) of the current device, then program the application." I do not was to erase the eeprom. Does an


Using eeprom constants in CW

Started by jfrom90 in 68HC1214 years ago 3 replies

Hi, I use codewarrior v3.0 in my project (processor = HCS12 DG128). My intention is to map the eeprom to addresss 0x800. The...

Hi, I use codewarrior v3.0 in my project (processor = HCS12 DG128). My intention is to map the eeprom to addresss 0x800. The Hiwave-debugger uses the s-record fpp-file to support eeprom-writing (I believe) during program loading. In my case the fpp file CW12_V3.0\prog\FP


Introl compiler with TRACE32

Started by venki in 68HC1212 years ago

Hello all, I am using Introl compiler and working on HC912B32 micro.I want to use TRACE32 debugger ,I don't know what is the command to...

Hello all, I am using Introl compiler and working on HC912B32 micro.I want to use TRACE32 debugger ,I don't know what is the command to load the dbg file. Now I am using "Data.LOAD.Ubrof test.dbg" but while flashing it is giving error like" Inconsistency at near offset 80". Let me know if any body experienced the same problem and how they overcome this.=20 =20 Your help woul...


Timer Capture Interrupt Please Help

Started by scca...@yahoo.com in 68HC1211 years ago 2 replies

Hello, I\'ve been trying to figure this out for some time now and think I\'m having a little trouble with the concept in addition to some other...

Hello, I\'ve been trying to figure this out for some time now and think I\'m having a little trouble with the concept in addition to some other details. I\'m trying to get a timer capture interrupt working on my cards12 (mc9s12d64) using ICC12 and a NoIce Debugger. At this point, I\'m just trying to get the interrupt working and then eventually will want to time stamp a 5V pulse coming into th...


DG128 locks up after 1 second

Started by mstrbelvedere in 68HC1215 years ago 6 replies

Hello, My program for the 912DG128 chip (using P&E's Dev-Dg128 development board) runs fine if I am running P&E's ICD12Z...

Hello, My program for the 912DG128 chip (using P&E's Dev-Dg128 development board) runs fine if I am running P&E's ICD12Z debugger, but locks up after 1 second every time if I run the chip by itself. I've stripped a lot of code out, and have rearranged things, and find


Programming 68HC912B32 Flash

Started by alienprey2000 in 68HC1215 years ago 1 reply

I have some simple code which is runing fine through Cosmic's ZAP debugger. I believe that ZAP actually programs the onboard flash...

I have some simple code which is runing fine through Cosmic's ZAP debugger. I believe that ZAP actually programs the onboard flash so I assumed that after it was programmed I would be able to power down, remove the BDM interface, power back up and the chip would run the code (def