IRQ

Started by fidjouss in M68HC1117 years ago 1 reply

Hello I am trying to read the data from an external device ( assuming that it doesnt have its internal clock). I am using...

Hello I am trying to read the data from an external device ( assuming that it doesnt have its internal clock). I am using IRQ (IRQE set to 1 for edge sensitive to notify me to read the data.I am supposed to read 5 digits ( will use a delay of 1ms after each reading)to s


Loading Buffalo into NVRAM

Started by mtn_biker37 in M68HC1117 years ago 9 replies

Hello everyone, I have one of the old (but still useful) EVBU boards with a HC711E9 on it. I've interfaced a DS1230 (32K x...

Hello everyone, I have one of the old (but still useful) EVBU boards with a HC711E9 on it. I've interfaced a DS1230 (32K x 8) NVRAM for use in expanded mode. My question is how do I load the Buf34.s19 the NVRAM? I've already cleared the ROMON bit in the config register.


Config Register

Started by bal_gill21 in M68HC1117 years ago 5 replies

Hi all, Is EEPROM normally enabled or disabled in the CONFIG register?. It is bit zero (EEON), the manual just says its...

Hi all, Is EEPROM normally enabled or disabled in the CONFIG register?. It is bit zero (EEON), the manual just says its default erased state is EEPROM enabled. Thanks Bal


68HC11A1P vs 68HC11A1FN

Started by micro controller in M68HC1117 years ago 5 replies

Hi, Is the 68HC11A1P identical to the 68HCA1FN with only different packaging and possibly memory sizes ? Can someone...

Hi, Is the 68HC11A1P identical to the 68HCA1FN with only different packaging and possibly memory sizes ? Can someone point to where can I download the data sheet for the 68HC11A1FN chip ? Best Regards, Roger Tann


EEPROM write/erase

Started by bal_gill21 in M68HC1117 years ago 2 replies

Hi all, Can anyone tell me the actual delay times that are involved with writing to the 68hc711e9 EEPROM? Do you have to erase...

Hi all, Can anyone tell me the actual delay times that are involved with writing to the 68hc711e9 EEPROM? Do you have to erase the byte first then write it, or can it be overwritten by a new value? The manual suggests a write/erase time of 10ms, but it's not too clear if yo


Programming 68HC711E9

Started by n4hhe in M68HC1117 years ago 2 replies

I have 100 of the 711E9 mask described in http://www. freescale.com/files/microcontrollers/doc/errata/MSE711E9_4K81H.pdf ...

I have 100 of the 711E9 mask described in http://www. freescale.com/files/microcontrollers/doc/errata/MSE711E9_4K81H.pdf and all attempts to write code into the devices have failed. The


Downloading code into Microstamp11

Started by indrajeetak in M68HC1117 years ago 3 replies

Hi, I have a microstamp11 and use Imagecraft's ICC11 compiler and Microload for my software needs. Lately the following...

Hi, I have a microstamp11 and use Imagecraft's ICC11 compiler and Microload for my software needs. Lately the following phenomenon has been observed: I compile the code in ICC11 successfully. I then switch the microstamp11 over to write mode and download the


using optical encoder for feedback to MicroCore11

Started by ng seng lee in M68HC1117 years ago 9 replies

I am using an optical encoder from Omron (E6A-CW100) as feedback the motor speed to MicroCore11. I am using asm language. I do not...

I am using an optical encoder from Omron (E6A-CW100) as feedback the motor speed to MicroCore11. I am using asm language. I do not know where to start with. Anyone can help??? Thanks Regards Ivy __________________________________________________ ">


programming the CONFIG register

Started by Steve Tabler in M68HC1117 years ago 6 replies

I am attempting to program the CONFIG register in order to enable COP. My initial attempts I discovered were wrong because I was...

I am attempting to program the CONFIG register in order to enable COP. My initial attempts I discovered were wrong because I was attempting to follow a procedure for the wrong version of 68HC11, namely an A-series part. What I have is an E-series part: MC68HC11E1CFN2.


downloading my code onto 68hc11 (using buffalo Chip)

Started by spourk007 in M68HC1117 years ago 10 replies

Hi, I am having some problems downloading my code onto the adapt11 (68hc11) chip. I am using Hyper terminal, and I have my...

Hi, I am having some problems downloading my code onto the adapt11 (68hc11) chip. I am using Hyper terminal, and I have my code ORG b600. I am using the buffalo Chip. Here is what I am doing: Using Hyperterminal I set the Baud rate to 9600, Com 1, data bits 8,


Ask a Question to the EmbeddedRelated community

To significantly increase your chances of receiving answers, please make sure to:

  1. Use a meaningful title
  2. Express your question clearly and well
  3. Do not use this forum to promote your product, service or business
  4. Write in clear, grammatical, correctly-spelled language
  5. Do not post content that violates a copyright