LPC2368 UART1 vs. UART0 - 115k baud issue?

Started by goodgodgivemeanaliasalready in LPC200010 years ago 12 replies

Hi all, I am trying to get a simple pass thru of data at 115k from uart 1 to uart 0 on an lpc2368. Both are enabled (powered) and if I use...

Hi all, I am trying to get a simple pass thru of data at 115k from uart 1 to uart 0 on an lpc2368. Both are enabled (powered) and if I use 9600 baud rates, everything is fine. I'm running the unit off the 4MHz IRC. I then bumped uart0 up to 115k, had to switch the fractional baud rate settings. No problem, have 9600 baud message coming in UART1, shooting out UART0 at 115k. Then, I...


Re: LPC2101 hangs randomly

Started by prab...@yahoo.co.in in LPC200011 years ago

hi all, I am using LPC2101.From pase three months i am working in LPC. In this,after receiving RTC interval from serial port UART1(two...

hi all, I am using LPC2101.From pase three months i am working in LPC. In this,after receiving RTC interval from serial port UART1(two wire).I am putting LPC into power down mode and wakeup using RTC interval which is receiving through uart1. After wakeup from RTC set one GPIO for my application and wating for serial data(interval).Then put LPC to powerdown and wake up using RTC. After...


RTS/CTS hardware flow control on UART1 - LPC2000 Family

Started by Gazelle in LPC200014 years ago

Hello, Is someone aware of a code snippet dealing with hardware flow control on UART1 - I need to steer CTS/RTS hardware flow...

Hello, Is someone aware of a code snippet dealing with hardware flow control on UART1 - I need to steer CTS/RTS hardware flow control on an LPC2129/2138 device. Any code or useful pointers is welcome . Thanks, Michel


UART1 Hardware Flow Control -- LPC2138

Started by Debabrata Purohit in LPC200014 years ago

Hello, Is someone aware of a code snippet dealing with hardware flow control on UART1 - I need to run CTS/RTS hardware flow control on...

Hello, Is someone aware of a code snippet dealing with hardware flow control on UART1 - I need to run CTS/RTS hardware flow control on an LPC2138 device. Any code or useful pointers are welcome . Thanks, Debabrata ------------------------ Yahoo! Groups Sponsor --------------------~--> Check out the new improvements in Yahoo! Groups email. http://us.click.yahoo.com/6pRQfA/fOaOAA/


Setting UART1 RTS modem bit?

Started by skyspyco in LPC200014 years ago

Hi All, What is the correct method to toggle the RTS bit in UART1's U1MCR=20 register? I have tried: U1MCR &=3D ~UMCR_RTS; // sets RTS bit...

Hi All, What is the correct method to toggle the RTS bit in UART1's U1MCR=20 register? I have tried: U1MCR &=3D ~UMCR_RTS; // sets RTS bit to 0 and U1MCR |=3D UMCR_RTS; // sets RTS bit to 1 I have tried both setting P0.10 to a high output and not setting=20 P0.10 at all. In either case, I cannot change the RTS output state. I have been able to just declare P0.10 as a general ...


DCD signal force LPC2xxx go into Bootloader during reset

Started by misstero in LPC200014 years ago 11 replies

Dear All, I have design which is connected modem signals to UART1 (Full UART) of LPC2xxxx but I found serious problem with DCD signal. DCD...

Dear All, I have design which is connected modem signals to UART1 (Full UART) of LPC2xxxx but I found serious problem with DCD signal. DCD signal of UART1 is alternate function on P0.14 which is LPC2xxx bootloader determine during reset to go into Bootloader mode if it low. Our problem occur when modem connected that DCD is active (Active Low same as bootloader mode request) and LPC2xx...


Problem facing with UART0

Started by seena_ele in LPC200015 years ago 2 replies

hai all I am using UART1 for my application its working but i am having problems with UART0. does any body help me tnk in...

hai all I am using UART1 for my application its working but i am having problems with UART0. does any body help me tnk in advance


Regarding RF ID using LPC2129

Started by hari krishnan in LPC200011 years ago 5 replies

Hello Sir, Regarding RF ID i am not getting output from UART0 and UART1..... I have develop some coding.... but didnt get output in...

Hello Sir, Regarding RF ID i am not getting output from UART0 and UART1..... I have develop some coding.... but didnt get output in Hyperterminal (PC)... So Please give me some Idea to this project ... thank you.. -- With Regards, HARIKRISHNAN.R ------------------------------------


CAN and UART1 troubles

Started by gerhard_uttenthaler in LPC200015 years ago 3 replies

Hello! I am working on a project using the LPC2119. My main loop observes, whether a message has been received by the CAN interrupt...

Hello! I am working on a project using the LPC2119. My main loop observes, whether a message has been received by the CAN interrupt and if so, sends it on the other CAN channel. Now, if i put a: // wait for free UART while( (UART1_LSR & 0x60) == 0x00){;} // send a character UART1_THR = 0x32; into this


Re: No interrupt serviced for UART

Started by rudr...@yahoo.com in LPC200013 years ago

Hi, Can you provide me the code for clearing the cpsr register. I am using the lpc2294 board. Currently i am not getting the isr called for...

Hi, Can you provide me the code for clearing the cpsr register. I am using the lpc2294 board. Currently i am not getting the isr called for uart0. Regards, Rudresh N B > > > > Hello all, > > After trying to figur out what the heck is going on for over a day, I > decided to throw the question in this group. > > Just sending out a string through the UART1 of a LPC2


UART1 problem receiving but ok transmitt

Started by fredrikssonjohan in LPC200013 years ago 25 replies

Hi! I'm stucked with this and can't figure out why it will not work. Anyone seeing the obvious or have any friendly ideas of what might...

Hi! I'm stucked with this and can't figure out why it will not work. Anyone seeing the obvious or have any friendly ideas of what might be wrong? OK. I'll try to give an as good description as possible of what I have and try do. The first problem is that if I send, as a test, 8 "A" I will get 4 or 5 "A"s in return and then one or two non ascii visible chars and mostly a FF as end. I wou...


AutoBaud

Started by Bruce Paterson in LPC200011 years ago 1 reply

Hi, I know this topic has been mentioned a couple of times, but I can't recall an outcome. Anyway, I'm trying to get autobauding going...

Hi, I know this topic has been mentioned a couple of times, but I can't recall an outcome. Anyway, I'm trying to get autobauding going on an lpc2468 Uart1 I am using the fractional divider too (it's also a USB app), but the manual implies that's all OK, and it uses the prescaled PCLK for it's autobauding rather than the raw value. In my case the prescaler is effectively 0.737, and...


No interrupt serviced for UART

Started by didier_edna in LPC200015 years ago 2 replies

Hello all, After trying to figur out what the heck is going on for over a day, I decided to throw the question in this...

Hello all, After trying to figur out what the heck is going on for over a day, I decided to throw the question in this group. Just sending out a string through the UART1 of a LPC2294 is not working. Hope someone can give me the obvious solution to our pr


More on my UART woes on the LPC2106

Started by Shawn Hunt in LPC200012 years ago 3 replies

One would really think that I would have figured this out by now but I am still stuck. I am just trying to output what I receive on UART0...

One would really think that I would have figured this out by now but I am still stuck. I am just trying to output what I receive on UART0 to UART1 (hooked up to the COM port of another PC) but I end up getting mostly frame errors. The LPC2106 board has a 14.7456 crystal in it. Here is my latest function to initialize both UARTs at 9600 8N1, if anyone has any suggestions as to what I am d...


LPC213x UART1 RX/TX buffer

Started by jlowryspectrum in LPC200015 years ago 1 reply

Anyone know if I turn off the FIFO (U1FCR bit 0 = 0) will I still get interrupts (if enabled) when a single character is...

Anyone know if I turn off the FIFO (U1FCR bit 0 = 0) will I still get interrupts (if enabled) when a single character is received? Or does turning off the FIFO disable receiving and transmitting altogether? Thanks, Jeff.


UART interrupt example programs

Started by aravindar_manikandan in LPC200015 years ago 1 reply

hi, i am in need of UART0/UART1 interrupt example programs. thanks in advance, mani ...

hi, i am in need of UART0/UART1 interrupt example programs. thanks in advance, mani


LPC2214: UART1 (DTR, CTS, DSR, ...)

Started by skymab in LPC200015 years ago 2 replies

Hi, is it possible just to use RDX1 and TDX1 (like UART0) without the additional signals like DTR, CTS, DSR and so on ... ? Because I...

Hi, is it possible just to use RDX1 and TDX1 (like UART0) without the additional signals like DTR, CTS, DSR and so on ... ? Because I need the I/O pins which are occupied by these control lines for other things. Thomas


pb with rs485

Started by sebfr74 in LPC200015 years ago 3 replies

Hi, I use UART1 to make a rs485 with GPIO0.10 for the direction. I've got a problem, when I look the transmission with an oscilloscope ...

Hi, I use UART1 to make a rs485 with GPIO0.10 for the direction. I've got a problem, when I look the transmission with an oscilloscope the sens go to level 0 just before the last character. I do this : ("p" is a pointer to the string to transfer and "n" the number of characters) do{ while (!(U1LSR & 0x20)) watchd


How do interrupts work?

Started by Guillermo Prandi in LPC200014 years ago 6 replies

Hi! I read every doc I've found and I couldn't get a detailed description of the interrupt mechanism in the LPC2XXX. In particular, I'm...

Hi! I read every doc I've found and I couldn't get a detailed description of the interrupt mechanism in the LPC2XXX. In particular, I'm looking for the following: - What happens to interrupts while they're disabled? Do they get "cached"? I mean, if I'm in the middle of processing a UART0 interrupt and UART1 receives a new character, I'd proba


Interrupt pending but not raised

Started by andersryl in LPC200014 years ago 4 replies

Hi, I have a very peculiar problem regarding interrupts on my Olimex E2214 board (using gcc and gld with Eclipse). I'm trying to...

Hi, I have a very peculiar problem regarding interrupts on my Olimex E2214 board (using gcc and gld with Eclipse). I'm trying to get my board to communicate with a Windows application using the UART1. The way it works is that the Win app sends frames with commands to the test board to which the ARM responds by sending a new frame back to t