Re: IAR - EW430 4.10A Released Today

Started by waldemar in MSP43012 years ago 1 reply
IAR

Ian Okey schrieb: > On the IAR site it says : > > Available Versions > Product: IAR Embedded Workbench for Texas Instruments MSP 430 > ...

Ian Okey schrieb: > On the IAR site it says : > > Available Versions > Product: IAR Embedded Workbench for Texas Instruments MSP 430 > Version number Release date > 4.10A (Information only) No data > 3.42A * Dec 13, 2006 > 3.41A Apr 20, 2006 > Ian > Hi Ian, I dunno where you read this but I just downloaded the newest version of Kickstart IAR and it says


Silly IAR

Started by Anonymous in MSP43014 years ago 4 replies
IAR

Silly IAR... I am attempting to install Kick Start on a dedicated PC and it insists to mount the FET USB drivers on com3: In my book, this is...

Silly IAR... I am attempting to install Kick Start on a dedicated PC and it insists to mount the FET USB drivers on com3: In my book, this is bellow mediocrity :( After 45minutes, I am ready to drop IAR like a rock! Alex


IAR again. It never ends!

Started by bumerang boom in MSP43013 years ago 17 replies
IAR

I have some functions that are called by pointers hard initialized to a specific address. The IAR tools (3.21) insist to delete these functions...

I have some functions that are called by pointers hard initialized to a specific address. The IAR tools (3.21) insist to delete these functions as it considers them as UNUSED. The optimizer is completely turned off by selecting NONE in the respective window. How can I turn off this IAR "feature" ? I want to be able to compile and link code that is considered wrongly by the tool as un...


IAR v1.26 to 4.11 conversion! * yikes *

Started by Darren Logan in MSP43011 years ago 2 replies

Howdy folks, I need to convert an msp430 IAR v1.26 project to a IAR v4.11 project and i'm struggling to get it to run. :'-( Using the...

Howdy folks, I need to convert an msp430 IAR v1.26 project to a IAR v4.11 project and i'm struggling to get it to run. :'-( Using the migration guide, I've done the obvious of converting the interrupt syntax, but apart from that I'm not sure what else to change. I've got it to compile in v4.11, and i've uploaded it to the F149 target... but it doesn't run properly. When I step th...


IAR compiler problem

Started by kinghogar in MSP43015 years ago 1 reply

Hello, I am using IAR 3.20A evaluation version and when I run linker I get an error: IAR Universal Linker V4.59A/386 Copyright...

Hello, I am using IAR 3.20A evaluation version and when I run linker I get an error: IAR Universal Linker V4.59A/386 Copyright 1987-2004 IAR Systems. All rights reserved. Error[e16]: Segment DATA16_Z (size: 0x14b0 align: 0x1) is too long for segment definition. At least 0xcaf more bytes needed. The problem occurred while processing the segment placement command "-Z(DATA)


IAR complains of parallel port in use

Started by hc08jb8 in MSP43015 years ago 3 replies
IAR

Hello I am using IAR 3.0 with Olimex JTAG, after I have ended a debug session, if I start a new one, it keeps complaining that the port is...

Hello I am using IAR 3.0 with Olimex JTAG, after I have ended a debug session, if I start a new one, it keeps complaining that the port is in use by another program, after trying two times, it goes into debug ok. I have made sure that no printer or other proggies are sharing or using the LPT1, btw this is on a Win2000 system. I tried the latest IAR 3.2 (4.0???) downloaded from ti's sit


Re: Baffled by CCE

Started by Grant Edwards in MSP43011 years ago
IAR

On 2007-11-06, Ken Rowberry wrote: > IAR EW crashes on me all the time. I called IAR tech support > and found them to be astonishingly...

On 2007-11-06, Ken Rowberry wrote: > IAR EW crashes on me all the time. I called IAR tech support > and found them to be astonishingly useless. I presume that all > my support contract gives me is access to the latest IAR bugs, > etc. Though EW crashed on me, at least I was able to figure out how to tell it what I wanted to do (it just couldn't do it). With CCE I could


sendUart

Started by caigin1 in MSP43014 years ago 1 reply

Hello, I am developping an application with IAR Embedded Workbench IDE. My MSP430F1611 must communicate on the UART interface with my...

Hello, I am developping an application with IAR Embedded Workbench IDE. My MSP430F1611 must communicate on the UART interface with my computer. I encounter a lot of problems to only transmit a char or a string. In fact, nothing goes out my MSP430. It is very strange because printf() works if I build and load the application with MSPGCC, but not with IAR...With IAR, the output chars or s


how to veirfy download in iar

Started by thisistausif in MSP43012 years ago 1 reply

i am using parallel port fet tool and iar workbench for programing msp430f133 , on project> > debug it downloads the program but it shows...

i am using parallel port fet tool and iar workbench for programing msp430f133 , on project> > debug it downloads the program but it shows garbage value after the process in the same iar memory window(flash) but the led(on the msp-ts430pm64) board doesnot blinks how can i verify that the program is properly transferred?


Issue with building Flash Monitor with latest IAR-Kickstart?

Started by John Porubek in MSP43010 years ago 9 replies

Hello, I'm having problems getting the Flash Monitor from the TI appnote slaa341 (which was built with IAR Embedded Workbench Version:...

Hello, I'm having problems getting the Flash Monitor from the TI appnote slaa341 (which was built with IAR Embedded Workbench Version: 3.41A) working using the latest IAR-Kickstart downloaded from the TI website (slac050t.zip IAR-Kickstart v 5.13 7/25/2008) in December. The program assembles OK and can be downloaded to my target system - the Softbaugh DLR169 board (which the appnote sof...


Can IAR support Serial Communication??

Started by "sachin .b . rathod" in MSP43012 years ago 9 replies

Hello , Can anyone work with IAR Kickstart v3.41a?? I have one simple question. Can IAR Embedded Workbench support Serial...

Hello , Can anyone work with IAR Kickstart v3.41a?? I have one simple question. Can IAR Embedded Workbench support Serial Communication UART via BSL?? --------------------------------- Here?s a new way to find what you're looking for - Yahoo! Answers


IAR Printf() usage.

Started by bharat in MSP43014 years ago 2 replies

Dear IAR people, I am using IAR embedded workbench for MSP430 Ver3.3. I am using printf() function to debug my MSP430 code. But I was unable...

Dear IAR people, I am using IAR embedded workbench for MSP430 Ver3.3. I am using printf() function to debug my MSP430 code. But I was unable to see the output on any of debug windows like, Log..etc. Does IAR workbench supports printf function ? or there any alternate method to see the debug messages ?. Regards, Bharat.


IAR, Embedded Workbench

Started by wish_akuze wish_akuze in MSP43013 years ago 3 replies
IAR

Hello I would like to ask, how do you pronounce "IAR" ? do you spell all these letters or it sounds more like "ear". Sorry if this...

Hello I would like to ask, how do you pronounce "IAR" ? do you spell all these letters or it sounds more like "ear". Sorry if this question is too stupid but i hope someone can give me an answer at least! By the way does IAR stand for "Interactive Agent Reporting "? thanks --------------------------------- Yahoo! Mail Use Photomail to share ph


Testing PORRSTIFG with IAR debugger

Started by Andy Busa in MSP43010 years ago 1 reply
IAR

I have some MSP430 code that will only run when the PORIFG or RSTIFG bit is set. How can I use the IAR debugger to create this condition? ...

I have some MSP430 code that will only run when the PORIFG or RSTIFG bit is set. How can I use the IAR debugger to create this condition? Whenever I use the reset icon on the IAR, neither the PORIFG nor the RSTIFG bits are set. The code just returns to the beginning. What steps can I follow with the IAR debugger to create this POR/RST condition? Andy -----------------------------...


New to IAR and MSP430, need help

Started by tpicker12003 in MSP43013 years ago 2 replies

I am new to using the MSP430/IAR and needed help getting started. I have IAR and SoftBaugh's USBP as well as the BLDAC2 board and D4270...

I am new to using the MSP430/IAR and needed help getting started. I have IAR and SoftBaugh's USBP as well as the BLDAC2 board and D4270 (Altimeter Board). I am having trouble getting anywhere it seems talking to the boards. I have probably set something somewhere now. The driver for USBP is loaded and working as well. I just need someone to walk me through the proper setting and the sim


Re: IAR XCAP definitions!?

Started by kels...@yahoo.co.uk in MSP4308 years ago 1 reply
IAR

Hi there I got the same doubt. Did you solve this issue? By the way, how did you calculate the correct value? Thanks in...

Hi there I got the same doubt. Did you solve this issue? By the way, how did you calculate the correct value? Thanks in advance Kelson Hi all, > > Re. device: MSP430FG4618. > > I've noticed that the IAR XCAP definitions are different to that of the T.I. data sheet. > > IAR's header file contains: > > #define XCAP0PF (0x00) /* XIN Cap = XOUT Cap


IAR: MSP430F21x1 flash erase

Started by reym...@... in MSP43013 years ago 2 replies

Dear all, Once more a problem with IAR's latest environment Setup: MSP430F21x1 / MSP-FET430UIF / IAR EW 3.40A...

Dear all, Once more a problem with IAR's latest environment Setup: MSP430F21x1 / MSP-FET430UIF / IAR EW 3.40A professional Intention: I want to initialize the information flash like this: *.c -> const char xyz[] @ 0x1000 = 1,2,3,4 ; *.txt -> @1000 01 02 03 04 This is just to check, if the compiler and linker did everything as intended, of course I'm not using this file for


Re: porting GCC to IAR

Started by Anders Lindgren in MSP43011 years ago 6 replies

franciscocantero1 wrote: > Hello, > > Thanks for the help to my previous post("function allocation"). > Now i have another task to...

franciscocantero1 wrote: > Hello, > > Thanks for the help to my previous post("function allocation"). > Now i have another task to complete, porting code from GCC to IAR. > > I have done most of the porting, but i have i difficulties with the > standard library i/o. In GCC there is a routine "uprintf()" to print > characters to a file. There is something similar in IAR, i tried to > bui


IAR workspace opening wrong files - bug?

Started by Aaron Greer in MSP43011 years ago 16 replies
IAR

I've discovered what may be a bug in IAR. Here is what I did: Closed my current workspace in IAR (after making sure everything was...

I've discovered what may be a bug in IAR. Here is what I did: Closed my current workspace in IAR (after making sure everything was saved). Went to Windows explorer and made a copy of the folder containing my workspace. Went back to IAR, clicked file-> open-> workspace, selected the workspace in the new folder (which is a copy of my original workspace), clicked open. The workspace opened in IA


IAR Release mode

Started by n_srinivasaraju in MSP43014 years ago 2 replies

Hello i have written an application(size is 12k,MSP430149,) using IAR C compiler (FULL VERSION),which is working fine when programmed via...

Hello i have written an application(size is 12k,MSP430149,) using IAR C compiler (FULL VERSION),which is working fine when programmed via JTAG (IAR Debug mode).But if i compile the project in IAR release Mode and program the chip via Ti Serial Programmer, the device is working fine at Serialport and display routines and hanging at keyboard and other routines. if i program a 4k size