Re: Launchpad clock jitter: What should I expect?

Started by "Nea...@gmail.com [msp430]" in MSP4303 years ago 1 reply

Is there a florescent light somewhere close to the scope/workbench? Those and cheaper LED lights have a bad habit of inducing nasty EMI...

Is there a florescent light somewhere close to the scope/workbench? Those and cheaper LED lights have a bad habit of inducing nasty EMI in unsuspecting circuits, scope leads, etc. Best regards, Neal


Hi All

Started by shrihari_u in MSP4309 years ago 3 replies
LED

I am just a beginner to Embedded system domain and have huge interest in it and have EZ430F2013 Development tool and MSP430F2013 uC and...

I am just a beginner to Embedded system domain and have huge interest in it and have EZ430F2013 Development tool and MSP430F2013 uC and have started programming it using simple programs for glowing the Led, and have no idea [:-/] wat to do further and will be really grateful if any of you can guide me how to proceed next with some tutorials files which will be really helpful [:)] Rega...


a problem with the temperatureRecorder

Started by Damien Jeannerat in MSP43010 years ago

Hello, I just installed the ez4430F2013 and the IAR and the flashing led demo works! But then I opened to the temperatureRecorder (another...

Hello, I just installed the ez4430F2013 and the IAR and the flashing led demo works! But then I opened to the temperatureRecorder (another classic) but it was programmed on an old version which opens OK (after to soft say it will make copies ....) But when I "debug" it is supposed to upload the compiled stuff to the F2013, but after a few second, the debugger goes through the old le...


Powering CC2500 from a GPIO from F2274?

Started by abufadel in MSP43010 years ago 3 replies
LED

Apologies if this is the same post twice. I am not sure if the first one went through.. Greetings, I was experimenting with the...

Apologies if this is the same post twice. I am not sure if the first one went through.. Greetings, I was experimenting with the EZ430-RF2500 board to try to figure out how to reduce the power consumption. My first try was not to use the CC2500 at all and only toggle the LED with the push button. I put the MSP in LPM4 just like the msp430x22x4_p1_04.c does with interrupts enabled on p...


ez430F2013 help

Started by Hithesh in MSP4308 years ago
LED

I just got started with the ez430F2013. I executed the flashing LED example successfully. But when I build my own project, I don't see the...

I just got started with the ez430F2013. I executed the flashing LED example successfully. But when I build my own project, I don't see the "CspyBiWire" option in the workspace. All I get is either Debug or Release. I made sure, I selected "FET Debugger" in the project options menu. Any help? ------------------------------------


led basic

Started by msp430 nascimento in MSP43011 years ago 12 replies

Of course that this is original code ..haha.. My problem with this code is that, subroutine don`t work. I`m using EZ_msp msp430f2013 kit. I`m...

Of course that this is original code ..haha.. My problem with this code is that, subroutine don`t work. I`m using EZ_msp msp430f2013 kit. I`m learning to programmer this kind of microcontroller now. I have the following code: ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++++++++++++++ // compiler IAR #include "msp430x20x3.h" void delay


Timing problem

Started by Claro Louie in MSP43010 years ago 3 replies
LED

hi guys..... can anybody tell me what is the effective way on how to set the rate of anoutput ....like for example blinking the LED light...

hi guys..... can anybody tell me what is the effective way on how to set the rate of anoutput ....like for example blinking the LED light at an accurate blink rate of 1 per 100ms? replies will be GREATLY appreciated...im using MSP430F2234 thank you in advance... best regards --------------------------------- Fussy? Opinionated? Impossible to please? Perfect. Join Yahoo!'s user ...


Re: calculating time between 2 events

Started by One Stone in MSP43010 years ago

Oh look, bce, we have a message from a transistor. I just hope that 5_17 isn't your date of birth, I'd hate to share it with another...

Oh look, bce, we have a message from a transistor. I just hope that 5_17 isn't your date of birth, I'd hate to share it with another idiot! Al bce5_17 wrote: > Hi all > can u give me the code for calculating the time between 2 LED blinking > and then displaying it on LCD. >


I2C bus 2013

Started by ronaldsorrell2005 in MSP4309 years ago
LED

I have finaly got some parts to work using the slaa368 example from TI web site. the master led is flashing while waiting on an ack or nack....

I have finaly got some parts to work using the slaa368 example from TI web site. the master led is flashing while waiting on an ack or nack. how ever it never gets to do anything else. either it is hung up there or the slave is not answering? I do not know which. in the material from slaa368 notes, it says to make sure the slave is initiated, what does this mean exactly? thank you ...


CC2420 never stabilize(?)

Started by adamouhabou in MSP4306 years ago 3 replies

I have been trying to execute a TI example on the tmote sky. The routine is just supposed to make a led blink whenever the crystal is...

I have been trying to execute a TI example on the tmote sky. The routine is just supposed to make a led blink whenever the crystal is st= able.=20 But, it get stuck at the "crystal stabilization" condition, which is appare= ntly never verified.=20 Could someone help me find out what is wrong in my code please. Thanks! Here it is: int main(void) {=20 WDTCTL =3D WDTPW + WDTHOLD; ...


newbie here. help needed in msp430fg4618.

Started by joeqoo89 in MSP4306 years ago 13 replies

hey guys. i'm new in msp430fg4618. can anyone mind teach me how to start using this microcontroller cause i'm having a final year project which...

hey guys. i'm new in msp430fg4618. can anyone mind teach me how to start using this microcontroller cause i'm having a final year project which uses this microcontroller. i'm currently using the IAR embedded workbench. If i want to use the microcontroller to light an LED in a breadboard, what should i do ? sorry. i'm really very new to this. please give me some help. thanks in advance. -- ...


Student question

Started by idiotequaneering in MSP43010 years ago 2 replies
LED

First off, I apologize for asking a newbie question. But if anyone can, I am tryting to initialize timer A for a "Flashing the LED with...

First off, I apologize for asking a newbie question. But if anyone can, I am tryting to initialize timer A for a "Flashing the LED with interrupts" program. How do I initialize it? If anyone can give me any tips or where I should look online... I cannot seem to get what I need from the User's manual. This is what I tried so far, but of course initializing Timer A should be more than o...


Malfunctioning RX pin?

Started by dhanyarangaraj in MSP43010 years ago 4 replies

Hello, I am using an MSP430F169, which (up til yesterday) was working fine. I set it up to take samples and pass the data through the UART to...

Hello, I am using an MSP430F169, which (up til yesterday) was working fine. I set it up to take samples and pass the data through the UART to an IR transceiver. Furthermore, I call some different functions when I send the uC certain characters from a PC(ie stop sampling, turn on LED etc). The board still samples and transmits perfectly. However, for some reason it can no longer receive any...


Beginner with a few questions

Started by Andrew in MSP4305 years ago 2 replies

Hey everybody, About two weeks ago I started making a serious effort to learn to use the MSP430 Launchpad (with MSP430F2012). I have no prior...

Hey everybody, About two weeks ago I started making a serious effort to learn to use the MSP430 Launchpad (with MSP430F2012). I have no prior experience coding in C or C++, so I wanted to describe what I've learned, and get some feedback, just to make sure I understand everything correctly. In the "blink your first LED" tutorial there is the following piece of code: P1DIR |= 0x01; It explai...


Help regarding programming msp430f2013

Started by vaibhav_jiit in MSP4307 years ago 1 reply
LED

Hi I am a newbee to programming msp430 I want to write code to turn on the led for 10 minutes when it has hi/lo or lo/high edge at...

Hi I am a newbee to programming msp430 I want to write code to turn on the led for 10 minutes when it has hi/lo or lo/high edge at one of its input pins. Please help I am currently going through existing code examples to understand the programming but any kind of help will give me a headstart I am using the usb ez430f2013 ------------------------------------


Re: Multiple port pin / pushbutton interrupts

Started by Paul Curtis in MSP43013 years ago
LED

Hi, > Can someone shed some light on why this code is broke, I > followed the users guide but I must be missing something. > I am working...

Hi, > Can someone shed some light on why this code is broke, I > followed the users guide but I must be missing something. > I am working with the MSP430F1232. > Port P2.1 seems to work, I do hit the interrupt for both P2.1 and > P2.4 when both bottons are pushed but never enter the code > below to turn on the LED. I am using CrossStudio. > > -- Thanks.. >


MSP430 DC-DC converter

Started by Martijn Broens in MSP43011 years ago 2 replies

Hi All, i was wondering if anyone could point me to some appnotes on how to use an msp as a dc/dc stepup converter? For an automotive...

Hi All, i was wondering if anyone could point me to some appnotes on how to use an msp as a dc/dc stepup converter? For an automotive application i'm looking into, i need an mcu to swich some i/o and to flash some high bright LED's (700mA, 6.8V) there fore i need to boost my main voltage from 8V < Vin


interfacing tmp175 (beginner)

Started by Bin Huy in MSP43010 years ago

Hi, Below is the code to interface with the tmp175 that I've got from TI website. I have run it and seen the LED was On with temperature > ...

Hi, Below is the code to interface with the tmp175 that I've got from TI website. I have run it and seen the LED was On with temperature > 28C so I assume everything is working fine. Anyone know how to monitor the exact temperature from this ? Is this code sufficient ? Thanks //****************************************************************************** // MSP-FET430P140 Demo - SM


iHex format

Started by Martijn Broens in MSP43014 years ago 2 replies
LED

Hi all, A small question about a .hex file format. I've generated the .hex of the fet example that toggles the led. It gave me the following...

Hi all, A small question about a .hex file format. I've generated the .hex of the fet example that toggles the led. It gave me the following output.: /* Fet140_1.hex : 10 1100 00 B240805A2001D2D32200D2E321003C40 D9 : 10 1110 00 50C33C53FE23F93F3140000AB0125E11 28 : 10 1120 00 0C9318243C4000020E4330120000B012 11 : 10 1130 00 80113


Frustrations with Kickstart

Started by Joerg Schulze-Clewing in MSP43013 years ago 19 replies

Hello All, Here I am, a hardware guy whose uC exposure has pretty much been C51 and very little firmware. So, I loaded the latest IAR...

Hello All, Here I am, a hardware guy whose uC exposure has pretty much been C51 and very little firmware. So, I loaded the latest IAR Kickstart, got the TI USB programmer and soldered together a board with an Olimex F1232 header on there. The 32kHz oscillator runs and all but here is where it gets frustrating. Even flashing an LED on P1.0 using the FET_example work space won't do it. I me