Need Help Urgently - Mysterious Problem after adding Function

Started by Roger_4U in Piclist11 years ago 4 replies

Hi Folks: I am up a creek, I have been working on some code for over a year and I am totally stumped with this last problem: Device: ...

Hi Folks: I am up a creek, I have been working on some code for over a year and I am totally stumped with this last problem: Device: Pic16F88 Chip OSC: 20Mhz Programmer: MeLabs USB Programmer Code is spread across two codepages. i.e Linker is being used. Number of Software Modules: 4 [3 in CodePage0 and 1 in CodePage1] Assembler/Complier: MPLAB IDE v8.00 Serial speed: 57.6Kbps M...


PIC assembler delay

Started by Matti Laevaert in Piclist15 years ago 4 replies

Hello, I experience some problems with a usual PIC-delay, written in assembler (with MPLAB IDE). I try to make a simple...

Hello, I experience some problems with a usual PIC-delay, written in assembler (with MPLAB IDE). I try to make a simple program wich toggles pin RA0. The program listed bellow is for a period(!) of +/- 6,5ms (but actually it doesn't mather I guess). When I connect my


16F628(A) at 16 MHz and TMR0 problem

Started by Wolfgang in Piclist13 years ago 3 replies

Hi, i am using "PIC Simulator IDE" from OshonSoft to compile and assemble my code for the 16F628. All is working fine. But I have got the...

Hi, i am using "PIC Simulator IDE" from OshonSoft to compile and assemble my code for the 16F628. All is working fine. But I have got the problem, that when I want to have i.e. 50 Hz frequency output to one pin on port a, i never get the result I am expecting. I compute like this : clock frequency is 16 Mhz, so internal clock is 4MHz. If I


High Level Languages for PIC

Started by Allan Lane in Piclist14 years ago 5 replies

Recently, on another group, someone asked about compatible languages for PIC processors. Here are some nice resources. ...

Recently, on another group, someone asked about compatible languages for PIC processors. Here are some nice resources. www.BasicMicro.com -- Maker of the Atom, a mostly Stamp compatible PIC platform. Very nice debugger built into their IDE. Very nice target board


mcc18 demo...got it sorted...norton system works corrupted files

Started by shaunundergrad in Piclist15 years ago 1 reply

hi guys, my previous problem resolved.....i've had this problem in the past with norton system works corrupting mplab ide...does...

hi guys, my previous problem resolved.....i've had this problem in the past with norton system works corrupting mplab ide...does anybody know y it does this or how to stop it. the only way i've found to work is to delete then reload mplab, but this is tedious, but at the same time


Any "Gotcha's" to look for when getting started?

Started by tom_bihn in Piclist15 years ago 5 replies

I'm just introducing myself to programming a PIC and plan on using MPASM. I have downloaded MPLAB IDE, purchased the EPIC...

I'm just introducing myself to programming a PIC and plan on using MPASM. I have downloaded MPLAB IDE, purchased the EPIC programmer, purchased "PIC - A personal Introductory Course" a book by John Morton, downloaded the Mid-Range MPU Reference Manual from Microchip and


PIC16F84A and "This device requires firmware version 2.1.0 or higher" message

Started by Jason Hsu in Piclist14 years ago 21 replies

I'm new to the world of microcontrollers, so bear with me. I'm trying to program a PIC1684A with my new PICSTART PLUS programmer ...

I'm new to the world of microcontrollers, so bear with me. I'm trying to program a PIC1684A with my new PICSTART PLUS programmer and MPLAB IDE v6.40 software. I have selected the PIC16F84A under Configure -> Select Device and PICSTART PLUS under Programmer -> Select P


Warp 13 Bluepole 1.6f

Started by bergweed in Piclist13 years ago

Got the 18F252 PIC today, programmed the new bluepole 1.6f hex file with my programmer still at 4 Mhz running redback 11. Did it under...

Got the 18F252 PIC today, programmed the new bluepole 1.6f hex file with my programmer still at 4 Mhz running redback 11. Did it under MPLAB IDE 6.50 by just selecting device as 18F252, importing the bluepole hex file, then programming. Then changed clock resonater to 20 MHz, installed .1 uF bypass caps as per instructs and replaced old redback PIC16F873


mikroBASIC compiler

Started by Ike AMD in Piclist14 years ago 6 replies

Hi, My name is Isaac, I'm new at programming PIC Microcontrollers.  I have been programming in MPLAB? IDE

Hi, My name is Isaac, I'm new at programming PIC Microcontrollers.  I have been programming in MPLAB? IDE


ICD2 Busy and Hung

Started by scottmack1 in Piclist11 years ago

I am having some kind of problem with the communications to the ICD2. When I start MPLAB IDE v7.60 with the ICD2 plugged in my computer's USB...

I am having some kind of problem with the communications to the ICD2. When I start MPLAB IDE v7.60 with the ICD2 plugged in my computer's USB port and the ICD2 plugged into my pcb (PIC16F887), it connects OK, reads ICD Product ID, runs the ICD self test, passed, says MPLAB ICD2 Ready but continues to have the Busy led on the ICD2 blinking. If I click in the program window or around on ...


Wake Up On Key Stroke

Started by jmsmith871 in Piclist10 years ago 2 replies

Although I've been using PICs for years, I'm only now studying the SLEEP instruction and code to wake up the processor. It's not going well at...

Although I've been using PICs for years, I'm only now studying the SLEEP instruction and code to wake up the processor. It's not going well at the moment. Microchip's app note AN552, "Implementing Wake-up on Key Stroke," has sample code for a 16C71. I pasted the code into the MPLAB IDE, and it assembled without errors. A PICStart Plus programmed it into a 16C71 with no errors. However,...


Anyone have any thoughts on this low-cost IDE?

Started by oi2all in Piclist14 years ago 3 replies

http://www.oshonsoft.com/pic.htm Costs 19$ and has a simulator/basic compiler/assembler and there is a programmer...

http://www.oshonsoft.com/pic.htm Costs 19$ and has a simulator/basic compiler/assembler and there is a programmer w/schematic for a lpt port programmer on the site as well. Looks like a guy could get into pic programming on


UART

Started by wonghongyik in Piclist10 years ago

Hello everybody, I was trying to write a UART program to send out few bytes of data by using PIC16F877A, CCS C compiler, MPLAB IDE, MPLAB SIM....

Hello everybody, I was trying to write a UART program to send out few bytes of data by using PIC16F877A, CCS C compiler, MPLAB IDE, MPLAB SIM. The problem of my program is the code fail to transmit out the data to pin RC6 of Port C. So far i am just use MPLAB SIM to simulate my program and using Watch window to monitor all the register and symbol. To simulate the program i was pressing the...


Here's how to get CVS & CVSNT working in the MPLAB IDE

Started by Scott Stephens in Piclist13 years ago

Perhaps this will save someone an evening of frustration. MPLAB comes with little instruction on getting CVS working. Heres how I...

Perhaps this will save someone an evening of frustration. MPLAB comes with little instruction on getting CVS working. Heres how I did; Get CVS Gui from http://cvsgui.sourceforge.net. It comes with CVSNT; a windows 2k / NT server for CVS,


CC5x Integration

Started by Gaurish Kapoor in Piclist9 years ago

Hi! I have been trying to get the CC5x compiler to work with MPLAB, but unfortunately Im getting this error message: Clean: Deleting...

Hi! I have been trying to get the CC5x compiler to work with MPLAB, but unfortunately Im getting this error message: Clean: Deleting intermediary and output files. Clean: Done. Executing: "C:\Program Files\bknd\CC5X\CC5X.EXE" mmc.c -CC -fINHX8M -p16F876 -a -L -Q -V -FM +reloc.inc C:\Program Files\MPLAB IDE\cc++\"-a Error : Unable to open file 'reloc.inc' Error options: -ew: no warning ...


ICD2Clone dont work ??

Started by Luis in Piclist11 years ago 1 reply

hi all, I?m build the icd2clone, in WindowsXP it?s ok, but in MPLAB: MPLAB ICD 2 Ready Downloading Operating System Connecting to MPLAB ICD...

hi all, I?m build the icd2clone, in WindowsXP it?s ok, but in MPLAB: MPLAB ICD 2 Ready Downloading Operating System Connecting to MPLAB ICD 2 ...Connected ICDWarn0054: MPLAB IDE has lost communications with the MPLAB ICD 2. Would you like to attempt to reconnect? Connecting to MPLAB ICD 2 ...Connected ICD0082: Failed MPLAB ICD 2 operation ICD0082: Failed MPLAB ICD 2 operation ...Dow...


questions abt MPLAB

Started by Vibha Ravindran in Piclist15 years ago 4 replies

Hi!   I am a new user of MPLAB IDE v6.20 and I have some questions regarding the same.

Hi!   I am a new user of MPLAB IDE v6.20 and I have some questions regarding the same.