CCS C compiler

Started by onmyownja in Piclist13 years ago

I would like to use the CCS C compiler but I would like to know where I could get the full version. I have never used it...

I would like to use the CCS C compiler but I would like to know where I could get the full version. I have never used it before but I believe it could be used with MPLAB. If anyone know have a full version please postoremail me.


help pic12f675

Started by vaishnavi236 in Piclist14 years ago

hi, i am doing a project " micontroller based pwm swithching charge controller for solar photovoltaic system using...

hi, i am doing a project " micontroller based pwm swithching charge controller for solar photovoltaic system using pic12f675".problem is the ckt is ready but i find it difficult to programme it using mplab s/w since i am not well versed in s/w.so we need a program for


TRISA/B/C not changing for 16F72

Started by Jason Hsu in Piclist10 years ago 1 reply

I'm using MPLAB to simulate a 16F72. For some reason, TRISA, TRISB, and TRISC are not updating. The Watch window shows that they do not change...

I'm using MPLAB to simulate a 16F72. For some reason, TRISA, TRISB, and TRISC are not updating. The Watch window shows that they do not change at the moment they are supposed to. I think there's one little thing that I'm missing. What am I missing? Here's the code: list p=pic16f72 include "p16f72.inc" __config b'11111110111001' ;These are the same settings as those used by Bert ...


Reset on Halt or on Breakpoints

Started by scottmack1 in Piclist10 years ago

Guys, I am using a 16F887 with MPLAB 7.60 and a ICD 2. I need to continue coding on a project I worked on a while back. Jumping in and fixing...

Guys, I am using a 16F887 with MPLAB 7.60 and a ICD 2. I need to continue coding on a project I worked on a while back. Jumping in and fixing stuff I have managed to get into some kind of mess. The cpu seems to always reset to the beginning of the program when I halt it. I kind of figured this may be do to using the WDT & SLEEP combination, not sure, and that I have something wrong the...


Explain this INHX32 file

Started by Eirik Karlsen in Piclist14 years ago 2 replies

Can someone clarify a couple of issues about the hex-files produced by MPLAB... :02 0000 04 0000 FA :10 0000 00...

Can someone clarify a couple of issues about the hex-files produced by MPLAB... :02 0000 04 0000 FA :10 0000 00 20EF05F0FFFFFFFF0FEF00F01000FFFF F4 :10 0010 00 FFFFFFFFFFFFFFFF14EC0FF01000F0A0 49 :


MPLAB IDE Error message

Started by farroos in Piclist15 years ago 1 reply

i can not go resolve this error when I compile my code. I think that the error accured because of a hidden charachter on that...

i can not go resolve this error when I compile my code. I think that the error accured because of a hidden charachter on that line. I oppened the source file with 'vi' the unix editor and found no strange charechters. Please help. Error messages follows: Deleting int


MPLAB 6.3

Started by vk2zza in Piclist15 years ago 1 reply

I am getting error messages when compiling even thought the complie is successful. The messages relate to the I/O ports as...

I am getting error messages when compiling even thought the complie is successful. The messages relate to the I/O ports as follows:- bsf STATUS, RP0 movlw b'00010000' ; RA0..RA3 outputs movwf TRISA ; RA4 input Compiling this gives the message:


Address failed verified at 000h!

Started by kepsco in Piclist15 years ago 2 replies

ive just started to make my own pic 16f84a programmer and have just finished downloading mplab ide version 6.80 and ic-prog ver...

ive just started to make my own pic 16f84a programmer and have just finished downloading mplab ide version 6.80 and ic-prog ver 1.05c... however, after completing the programmer and making my first program, i got this message that didn't irrate me the first time but when i


16f628 bare necessities to run?

Started by dave in Piclist14 years ago 1 reply

I am new to pic programming, I am using MPLAB to assemble and compile the programs, then using micropro to send the data to the...

I am new to pic programming, I am using MPLAB to assemble and compile the programs, then using micropro to send the data to the chip via a usb k-128 board. I have tried using a 6MHz crystal and the internal oscillator but my program dosent seem to run unless I am physically touch


breakpoints within interrupts

Started by Naveen in Piclist15 years ago 2 replies

>Date: Wed, 26 Mar 2003 22:19:26 +0530 >To: "ben" <> >From: Naveen <> >Subject: breakpoints within interrupts > >Hi All, ...

>Date: Wed, 26 Mar 2003 22:19:26 +0530 >To: "ben" <> >From: Naveen <> >Subject: breakpoints within interrupts > >Hi All, >I'm using MPLAB v6.13 along with Hi-Tech PICC compiler v8.01 PL3. >I'm unable to set breakp


Error from PICstart:Cannot Transmit

Started by sandeep c p in Piclist13 years ago 1 reply

hi i can't enable picstart programmer. i got the message from the MPLAB v6.40 under PICStart saying that "Cannot Transmit....

hi i can't enable picstart programmer. i got the message from the MPLAB v6.40 under PICStart saying that "Cannot Transmit. Please verify connection and retry the previous operation." Once its accedently enabled then after its never. i tried every thing like bau


Parameters not passing correctly

Started by Basic Poke in Piclist10 years ago

I am writing a program for the PIC18F66J50, using MPLAB IDE v8.14 (also happened with 8.10). Suddenly I noticed one of my functions was not...

I am writing a program for the PIC18F66J50, using MPLAB IDE v8.14 (also happened with 8.10). Suddenly I noticed one of my functions was not working correctly, and discovered that inside the function the parameters that were passed in do not have the values that was used in the function call. I made a test function (see below) and the same thing happens. void main() { ... ServiceD...


MPLAB 6.3 again

Started by vk2zza in Piclist15 years ago 1 reply

Another error message: Message[305] D:\MCU\PICPROGS\COUNTER\LCD4CNTR.ASM 205 : Using default destination of 1 (file). ...

Another error message: Message[305] D:\MCU\PICPROGS\COUNTER\LCD4CNTR.ASM 205 : Using default destination of 1 (file). happens for these instructions: movlw 0x030 ; Command for 4-bit interface high nibble iorwf PORTB ; Send data to LCD I definitely need some


Need help with MC C18 Compiler

Started by Raul Lucientes in Piclist15 years ago

Hi everybody .... Im trying to compile (with Microchip C18 compiler) in my MPLAB 6.0 IDE an easy program for the PIC18F258...

Hi everybody .... Im trying to compile (with Microchip C18 compiler) in my MPLAB 6.0 IDE an easy program for the PIC18F258 target, also Im using the PICDEM 2 Plus board for testing my develop, My source code is compile without errros and also is linked correctly, once I progra


C18 compiler in MPLAB

Started by Vecheslav Silagadze in Piclist13 years ago 3 replies

I'm having a lot of issues with the C18 compiler. To say the least, it's acting very strange. Example1: I build a simple...

I'm having a lot of issues with the C18 compiler. To say the least, it's acting very strange. Example1: I build a simple (maybe 300 line) program. I run the debugger and by the looks of it the program counter jumps all over the place, inluding whitespace in between f


PIC24HJ64GP502 UARTs will not receive

Started by kabo...@NorthState.net in Piclist5 years ago 1 reply

I am attempting to establish serial communications with UART1 or 2=20 on a PIC24HJ64GP502. MPLAB IDE v8.76 and c30 v3.30.=20 I am using a...

I am attempting to establish serial communications with UART1 or 2=20 on a PIC24HJ64GP502. MPLAB IDE v8.76 and c30 v3.30.=20 I am using a MAX232 and serial-USB converter to a Win-7=20 PC running hyperterm (9600-N-8-1). If I pull the PIC and jumper=20 pins 21 and 22 together I get a proper echo on the PC, so the connectivity is good too/from the PIC. Current program does nothing but try t...


Hi Tech c enviroment help required

Started by tuurbo46 in Piclist13 years ago 1 reply

Hi Im just intergrating a version of hi-tech c into my mplab enviroment and this error keeps being shown when i make...

Hi Im just intergrating a version of hi-tech c into my mplab enviroment and this error keeps being shown when i make project. I have encluded the error below. Does anybody know what i have to do to my enviroment to correct this error? Building SMART.HEX.


IF ELSE ENDIF

Started by Emmanuel Gonzalez in Piclist15 years ago 1 reply

can we use "if else endif" in mplab... i tried the following code: IF ADRESH == B'00000010' GOTO JUMP ELSE GOTO CONTINUE ...

can we use "if else endif" in mplab... i tried the following code: IF ADRESH == B'00000010' GOTO JUMP ELSE GOTO CONTINUE ENDIF ...but the code doesnt work...do i have to declare something? --------------------------------


Newbie problems

Started by Anonymous in Piclist14 years ago 3 replies

I am new to PIC programming and am using Bojan's P16Pro Light software to program a 16F84 (with David Tait designed hardware) but I...

I am new to PIC programming and am using Bojan's P16Pro Light software to program a 16F84 (with David Tait designed hardware) but I get a Programming Failed Error 0 3000 3FFF. What does this error mean? I am using the Microchips MPLAB precompiler. My program is...........


problems with PIC12F675 GPIO

Started by ajellisuk in Piclist9 years ago 2 replies

Hi, I've just started a project using a PIC12F675. Just to get started I'm trying to drive all of the port pins high, but I'm having no...

Hi, I've just started a project using a PIC12F675. Just to get started I'm trying to drive all of the port pins high, but I'm having no success. I'm aware that the ports have multiple functions and need to be set up. I don't seem to have nay control over any of the pins. I'm using HI Tec PICC lite embedded into MPLAB 8.1. My code is: /* PIC 12F flash.c */ #include "pic12f6x.h" vo...