RCM6750 - Ethernet flooding issue?

Started by "Dav...@questcontrols.com [rabbit-semi]" in Rabbit-Semi1 year ago

Just got back into some RCM6750 based work and am sorting out a little problem. I noticed that when I had my board plugged into a hub, every...

Just got back into some RCM6750 based work and am sorting out a little problem. I noticed that when I had my board plugged into a hub, every now and then ethernet connectivity would go away. Board was running other stuff, but nothing was making it out of the stack. Diagnosing this now, and I isolated the device's ethernet connection to a PC, run a homemade icmp flood on it, and I can ...


SNMP on an RCM6k

Started by "see...@yahoo.com [rabbit-semi]" in Rabbit-Semi1 year ago 2 replies

I am trying to add SNMP to an RCM6750 application, and I'm using DC 10.72. When I compile I get three warnings about incompatible pointer...

I am trying to add SNMP to an RCM6750 application, and I'm using DC 10.72. When I compile I get three warnings about incompatible pointer types: line 2026: SNMP.LIB : Wrong type for parameter 2. line 2026: SNMP.lib : Converting long to incompatible pointer type __far void * There are two other sets of warning that are just the same at different places. The warning at line 2026 is regarding...


rabbit-semi@yahoogroups.com

Started by "mud...@yahoo.com [rabbit-semi]" in Rabbit-Semi1 year ago 7 replies

any one can help me in my project at rabbit BL2000(Measurement system for an oil storage tank).

any one can help me in my project at rabbit BL2000(Measurement system for an oil storage tank).


SMTP Email not working after calling http_handler()

Started by "mjm...@gmail.com [rabbit-semi]" in Rabbit-Semi2 years ago 2 replies

Good day, I have a web server application running quite successfully but now I need to add Email functionality. As a standalone I used the...

Good day, I have a web server application running quite successfully but now I need to add Email functionality. As a standalone I used the example SMTP.c and that works for me. However after including in my my web server app it fails if I call http_handler() before sending the email. The "Resolving" resolves my smtp server then I get "error opening socket..." Anyone with some solutions? ...


Detecting network connection

Started by "see...@yahoo.com [rabbit-semi]" in Rabbit-Semi2 years ago 3 replies

Tom, et.al, Some years ago we had an issue with Moxi switches where, when the Ethernet cable was disconnected and then reconnected, the...

Tom, et.al, Some years ago we had an issue with Moxi switches where, when the Ethernet cable was disconnected and then reconnected, the Rabbit would not detect the presence of the network so you couldn't communicate with it until you power-cycled the Rabbit. These are RCM3900s. This never happened with Netgear switches, which is what we use 98% of the time. At the time I submitted a tech ...


RCM3700

Started by "S S...@gmail.com [rabbit-semi]" in Rabbit-Semi2 years ago 4 replies

Hi guys, I'm have problem with RC3700. I use RC3700 and development board with DC9.25. I use ADC and serial flash together but ADC not...

Hi guys, I'm have problem with RC3700. I use RC3700 and development board with DC9.25. I use ADC and serial flash together but ADC not work. If serial flash disable, ADC run normally. After i'm check, PB0 use together for ADC on development board and serial flash on RC3700 for CLK. Can you give me pointer what i'm must doing ? Or maybe you have sample program like i'm doing ? Thank you v...


Maximum xml Data Size: RCM4300 DC10-72

Started by "mjm...@gmail.com [rabbit-semi]" in Rabbit-Semi2 years ago 3 replies

Good day, I would like to know what the size limitation for sending xml data is? I'm using XMLHttpRequest() to request the xml file. I have...

Good day, I would like to know what the size limitation for sending xml data is? I'm using XMLHttpRequest() to request the xml file. I have been through the documentation and can't seem to find any (MACROS) settings for this? I can successfully send a small number of characters in xml. But when I examine the packet sent (using Fiddler) from the RCM4300 I find that the data in the xml file...


TLS 1.2 for Dynamic C 10

Started by "Tom...@tomlogic.com [rabbit-semi]" in Rabbit-Semi2 years ago 4 replies

I've been working to update Dynamic C 10's TLS (the protocol formerly known as SSL) implementation from 1.0 to 1.2, and feel that it's ready for...

I've been working to update Dynamic C 10's TLS (the protocol formerly known as SSL) implementation from 1.0 to 1.2, and feel that it's ready for testing if anyone is interested. Modern web browsers will refuse to connect to Rabbit products with the TLS 1.0 implementation, hence the push to support 1.2. Along the way, I removed support for protocols and ciphers now considered insecure. I've pa...


Targetless data retained for this project differs from tcdata.ini entry.

Started by "rai...@ymail.com [rabbit-semi]" in Rabbit-Semi2 years ago

This starts to annoy me... Every time I'm starting the DC 10.72 I get the following dialog message. From the message it seems that tcdata.ini is...

This starts to annoy me... Every time I'm starting the DC 10.72 I get the following dialog message. From the message it seems that tcdata.ini is wrong (Base Frequency: 0) although I looked at it and it does contain "25.0000" for that entry. Anyone experiencing this? I'm using it in a Win7 32bit It's true that selecting either Yes or No doesn't seem to have eny effect, and everything is w...


XBee network discovery in API mode

Started by "rai...@ymail.com [rabbit-semi]" in Rabbit-Semi2 years ago 2 replies

Hi all, This is not directly rabbit related (yet)... since for the moment I'm playing with the xbee modules all connected on a windows pc...

Hi all, This is not directly rabbit related (yet)... since for the moment I'm playing with the xbee modules all connected on a windows pc though usb-serial adaptors. I want to play with them and see what's happening with my own eyes :) Then, I'll have some rabbit targets for them. All in all, I set up a network with 3 modules, one coordinator and 2 routers. Everything works very well (and I ...


Ask a Question to the EmbeddedRelated community

To significantly increase your chances of receiving answers, please make sure to:

  1. Use a meaningful title
  2. Express your question clearly and well
  3. Do not use this forum to promote your product, service or business
  4. Write in clear, grammatical, correctly-spelled language
  5. Do not post content that violates a copyright