Reply by Mark Norton March 2, 20062006-03-02
It turns out that my problem was with the CrossWorks
loader.  The code didn't have support for the LPC2131
and the default was another "geometry".  I added
support and all is good.  

On a side note, I tried upgrading the firmware and
driver for the j-link.  This caused me all sorts of
grief with CrossWorks.  I would get USB communication
failures, timeouts, ect...  I could unplug/disconnect
the j-link and say a little chant and it would work
for a bit and then quite.  As it turns out, the new
driver/firmware comes with a new dll.  Once I replaced
the dll in the CrossWorks bin directory, all is good
again.

--- Mark Norton <timothymarknorton@timo...> wrote:

> For a bit more info:
> 
> I have a demo board with a LPC2138 and the code will
> download to it just fine.  On my product which has a
> LPC2131 it won't.
> 
> --- arm7dude <arm7dude@arm7...> wrote:
> 
> > Mark
> > 
> > It's quite possible that you need to update you
> > JLink driver. The
> > current on is 3.12c. I've seen a lot of problems
> > downloading with the
> > older drivers. Hope this helps.
> > 
> > Ed
> > --- In lpc2000@lpc2...,
> "timothymarknorton"
> > <timothymarknorton@...> wrote:
> > >
> > > Hi All,
> > > 
> > > I am new to ARM and currently working on a
> design
> > that uses and 
> > > LPC2131.  I am using CrossStudio and having some
> > problems.  When I 
> > > start debugging it gives me Verification errors
> > after downloading.  I 
> > > am using a Seggar J-Link that came in an IAR
> > kickstart kick.  The 
> > > verification errors begin at 0x1000.  Anything
> > before that programs 
> > > just fine.  Any ideas?
> > > 
> > > 
> > > Mark
> > >
> > 
> > 
> > 
> > 
> > 
> 
> 
> __________________________________________________
>  
>
	__________________________________________________
 

An Engineer's Guide to the LPC2100 Series

Reply by Mark Norton March 1, 20062006-03-01
For a bit more info:

I have a demo board with a LPC2138 and the code will
download to it just fine.  On my product which has a
LPC2131 it won't.

--- arm7dude <arm7dude@arm7...> wrote:

> Mark
> 
> It's quite possible that you need to update you
> JLink driver. The
> current on is 3.12c. I've seen a lot of problems
> downloading with the
> older drivers. Hope this helps.
> 
> Ed
> --- In lpc2000@lpc2..., "timothymarknorton"
> <timothymarknorton@...> wrote:
> >
> > Hi All,
> > 
> > I am new to ARM and currently working on a design
> that uses and 
> > LPC2131.  I am using CrossStudio and having some
> problems.  When I 
> > start debugging it gives me Verification errors
> after downloading.  I 
> > am using a Seggar J-Link that came in an IAR
> kickstart kick.  The 
> > verification errors begin at 0x1000.  Anything
> before that programs 
> > just fine.  Any ideas?
> > 
> > 
> > Mark
> >
> 
> 
> 
> 
>
	__________________________________________________
 

Reply by arm7dude March 1, 20062006-03-01
Mark

It's quite possible that you need to update you JLink driver. The
current on is 3.12c. I've seen a lot of problems downloading with the
older drivers. Hope this helps.

Ed
--- In lpc2000@lpc2..., "timothymarknorton"
<timothymarknorton@...> wrote:
>
> Hi All,
> 
> I am new to ARM and currently working on a design that uses and 
> LPC2131.  I am using CrossStudio and having some problems.  When I 
> start debugging it gives me Verification errors after downloading.  I 
> am using a Seggar J-Link that came in an IAR kickstart kick.  The 
> verification errors begin at 0x1000.  Anything before that programs 
> just fine.  Any ideas?
> 
> 
> Mark
>
	
Reply by timothymarknorton March 1, 20062006-03-01
Hi All,

I am new to ARM and currently working on a design that uses and 
LPC2131.  I am using CrossStudio and having some problems.  When I 
start debugging it gives me Verification errors after downloading.  I 
am using a Seggar J-Link that came in an IAR kickstart kick.  The 
verification errors begin at 0x1000.  Anything before that programs 
just fine.  Any ideas?
	Mark