Re: Metrowerks/Hiwave/PE-USB Very Slow

Started by John Hartman NoICE September 20, 2005

>I use a combination of Metrowerks and PE-USB-ML Cable.
>Lately I have noticed that response to run/stop and reset when debugging
>are very slow. I think that this has been happening for a while but now
>it seems to happen at nearly every step.
>When I say slow, sometimes it takes 20-25 seconds for the debugger to
>stop my hardware!

I am not sure it is the same problem, but two NoICE users reported
something similar. That turned out to be a long delay in unloading part of
the P&E driver (when NoICE resets the target it may close and re-open the
driver).

Both users were able to get relief by downloading the latest drivers from
P&E and installing them. It doesn't seem to be the drivers themselves -
it's the install process that makes everything happy. Worth a try in any case.

Best regards, John Hartman
john@john...
NoICE Debugging Tools
http://www.noicedebugger.com


Although I have not noticed any difference in time taken to stop or
reset recently with my recently updated version of Cosmic Zap 3.80a,
those operations have always been slow. There used to be no difference
between the parallel and the USB BDM interfaces in this respect.
Unfortunately my installation on windows Xp is not satisfactory and I
cannot use the parallel BDM interface. Perhaps you also have an
installation problem with Xp?

Andrew Lohmann AMIIE
Design Engineer

PLEASE NOTE NEW EMAIL ADDRESS IS:
andrew.lohmann@andr...

Bellingham + Stanley Ltd.
Longfield Road, Tunbridge Wells, Kent, TN2 3EY, England.
Tel: +44 (0) 1892 500400
Fax: +44 (0) 1892 543115
Website: www.bs-ltd.com
John Hartman (NoICE) wrote:

>
> >I use a combination of Metrowerks and PE-USB-ML Cable.
> >Lately I have noticed that response to run/stop and reset when debugging
> >are very slow. I think that this has been happening for a while but now
> >it seems to happen at nearly every step.
> >When I say slow, sometimes it takes 20-25 seconds for the debugger to
> >stop my hardware!
>
> I am not sure it is the same problem, but two NoICE users reported
> something similar. That turned out to be a long delay in unloading
> part of
> the P&E driver (when NoICE resets the target it may close and re-open the
> driver).
>
> Both users were able to get relief by downloading the latest drivers from
> P&E and installing them. It doesn't seem to be the drivers themselves -
> it's the install process that makes everything happy. Worth a try in
> any case.
>
> Best regards, John Hartman
> john@john...
> NoICE Debugging Tools
> http://www.noicedebugger.com >
> >. >
>

-----------------------------Disclaimer-----------------------------

This communication contains information which is confidential and may also be privileged. It is for the exclusive use of the addressee. If you are not the addressee please note that any distribution, reproduction, copying, publication or use of this communication or the information is prohibited. If you have received this communication in error, please contact us immediately and also delete the communication from your computer. We accept no liability for any loss or damage suffered by any person arising from use of this e-mail.

-----------------------------Disclaimer-----------------------------


If you are have a problem using P&E's parallel interface on XP, it is
usually caused by XP polling the parallel port. In the process, XP
changes bits on the port. To stop this, you can download a utility from
P&E's website at www.pemicro.com called WINXP.REG which will fix this XP
problem.

Dave

Andrew Lohmann wrote:

> Although I have not noticed any difference in time taken to stop or
> reset recently with my recently updated version of Cosmic Zap 3.80a,
> those operations have always been slow. There used to be no difference
> between the parallel and the USB BDM interfaces in this respect.
> Unfortunately my installation on windows Xp is not satisfactory and I
> cannot use the parallel BDM interface. Perhaps you also have an
> installation problem with Xp?
>
> Andrew Lohmann AMIIE
> Design Engineer
>
> PLEASE NOTE NEW EMAIL ADDRESS IS:
> andrew.lohmann@andr...
>
> Bellingham + Stanley Ltd.
> Longfield Road, Tunbridge Wells, Kent, TN2 3EY, England.
> Tel: +44 (0) 1892 500400
> Fax: +44 (0) 1892 543115
> Website: www.bs-ltd.com >
> John Hartman (NoICE) wrote:
>
> >
> > >I use a combination of Metrowerks and PE-USB-ML Cable.
> > >Lately I have noticed that response to run/stop and reset when
> debugging
> > >are very slow. I think that this has been happening for a while but now
> > >it seems to happen at nearly every step.
> > >When I say slow, sometimes it takes 20-25 seconds for the debugger to
> > >stop my hardware!
> >
> > I am not sure it is the same problem, but two NoICE users reported
> > something similar. That turned out to be a long delay in unloading
> > part of
> > the P&E driver (when NoICE resets the target it may close and
> re-open the
> > driver).
> >
> > Both users were able to get relief by downloading the latest drivers
> from
> > P&E and installing them. It doesn't seem to be the drivers themselves -
> > it's the install process that makes everything happy. Worth a try in
> > any case.
> >
> > Best regards, John Hartman
> > john@john...
> > NoICE Debugging Tools
> > http://www.noicedebugger.com
> >
> >
> >
> >
> >
> >
> > >.
> >
> >
> >
> >
>
> -----------------------------Disclaimer-----------------------------
>
> This communication contains information which is confidential and may
> also be privileged. It is for the exclusive use of the addressee. If
> you are not the addressee please note that any distribution,
> reproduction, copying, publication or use of this communication or the
> information is prohibited. If you have received this communication in
> error, please contact us immediately and also delete the communication
> from your computer. We accept no liability for any loss or damage
> suffered by any person arising from use of this e-mail.
>
> -----------------------------Disclaimer----------------------------- >
> SPONSORED LINKS
> Freescale semiconductor inc
> <http://groups.yahoo.com/gads?t=ms&k=Freescale+semiconductor+inc&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=K2HGv-zFlv5OYUv_QxIq_Q>
> Microcontrollers
> <http://groups.yahoo.com/gads?t=ms&k=Microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=SYHwNJjjGQXRvtt_GybT4g>
> Pic microcontrollers
> <http://groups.yahoo.com/gads?t=ms&k=Pic+microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=umVbbnUwsPzEzKKD_pQfUw>
>
> 8051 microprocessor
> <http://groups.yahoo.com/gads?t=ms&k51+microprocessor&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=NO-nSKjHoAlh9XtZ8LB1_A >
>
> >. >
>




I have run WINXP.REG plus uninstalled all drivers and cosmic Zap and
them reinstalled them. Either BDM can be used with P&E Unsecure12 which
of cause reports that the device is unsecured.

Andrew Dave Perreault wrote:

> If you are have a problem using P&E's parallel interface on XP, it is
> usually caused by XP polling the parallel port. In the process, XP
> changes bits on the port. To stop this, you can download a utility from
> P&E's website at www.pemicro.com called WINXP.REG which will fix this XP
> problem.
>
> Dave
>
> Andrew Lohmann wrote:
>
> > Although I have not noticed any difference in time taken to stop or
> > reset recently with my recently updated version of Cosmic Zap 3.80a,
> > those operations have always been slow. There used to be no difference
> > between the parallel and the USB BDM interfaces in this respect.
> > Unfortunately my installation on windows Xp is not satisfactory and I
> > cannot use the parallel BDM interface. Perhaps you also have an
> > installation problem with Xp?
> >
> > Andrew Lohmann AMIIE
> > Design Engineer
> >
> > PLEASE NOTE NEW EMAIL ADDRESS IS:
> > andrew.lohmann@andr...
> >
> > Bellingham + Stanley Ltd.
> > Longfield Road, Tunbridge Wells, Kent, TN2 3EY, England.
> > Tel: +44 (0) 1892 500400
> > Fax: +44 (0) 1892 543115
> > Website: www.bs-ltd.com
> >
> >
> >
> > John Hartman (NoICE) wrote:
> >
> > >
> > > >I use a combination of Metrowerks and PE-USB-ML Cable.
> > > >Lately I have noticed that response to run/stop and reset when
> > debugging
> > > >are very slow. I think that this has been happening for a while
> but now
> > > >it seems to happen at nearly every step.
> > > >When I say slow, sometimes it takes 20-25 seconds for the debugger to
> > > >stop my hardware!
> > >
> > > I am not sure it is the same problem, but two NoICE users reported
> > > something similar. That turned out to be a long delay in unloading
> > > part of
> > > the P&E driver (when NoICE resets the target it may close and
> > re-open the
> > > driver).
> > >
> > > Both users were able to get relief by downloading the latest drivers
> > from
> > > P&E and installing them. It doesn't seem to be the drivers
> themselves -
> > > it's the install process that makes everything happy. Worth a try in
> > > any case.
> > >
> > > Best regards, John Hartman
> > > john@john...
> > > NoICE Debugging Tools
> > > http://www.noicedebugger.com
> > >
> > >
> > >
> > >
> > >
> > >
>
> > > >.
> > >
> > >
> > >
>
> > >
> >
> > -----------------------------Disclaimer-----------------------------
> >
> > This communication contains information which is confidential and may
> > also be privileged. It is for the exclusive use of the addressee. If
> > you are not the addressee please note that any distribution,
> > reproduction, copying, publication or use of this communication or the
> > information is prohibited. If you have received this communication in
> > error, please contact us immediately and also delete the communication
> > from your computer. We accept no liability for any loss or damage
> > suffered by any person arising from use of this e-mail.
> >
> > -----------------------------Disclaimer-----------------------------
> >
> >
> >
> >
> >
> >
> > SPONSORED LINKS
> > Freescale semiconductor inc
> >
> <http://groups.yahoo.com/gads?t=ms&k=Freescale+semiconductor+inc&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=K2HGv-zFlv5OYUv_QxIq_Q
> <http://groups.yahoo.com/gads?t=ms&k=Freescale+semiconductor+inc&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=K2HGv-zFlv5OYUv_QxIq_Q>>
>
> > Microcontrollers
> >
> <http://groups.yahoo.com/gads?t=ms&k=Microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=SYHwNJjjGQXRvtt_GybT4g
> <http://groups.yahoo.com/gads?t=ms&k=Microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=SYHwNJjjGQXRvtt_GybT4g>>
>
> > Pic microcontrollers
> >
> <http://groups.yahoo.com/gads?t=ms&k=Pic+microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=umVbbnUwsPzEzKKD_pQfUw
> <http://groups.yahoo.com/gads?t=ms&k=Pic+microcontrollers&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=umVbbnUwsPzEzKKD_pQfUw>>
>
> >
> > 8051 microprocessor
> >
> <http://groups.yahoo.com/gads?t=ms&k51+microprocessor&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=NO-nSKjHoAlh9XtZ8LB1_A
> <http://groups.yahoo.com/gads?t=ms&k51+microprocessor&w1=Freescale+semiconductor+inc&w2=Microcontrollers&w3=Pic+microcontrollers&w451+microprocessor&c=4&s6&.sig=NO-nSKjHoAlh9XtZ8LB1_A>>
>
> >
> >
> >
> >
> > >.
> >
> >
> >
> >
> >. >
>

-----------------------------Disclaimer-----------------------------

This communication contains information which is confidential and may also be privileged. It is for the exclusive use of the addressee. If you are not the addressee please note that any distribution, reproduction, copying, publication or use of this communication or the information is prohibited. If you have received this communication in error, please contact us immediately and also delete the communication from your computer. We accept no liability for any loss or damage suffered by any person arising from use of this e-mail.

-----------------------------Disclaimer-----------------------------


I use a combination of Metrowerks and PE-USB-ML Cable.

Lately I have noticed that response to run/stop and reset when debugging
are very slow. I think that this has been happening for a while but now
it seems to happen at nearly every step.

When I say slow, sometimes it takes 20-25 seconds for the debugger to
stop my hardware!

Has anyone encountered anything like this? Where should I start looking
to improve this situation?

Jonathan Masters