Forums

Re: Metrowerks IDE question

Started by rufuswatchdog June 28, 2011
I am not in the habit of reawakening message threads from nearly 10
years ago, but this never got resolved, as far as I can see.

I am experiencing the same issues with CodeWarrior IDE V. 5.7.0(We can't move to the new IDE for the legacy code)
and the Find in Files function does have a problem with scanning
header files. Namely, it isn't scanning them. But I think sometimes with other projects it does. (We can't move to the new IDE for the legacy code).

The Scan Source files checkbox is checked. The Scan Headers box is checked, but grayed out. It doesn't find the search terms in header files.

Lord, save me from software that "kinda" works. If it simply didn't work, I use grep and move on with my life. But this should work and I am destined to lose hours of my life finding out why it isn't.

Rufus
--- In 6..., "Paul Johnson" wrote:
>
> I find that the Find in Files function of the Codewarrior IDE is seriously
> broken on my system. When I select the Project tab, and check all the
> checkboxes, so that it will search all of the files in the project, it fails
> to look in some files (with no error message) and complains that it can't
> find others.
>
> The compiler can obviously find all these files, because it compiles them
> all into the executable, but Find in Files cannot.
>
> Can someone out there confirm or deny this on their system? If it's
> something I'm doing, I'd like to know what it is. If it's just a defect in
> the IDE, I'll move on to the next problem.
>
> Thanks,
>
> Paul
>