Forums

About m68evb912c32 evaluation board

Started by cosming January 14, 2004
Hello,
I have an eval. board with 9s12c32 uP and i'm trying to write
a simple test application for it. I use Codewarrior 3 from Metrowerks.
I have write a C application which works ok on simulator but when
I'm trying to write the Srecord into the uP flash i have some errors.
When I use the serial monitor "go" command sometimes the test
application works sometimes doesn't.
Somebody knows what i have done wrong?
Thank you



Hello,
I have similar difficulties with my 9s12c32 board.
I can't use FBULK and FLOAD commands through any terminal.
(Other commands have seen usable!)
I'm using Dbug-12 version 4.0.0b18 with TechnologicalArts MicroBDM12SX
I can burn flash NoICE only but sometimes not - I don't know what it
depends..
Thank You
zba

----- Original Message -----
From: "cosming" <>
To: <>
Sent: Wednesday, January 14, 2004 9:36 AM
Subject: [68HC12] About m68evb912c32 evaluation board > Hello,
> I have an eval. board with 9s12c32 uP and i'm trying to write
> a simple test application for it. I use Codewarrior 3 from Metrowerks.
> I have write a C application which works ok on simulator but when
> I'm trying to write the Srecord into the uP flash i have some errors.
> When I use the serial monitor "go" command sometimes the test
> application works sometimes doesn't.
> Somebody knows what i have done wrong?
> Thank you > --------------------To learn more
about Motorola Microcontrollers, please visit
> http://www.motorola.com/mcu
> o learn more about Motorola Microcontrollers, please visit
> http://www.motorola.com/mcu >




Mr. Bela

How is the crystal oscillator configured on your board? Colpitts or
Pierce?

If Colpitts is the XCLK open or pulled up high? If Pierce is the
XCLK pulled low?

Symptom tells me it is clocking problem..


Hello,
Thank You for the idea...
I use Pierce osc with 16MHz crystal,
PE7 = 0 at reset (10K pull down resistor),
XFC tied to VddPLL (PLL not used)
The circuit analog with as recommended
"Figure 2-6 Pierce Oscillator Connections (PE7=0)"
(MC9S12C Family Device User Guide V01.01)
Regards,
zba

----- Original Message -----
From: "zeta_alpha2002" <>
To: <>
Sent: Wednesday, January 14, 2004 3:34 PM
Subject: [68HC12] Re: About m68evb912c32 evaluation board > Mr. Bela
>
> How is the crystal oscillator configured on your board? Colpitts or
> Pierce?
>
> If Colpitts is the XCLK open or pulled up high? If Pierce is the
> XCLK pulled low?
>
> Symptom tells me it is clocking problem.. > --------------------To learn more
about Motorola Microcontrollers, please visit
> http://www.motorola.com/mcu
> o learn more about Motorola Microcontrollers, please visit
> http://www.motorola.com/mcu >
>




For experiment, change the crystal to 8 MHz to see if it is better.

--- In , "ZbBa" <zbela@f...> wrote:
> Hello,
> Thank You for the idea...
> I use Pierce osc with 16MHz crystal,
> PE7 = 0 at reset (10K pull down resistor),
> XFC tied to VddPLL (PLL not used)
> The circuit analog with as recommended
> "Figure 2-6 Pierce Oscillator Connections (PE7=0)"
> (MC9S12C Family Device User Guide V01.01)
> Regards,
> zba


I have already tried it, had no effect.
Regards,
zbela

----- Original Message -----
From: "zeta_alpha2002" <>
To: <>
Sent: Wednesday, January 14, 2004 9:07 PM
Subject: [68HC12] Re: About m68evb912c32 evaluation board For experiment, change the crystal to 8 MHz to see if it is better.

--- In , "ZbBa" <zbela@f...> wrote:
> Hello,
> Thank You for the idea...
> I use Pierce osc with 16MHz crystal,
> PE7 = 0 at reset (10K pull down resistor),
> XFC tied to VddPLL (PLL not used)
> The circuit analog with as recommended
> "Figure 2-6 Pierce Oscillator Connections (PE7=0)"
> (MC9S12C Family Device User Guide V01.01)
> Regards,
> zba
--------------------To learn more about
Motorola Microcontrollers, please visit
http://www.motorola.com/mcu
o learn more about Motorola Microcontrollers, please visit
http://www.motorola.com/mcu