Forums

AT91SAM9260 EK connection via USB

Started by pattloch September 11, 2009
Hello,
I have purchased a Atmel AT91SAM9260 EK. I used SAM-BA and tried to connect the board to via USB. It didn't work. There is no autodectection and the connection failed.

Please help. I am a newbie in embedded world.

Thanks

Regards

--- In A..., "pattloch" wrote:
>
> Hello,
> I have purchased a Atmel AT91SAM9260 EK. I used SAM-BA and tried to connect the board to via USB. It didn't work. There is no autodectection and the connection failed.
>
> Please help. I am a newbie in embedded world.

Did you load any code into the AT91SAM9260 EK ??

What did you expect ??

If you did load code into the chip, what code did you compile and load ??

don

>
> Thanks
>
> Regards
>
If any program exists in dataflash or external flash then samba cannot detect the board unless the code is erased. I think there might be bms jumper which should be removed while talking to samba. When program is downloaded assert bms jumper to low to execute the program.

Regards
snr

-----Original Message-----
From: donhamilton2002
Sent: Saturday, September 12, 2009 8:55 PM
To: A...
Subject: [AT91SAM] Re: AT91SAM9260 EK connection via USB

--- In A..., "pattloch" wrote:
>
> Hello,
> I have purchased a Atmel AT91SAM9260 EK. I used SAM-BA and tried to connect the board to via USB. It didn't work. There is no autodectection and the connection failed.
>
> Please help. I am a newbie in embedded world.

Did you load any code into the AT91SAM9260 EK ??

What did you expect ??

If you did load code into the chip, what code did you compile and load ??

don

>
> Thanks
>
> Regards
>
Messages in this topic (2)

[The entire original message is not included]
Hello,
I already press BP4 and reset and BMS is open. And i didn't load any code to the board. It didn't work.

So what is wrong?

Thanks
--- In A..., Narasimha Rao wrote:
>
> If any program exists in dataflash or external flash then samba cannot detect the board unless the code is erased. I think there might be bms jumper which should be removed while talking to samba. When program is downloaded assert bms jumper to low to execute the program.
>
> Regards
> snr
>
> -----Original Message-----
> From: donhamilton2002
> Sent: Saturday, September 12, 2009 8:55 PM
> To: A...
> Subject: [AT91SAM] Re: AT91SAM9260 EK connection via USB
>
>
> --- In A..., "pattloch" wrote:
> >
> > Hello,
> > I have purchased a Atmel AT91SAM9260 EK. I used SAM-BA and tried to connect the board to via USB. It didn't work. There is no autodectection and the connection failed.
> >
> > Please help. I am a newbie in embedded world.
>
> Did you load any code into the AT91SAM9260 EK ??
>
> What did you expect ??
>
> If you did load code into the chip, what code did you compile and load ??
>
> don
>
> >
> > Thanks
> >
> > Regards
> >
> Messages in this topic (2)
>
> [The entire original message is not included]
>
--- In A..., "pattloch" wrote:
>
> Hello,
> I already press BP4 and reset and BMS is open. And i didn't load any code to the board. It didn't work.
>
> So what is wrong?

The operator.

Do you have the CD that came with the board ?

If not download this:
http://www.atmel.com/dyn/resources/prod_documents/SAM9260_CDROM_image.zip

Then read this:
http://www.atmel.com/dyn/resources/prod_documents/doc6297.pdf

good luck.

don