Forums

mmc not detected on AT91SAM9263 board

Started by suse auto November 18, 2009
i am using SAM9263K eval board to integrate wifi card from gemtek
(*GM9601*)
with marvel chip 88w8686.
i compiled the linux kernel 2.6.30 with patches from AT91. kernel is booting
up from data flash. I am not seeing the 'mmc' getting mounted while kernel
bootup. also I don't see 'eth1' device when I run "ifconfig -a" command. I
am thinking that I can map my wireless ethernet port to the 'eth1' device.
correct me if I am wrong.
please let me know how do I debug to bring the Wifi board up?

find below the configuration tags for 'mmc' and 'sdio' in .config file of
the linux kernel.

*"MMC" configuration in .config file*
CONFIG_MMC=y
CONFIG_MMC_DEBUG=y
CONFIG_MMC_UNSAFE_RESUME=y
#
# MMC/SD/SDIO Card Drivers
#
CONFIG_MMC_BLOCK=y
CONFIG_MMC_BLOCK_BOUNCE=y
CONFIG_SDIO_UART=y
CONFIG_MMC_TEST=y
#
# MMC/SD/SDIO Host Controller Drivers
#
# CONFIG_MMC_SDHCI is not set
CONFIG_MMC_AT91=y
CONFIG_MMC_ATMELMCI=y
# CONFIG_MEMSTICK is not set
# CONFIG_ACCESSIBILITY is not set
# CONFIG_NEW_LEDS is not set
CONFIG_RTC_LIB=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
# CONFIG_RTC_DEBUG is not set

*LIBERTAS configuration in .config file*
#
# Wireless LAN
#
CONFIG_WLAN_PRE80211=y
# CONFIG_STRIP is not set
CONFIG_WLAN_80211=y
CONFIG_LIBERTAS=m
CONFIG_LIBERTAS_SDIO=m
CONFIG_LIBERTAS_SPI=m
# CONFIG_LIBERTAS_DEBUG is not set
# CONFIG_HOSTAP is not set
-regards,
-susan.
On Wed, 18 Nov 2009 21:01:17 +0530
suse auto wrote:
> i compiled the linux kernel 2.6.30 with patches from AT91. kernel is
> booting up from data flash. I am not seeing the 'mmc' getting mounted
> while kernel bootup.

Do you have the device? Can you compile the mmc support as a module,
and then load it and see what the drivers tell you?

It's not going to get mounted automatically unless you either have
it in your fstab, or you have the hotplug system configured correctly,
and that runs in user space, so that'd be after the boot process.

Dan
Hi,

If I remember it well MMC detection does not work quite well during bootup IF
* SPI is activated.
* ALSA is configured as a module.

Try this in your kernel conf to see if this solves your problem (it
worked for me in 2.6.28 and 2.6.29, but I haven't tested 2.6.30 yet).

Regards

JosMar Sico

MScE Telecommunication

blog: http://jm.sunico.org
twitter: http://twitter.com/jmsunico
linkedin: http://linkedin.com/in/jmsunico

Skype: jmsunico
Wave: jmsunico
MSN: jmsunico
On Wed, 18 Nov 2009 19:08:47 +0100
José María Súnico wrote:
> If I remember it well MMC detection does not work quite well during
> bootup IF
> * SPI is activated.
> * ALSA is configured as a module.

This is definitely a problem on the 261-EK, but I looked at the Linux
source for the 263-EK and didn't see the same issues. I haven't traced
the pins used for each, though, the problem with the 261 is that there
was some pin sharing between MMC and SPI0 that needed some careful
coding to keep separate, and the Linux driver model didn't have an easy
way to honor that.

Dan
hi,

I tried with SPI enabled but was of no use. i did not find ALSA option in
the kernel config file. I have inserted the wifi sdio card to the mmc
interface. note that there is a 8MB data flash connected to other mmc
interface and is detected on power-on-reset. do you think there may be any
jumper settings that is required to be changed on the SAM9263-EK board to
enable mmc1 interface?

-susan.

On Thu, Nov 19, 2009 at 1:32 AM, Dan Lyke wrote:

> On Wed, 18 Nov 2009 19:08:47 +0100
> JosMar Sico > wrote:
> > If I remember it well MMC detection does not work quite well during
> > bootup IF
> > * SPI is activated.
> > * ALSA is configured as a module.
>
> This is definitely a problem on the 261-EK, but I looked at the Linux
> source for the 263-EK and didn't see the same issues. I haven't traced
> the pins used for each, though, the problem with the 261 is that there
> was some pin sharing between MMC and SPI0 that needed some careful
> coding to keep separate, and the Linux driver model didn't have an easy
> way to honor that.
>
> Dan
>