Forums

problem with tutorial nokia 6100 LCD by james lynch(im using SAM7X256)

Started by Zack May 18, 2010
ive already edited and done the tutorial...i used yagarto to compile..there are no problems with the compiling...after that i flashed the binary file on to the sam7x256 board...the problem is there are absolutely no output...it suppose to show "hello World" on the LCD screen....is this bcoz im missing some files?ive already included the Cstartup_SAM7.c...the files on my projects are,Lcd.h,Lcd.c,at91sam7x256.h,board.h,main.c and Cstartup_SAM7.c

my main programming looks like this..

#include "at91sam7x256.h"
#include "Lcd.h"
#include "board.h"

extern void LowLevelInit(void);

int main (void){

unsigned long j;
unsigned long k;
unsigned long col;
unsigned long row;
unsigned int IdleCount=0;
int TempColor[11]={ WHITE , BLACK ,RED , GREEN , BLUE , CYAN , MAGENTA ,
YELLOW , BROWN , ORANGE , PINK};
char *TempChar[11]={ "White","Black","Red","Green","Blue","Cyan",
"Magenta","Yellow","Brown","Orange","Pink"};

LowLevelInit();

InitSpi();
InitLCD();
//LCDClearScreen();

LCDPutString("Hello World", 60, 5, SMALL, WHITE, BLACK);
LCDPutString("Hello World", 40, 5, MEDIUM, ORANGE, BLACK);
LCDPutString("Hello World", 20, 5, LARGE, PINK, BLACK);

Delay(8000000);

}

my makefile looks like this

INCLUDE1=./

INCLUDE2=C:/WinARM/arm-elf/include

INCLUDE3=C:/WinARM/lib/gcc/arm-elf/4.1.1/include

all:
arm-elf-gcc main.c Lcd.c Cstartup_SAM7.c

-o main3.bin -I$(INCLUDE1) -I$(INCLUDE2) -I$(INCLUDE3)

i would appreciate it if someone told me where i went wrong...tq