Problems with ATMega16 (after programming)

Started by Marcus Klein February 3, 2004
Hi AVR-world!

I have problems programming an ATMega 16 device via ICSP on two
application boards I
designed (two different boards with different applications). The first
one works fine but as I finished
the second one today and put a blank ATMega in for programming, the
following occured:
Programming and verification were reported to be ok, but nothing happens
(althoug the XTal runs).
Ports are all low or High-Z (couldn't measure that in circuit). I closed
the programmer, reopened it and
read the complete MCU-Memory and E2PROM - all ok. Next I put the
controller on the second
application board and programmed (also with the same ICSP-Interface) the
suiting hex-file - cycle ok,
XTal runs - noting happens.

I've checked for short circuits, low voltages, proper RESET-line
handling and couldn't find any errors.
I Used PonyProg to flash the hex-files and a simple COM-Port to
MSIO/MOSI/SCK/RESET - interface
that I used for a longer time on different MCUs.

I tried out a second device, programmed it first on the second board -
nothing, reprogrammed it on the
running board - nothing. You can only write, erase and read the device
but it does not run anymore...

I didn't try to put a MCU on the first board for programming because of
the different port config.

For hell's sake - I tried the whole afternoon, without any flashing idea
or any hint or help. I hope there
is anybody out there who can help me in this case. Thanks a lot to all
who try...

I can't get rid of the feeling, that I killed the two MCUs someway - I
don't want to kill the next ones I have
to order tomorrow...

Hope for help

Marcus