Re: BX01 Parallel Port woes - any suggestions appreciated!

Started by #...@!%! Herzog August 2, 2005
Having had the same problem and in a muddle with all the documenets,
I let this sit for nearly a year.

Finally, I tried changing the Parallel Port addresses in the IDE and
found that the default address was the wrong one.

Windows XP is just fine.

I am a bit frustrated as there is little beginners support. All you
get is a "hello world" routine and that is it.

Many of us buy these things to learn and it a more procedural startup
for newbies would greatly enhance sales.

I bought the Bx-01 with the RAMsandwich especially for the its RAM,
but moved over to BasicStamp products to build confidence in my
skills and understanding.

I really don't like to flame through email, so I just let it go.
But, if you want customers, you do have to teach them a bit more and
not just assume your market is full of experts. --- In basicx@basi..., "Pete Markiewicz" <pindiespace@g...>
wrote:
>
> Hi, I just purchased the BX-01 with the development board. I've
been
> unable to get the board working successfully - would appreciate
> comments:
>
> 1. Running on Windows 2000 computer with NO print drivers
installed.
> Both serial port and parallel port connected to development board.
I
> have a PCI secondary parallel port. Power applied to BX development
> board = green light on.
>
> When I bring up the BasicX downloader, no sign of the default
> program. When I press the green stoplight in the software, a
message
> in status bar at bottom saying either "Power is on, Running"
> or "Power is off" but nothing in the console window.
>
> When I try to compile and run, I get an alert
>
> "Setup returned invalid data: 255"
>
> I have tried both the built-in parallel port, and the third-party
> PCI card supplying an additional parallel port. However, I get this
> message even if I DISCONNECT the parallel port cable.
>
> I have tried this with and without applying external power to the
> board.
>
> I'm using the internal EPROM. I'm sure this isn't the problem
> because if I switch to the (nonexistent) external EPROM I get the
> additional error "bad verify at 1".
>
> Unplugging the serial port gives "serial port error" so I think it
> is OK.
>
> So the problem appears to be the download via the parallel port. I
> have tried switching the mode of communication using the parallel
> port between EPP, ECP and both, with no effect on the outcome.
>
> I'm at a loss at this point. I originally tried using a Windows XP
> box but switched to the dedicated Win2000 system in case there were
> some XP-related parallel port problems. But no dice. Bad parallel
> port cable? Development board is fried? Any ideas?
>
> Pete Markiewicz