BX 35 COMMUNICATION PROBLEM

Started by jmayn2001 December 14, 2005
hi has anyone had any trouble or experience hooking up a bx35 with the
suggested hookup schematic from net media? i cant get the chip to
communicate when i hook it up the way the schematic says on a proto
board.



--- In basicx@basi..., "jmayn2001" <jpmayn@v...> wrote:
>
> hi has anyone had any trouble or experience hooking up a bx35 with
the
> suggested hookup schematic from net media?

Hi
Try putting a small cap (I have used 22pF) between Reset pin and GND.
This solved my problem with startup of BX35 (otherwise using suggested
hook-up).

73's
Tore Fintland
LA6ZT



That is an interesting solution. Some of the resistor values were of
concern to me. {You can look in Files for posted ERRATA.}

Actually, the BX35 schematic is marked "PRELIMINARY" and I strongly
suggest that you look at the Development Board Schematic if you have
any further trouble as it is in production and being used.

--- In basicx@basi..., "Tore Fintland" <tore.fintland@s...>
wrote:
> [] (I have used 22pF) between Reset pin and GND.
[]


--- In basicx@basi..., "G. Kramer Herzog" <hwanghetw@y...>
wrote:
>
> That is an interesting solution. Some of the resistor values were
of
> concern to me. {You can look in Files for posted ERRATA.}
>
> Actually, the BX35 schematic is marked "PRELIMINARY" and I strongly
> suggest that you look at the Development Board Schematic if you have
> any further trouble as it is in production and being used.
>
> --- In basicx@basi..., "Tore Fintland" <tore.fintland@s...>
> wrote:
> > [] (I have used 22pF) between Reset pin and GND.
> []
>
i finnaly found the problem by looking in the errata area. mike perks
has a schematic for a bx35 development board pin 4 on the netmedia
schematic goes to the atn line on mikes schematic pin 6 goes to the
atn pin 4 is not used.this is from the db9 connector. on mike perks
schematic he has the rx and tx switched it needs to be fixed on his
schematic otherwise i downloaded to the chip fine.



jmayn2001 wrote:

> i finnaly found the problem by looking in the errata area. mike perks
> has a schematic for a bx35 development board pin 4 on the netmedia
> schematic goes to the atn line on mikes schematic pin 6 goes to the
> atn pin 4 is not used.this is from the db9 connector. on mike perks
> schematic he has the rx and tx switched it needs to be fixed on his
> schematic otherwise i downloaded to the chip fine.

I'm sorry that my schematic (
http://home.austin.rr.com/perks/micros/bx35_development_board.pdf )
confused you. It is clearly marked that it is for a DCE (null modem)
cable which is wired differently to a straight-through cable that you
probably have. The schematic has extra text to show 4/6 and 2/3 are
switched as that is what happens inside a null modem cable.

Here is another place for a BX-35 connection diagram:
http://basicx.com/Products/BX-35/BX35_Schematic.gif

Mike
http://home.austin.rr.com/perks/micros/