basicx, eb500 and stampplot

Started by dosun129 April 11, 2008
Hello!
Im wondering if anyone can steer me in the right direction for my
problem.
I have a boe bot with the ping ultrasonic sensor and eb500.
Initially i had the Basic stamp on the BOE and was able to plot on
stampplot over Bluetooth using the serout command where i was
plotting in XY coordinates.
SEROUT 1,84,["[",DEC3 val,"],[",DEC val,"]",CR]

Now, i have dropped a bx24p into the BOE and im trying to get
connection with the eb500 and plot to stampplot. I've been trying
the definecom3, openqueue, putqueue, but im having big troubles
getting results.

I can't even seem to send one thing!
call definecom3(5,6,bx1000_1000) '8data,1stop,no parity
call openqueue(xAr,10) 'arrays of single
call openqueue(xout,10)
call openqueue(xin,10)

call opencom(3,9600,xin,xout)
'testing
xAr(1).0
xAr(2) .0
call putqueue(xout,xAr(1),4)
call putqueue(xout,xAr(2),4)

Am i on the right track? Is this supposed to send the individual
values in xAr to stampplot?

Looking ahead...
>From reading, putqueue sends bytes from an array, correct?
so if i had 2 arrays (x coordinate and y coordinate)
how would i send the x and y simultaneously in 1 call for stampplot
to read correctly?

I was directed from the stampplot group to this group. hopefully
someone can help me out!

Thank You
Ben.

Hello!
>Im wondering if anyone can steer me in the right direction for my
>problem.
>I have a boe bot with the ping ultrasonic sensor and eb500.
>Initially i had the Basic stamp on the BOE and was able to plot on
>stampplot over Bluetooth using the serout command where i was
>plotting in XY coordinates.
>SEROUT 1,84,["[",DEC3 val,"],[",DEC val,"]",CR]
>
>Now, i have dropped a bx24p into the BOE and im trying to get
>connection with the eb500 and plot to stampplot. I've been trying
>the definecom3, openqueue, putqueue, but im having big troubles
>getting results.
>
>I can't even seem to send one thing!
>call definecom3(5,6,bx1000_1000) '8data,1stop,no parity
>call openqueue(xAr,10) 'arrays of single
>call openqueue(xout,10)
>call openqueue(xin,10)
>
>call opencom(3,9600,xin,xout)
>'testing
>xAr(1).0
>xAr(2) .0
>call putqueue(xout,xAr(1),4)
>call putqueue(xout,xAr(2),4)
>
>Am i on the right track? Is this supposed to send the individual
>values in xAr to stampplot?
>
>Looking ahead...
>> From reading, putqueue sends bytes from an array, correct?
>so if i had 2 arrays (x coordinate and y coordinate)
>how would i send the x and y simultaneously in 1 call for stampplot
>to read correctly?
>
>I was directed from the stampplot group to this group. hopefully
>someone can help me out!
>
>Thank You
>Ben.
>
>

I'm also trying to get the EB500 to work with the Basicx. I do have the led lighting up on the EB500 indicating a connection. This is what I found:
Call DefineCom3(5, 6, bx0000_1000)
to define Com3 bx1000_1000 defines an inverted serial output. You need a non-inverted serial output.
For connecting the USB Blue tooth dongle on the PC use this call to send the address
SEROUT 1,84,["con 11:45:57:49:36:24",CR]
should be :
Call PutQueuestr(Com3_Out,"con ")
Call PutQueuestr(Com3_Out,"11:45:57:49:36:24" & chr(13))
I broke it up into 2 lines since for some reason when sent in one line the last character is dropped off.

I hope this helps
>