Forums

AT91RM9200 Linux Board bootloader problems?

Started by Ethan May 1, 2012
Hello, I am extremely new to this stuff and just got a AT91RM9200 Linux
Board. I was going to download Python to it to make some programs. After
setting it up per the setup MANUAL, it seemed to lad fine. I proceeded to
download Python but it just wouldn't work. I researched and found that i
had an error when booting (Error bad CRC, continuing loading Linux
environment). The best fix to this problem was to install a fresh u-boot to
board. Awesome, the MANUAL covers that! I followed steps to the letter...
but apparently it did not have everything. 
U-BOOT> protect off 10000000 1001ffff
U-BOOT> erase 10000000 1001ffff
U-BOOT> tftp 20000000 boot.bin      <<< I got to here...
U-BOOT> cp.b 20000000 10000000 20000
U-BOOT> protect on 10000000 1001ffff

U-BOOT> protect off 10020000 1003ffff
U-BOOT> erase 10020000 1003ffff
U-BOOT> tftp 20000000 u-boot.gz
U-BOOT> cp.b 20000000 10020000 20000
U-BOOT> protect off 10020000 1003ffff

It said Loading... TTTT for 2 lines then timeout error. Now when i boot it
doesnt load anything because i erased the boot files... Apparently this has
never been a problem because i can not find any documentation for it in
manuals or online. The code above is directly from manual.
Please help!
Ethan


	   
					
---------------------------------------		
Posted through http://www.EmbeddedRelated.com
On 2012-05-02 00:51, Ethan wrote:
> Hello, I am extremely new to this stuff and just got a AT91RM9200 Linux > Board. I was going to download Python to it to make some programs. After > setting it up per the setup MANUAL, it seemed to lad fine. I proceeded to > download Python but it just wouldn't work. I researched and found that i > had an error when booting (Error bad CRC, continuing loading Linux > environment). The best fix to this problem was to install a fresh u-boot to > board. Awesome, the MANUAL covers that! I followed steps to the letter... > but apparently it did not have everything. > U-BOOT> protect off 10000000 1001ffff > U-BOOT> erase 10000000 1001ffff > U-BOOT> tftp 20000000 boot.bin<<< I got to here... > U-BOOT> cp.b 20000000 10000000 20000 > U-BOOT> protect on 10000000 1001ffff > > U-BOOT> protect off 10020000 1003ffff > U-BOOT> erase 10020000 1003ffff > U-BOOT> tftp 20000000 u-boot.gz > U-BOOT> cp.b 20000000 10020000 20000 > U-BOOT> protect off 10020000 1003ffff > > It said Loading... TTTT for 2 lines then timeout error. Now when i boot it > doesnt load anything because i erased the boot files... Apparently this has > never been a problem because i can not find any documentation for it in > manuals or online. The code above is directly from manual. > Please help! > Ethan
I could probably fix this, since I worked a lot with the AT91RM9200 at Atmel, but it is going to take some time, which I don't have unless someone pays for it. Best Regards Ulf Samuelsson
> > > > > --------------------------------------- > Posted through http://www.EmbeddedRelated.com