Forums

UART SPI MCF5282

Started by Bjoern Braun May 4, 2004
Hello all,

i have some problems with the UART and the SPI modules of the MCF5282. 
What do i have to do to get them running. I work with the senTec evaluation  
Board COBRA5282 and a gcc GNU - Compiler. The Compiler is installed on the 
host and is running well. The Motorola dBug - Software on the Evaluation 
Board is also running well.

Steps that I have done:

- Creating a Header - File where all register addresses are dedicated to 
register names

- Writing a Init.c where the

    	- Chip Configuration register is set
    	- PLL is initialized
    	- Software Watchdogtimer is disabled
    	- SRAM is enabled for the on chip modules through the SCM - Registers
    	- UART is set up and enabled through the UART registers

- Writing a io.c which handles the UART IN/OUT - functions
- Writing a main.c which calls the functions of Init.c and uses the OUT - 
function of io.c

The compilation of the project works properly.

But there is entirely no effect to the UART after downloading the software 
with the dBug tool. Hope anyone can tell me standard way to run the UART on 
the MCF5282. Perhaps the failure is by start up configuration of the 
Coldfire.

bye Bjoern!
It is impossible to tell what you are doing wrong if you don't show us what you
are doing. At least post the code you wrote for initializing and talking to the
UART.

> >But there is entirely no effect to the UART after downloading the software >with the dBug tool. Hope anyone can tell me standard way to run the UART on >the MCF5282. Perhaps the failure is by start up configuration of the >Coldfire.
You need to enable the IO pins for UART mode: if ( unit < 2 ){ MCF5282_GPIO_PUAPAR |= 0x3<<(unit<<1); MCF5282_GPIO_PTCPAR |= 0x11<<unit; } --- 42Bastian Do not email to bastian42@yahoo.com, it's a spam-only account :-) Use <same-name>@epost.de instead !