Forums

Bringing up ecos on Integrator/AP.

Started by ivy May 10, 2005
Dear friends,

          I am very newbie to this list and also ecos... I have a
Integrator /AP (ARM920T) Evaluation Board.  It has 128MB SDRAM. Actually 
m trying to run ecos + application program on it. Basically i dont know th
exact procedure to follow.. 

           My Evalutation Board has inbuilt ARM BootPROM. Using that 
have downloaded prebuilt Redboot to Flash. Redboot is working fine. I hav
compiled ecos using configtool.exe (cygwin Env). While i was trying t
download the final image, i wasnot getting download... I have compiled m
in RAM mode. 
 
            I thought that, the prebuilt Redboot shows on 16MB SDRAM. bu
mine has 128MB. So that could be a problem. So i have changed *.ldi, *.
files for RAMSIZE entries. But THERE ARE NO PROGRESS SOFAR...Any on
worked on this kind of Environment please help me out ... 

             I am hanging in this problem last 4 days.... Even i hav
posted in ecos-discuss mailing list . There was no reply so far... I hop
this is the right place to shoot my question and hope that i ll get th
right direction.


Thanks
Ivy 


		
-> This message was sent using the  web interface o
www.EmbeddedRelated.com <-
How are you downloading the image. Through tftp ?

What is Redboot giving after downloading your image ? 

Jon

>How are you downloading the image. Through tftp ? > >What is Redboot giving after downloading your image ? > >Jon > >
Actually very first, i was trying with serial port ... but it was no helpful... i dont know why ... I tried with tftp ... Yes!!!... I wa downloaded successfully... and starts working also... Thanks for you tips.... Now came with another issue... Actually i m using ecos snapsho packages... While rebuilding my redboot using configtool,i have choosen "ARM INTEGRATOR development board w/ ARM966" Template. I have compile without any problem.. It was working also. when i go through configuratio window in configtool, it shows "ARM ARM920T Microprocessor" option unde ARM ARM9 ARchitecure was disabled. instead of this , ARM ARM966E wa enabled... so i have changed option by enabling ARM920T... It throws conflict message.. i resolved it... compiled successfully... But it is no working in Board... Please tell me what is wrong with it.. Ivy -> This message was sent using the comp.arch.embedded web interface o www.EmbeddedRelated.com <-