Forums

MPLAB 5.70.40 is integrated with HI-TECH PICC compiler v8.02 PL1

Started by Bruce Sam October 15, 2004
I have integrated MPLAB 5.70.40  with HI-TECH PICC compiler v8.02
PL1 but failed.When I only compiled just a simple .c file,it appear
this message:MPLAB is unable to find output file "DELAY.HEX".
This may be due to a compile, assemble, or link process
failure.Here is all I have done:
1.Click on the Option menu in the mehu bar, and select Environment
setup,in this new dialog box,I have setted Default language suite to
HI-TECH PICC.
2.Click on the Project menu in the menu bar,and select Install Language
Tool,in here,I have setted the location of the compiler,assembler and
linker of the HI-TECH compiler that I have installed.The executable for
all three tools(compiler/assembler/linker) is setted to picc.exe.
3.I have added two environment variable showed below:
HTC_ERR_FORMAT=Error[000] %f %l : %s
HTC_WARN_FORMAT=Warning[000] %f %l : %s
Even I have done above step,but it also not success.
How to solve this problem?I am using MPLAB-ICD not MPLAB-ICD2,so
please don't advise me to use MPLAB v6.xx.
Any help will very appreciate!

>I have integrated MPLAB 5.70.40 with HI-TECH PICC compiler v8.02 >PL1 but failed.When I only compiled just a simple .c file,it appear >this message:MPLAB is unable to find output file "DELAY.HEX". >This may be due to a compile, assemble, or link process >failure.Here is all I have done: >1.Click on the Option menu in the mehu bar, and select Environment >setup,in this new dialog box,I have setted Default language suite to >HI-TECH PICC. >2.Click on the Project menu in the menu bar,and select Install Language >Tool,in here,I have setted the location of the compiler,assembler and >linker of the HI-TECH compiler that I have installed.The executable for >all three tools(compiler/assembler/linker) is setted to picc.exe. >3.I have added two environment variable showed below: >HTC_ERR_FORMAT=Error[000] %f %l : %s >HTC_WARN_FORMAT=Warning[000] %f %l : %s >Even I have done above step,but it also not success. >How to solve this problem?I am using MPLAB-ICD not MPLAB-ICD2,so >please don't advise me to use MPLAB v6.xx. >Any help will very appreciate! >
I also had problems using fairly new versions of PICC with older versions of MPLAB. Like you, I wanted to use an ICD1. In the end, I was forced to give up. I now use the latest versions of MPLAB and PICC and I bought an ICD2. I would advise you to do the same, as it will save you a lot of time. I am almost certain that you cannot use your version 8 PICC with MPLAB 5.x Even if you get it to compile, you will have problems debugging.
Ppelectron schrieb:
>>I have integrated MPLAB 5.70.40 with HI-TECH PICC compiler v8.02 >>PL1 but failed.When I only compiled just a simple .c file,it appear >>this message:MPLAB is unable to find output file "DELAY.HEX". >>This may be due to a compile, assemble, or link process >>failure.Here is all I have done: >>1.Click on the Option menu in the mehu bar, and select Environment >>setup,in this new dialog box,I have setted Default language suite to >>HI-TECH PICC. >>2.Click on the Project menu in the menu bar,and select Install Language >>Tool,in here,I have setted the location of the compiler,assembler and >>linker of the HI-TECH compiler that I have installed.The executable for >>all three tools(compiler/assembler/linker) is setted to picc.exe. >>3.I have added two environment variable showed below: >>HTC_ERR_FORMAT=Error[000] %f %l : %s >>HTC_WARN_FORMAT=Warning[000] %f %l : %s >>Even I have done above step,but it also not success. >>How to solve this problem?I am using MPLAB-ICD not MPLAB-ICD2,so >>please don't advise me to use MPLAB v6.xx. >>Any help will very appreciate! >> > > > I also had problems using fairly new versions of PICC with older versions of > MPLAB. Like you, I wanted to use an ICD1. In the end, I was forced to give up. > I now use the latest versions of MPLAB and PICC and I bought an ICD2. I would > advise you to do the same, as it will save you a lot of time. I am almost > certain that you cannot use your version 8 PICC with MPLAB 5.x Even if you get > it to compile, you will have problems debugging. >
There is a workaraound for this problem. You can compile your project with MPLAB V6.xx and use MPLAB V5.xx with the ICD for debugging. Setting breakpoints in C sourcecode works in V5.xx. Markus