Forums

lint config file for IAR EWARM?

Started by Not Really Me July 12, 2007
Does anyone have a current PC-lint configuration file (.lnt) to use with IAR 
Embedded workbench for ARM?

Scott


"Not Really Me" <scott@validatedQWERTYsoftware...XYZZYcom> wrote in 
message news:5fnp63F3csnauU1@mid.individual.net...
> Does anyone have a current PC-lint configuration file (.lnt) to use > with IAR Embedded workbench for ARM? > > Scott
I believe line already comes with one. Check out co-iar.lnt in the lnt directory.
"Tom Lucas" <news@REMOVE_tlcs_THIS_dot_TO_fsnet_REPLY_dot_co.uk> wrote 
in message news:1184324953.63956.0@demeter.uk.clara.net...
> "Not Really Me" <scott@validatedQWERTYsoftware...XYZZYcom> wrote in > message news:5fnp63F3csnauU1@mid.individual.net... >> Does anyone have a current PC-lint configuration file (.lnt) to use >> with IAR Embedded workbench for ARM? >> >> Scott > > I believe line already comes with one. Check out co-iar.lnt in the lnt > directory.
ahem, I believe *lint* already comes with one. Long week...
In article <5fnp63F3csnauU1@mid.individual.net>, Not Really Me 
<scott@validatedQWERTYsoftware.?.?.XYZZYcom.invalid> writes
>Does anyone have a current PC-lint configuration file (.lnt) to use with IAR >Embedded workbench for ARM?
Try www.gimpel.com ? -- \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\ \/\/\/\/\ Chris Hills Staffs England /\/\/\/\/ /\/\/ chris@phaedsys.org www.phaedsys.org \/\/\ \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
"Chris Hills" <chris@phaedsys.org> wrote in message 
news:bx7MQHDg62lGFAbO@phaedsys.demon.co.uk...
> In article <5fnp63F3csnauU1@mid.individual.net>, Not Really Me > <scott@validatedQWERTYsoftware.?.?.XYZZYcom.invalid> writes >>Does anyone have a current PC-lint configuration file (.lnt) to use with >>IAR >>Embedded workbench for ARM? > > Try www.gimpel.com ? > > > -- > \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\ > \/\/\/\/\ Chris Hills Staffs England /\/\/\/\/ > /\/\/ chris@phaedsys.org www.phaedsys.org \/\/\ > \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/ > > >
Thanks to both for the answers. I have used the version on the Gimpel site, but it isn't sufficient. It certainly could be that I am missing the right processor setting, but I am getting messages like the following: --- Module: ..\src\bsp.c (C) _ #error "<yvals.h> compiled with wrong (version of IAR) compiler" C:\Program Files\IAR Systems\Embedded Workbench 4.0\arm\inc\yvals.h 45 Error 309: #error "<yvals.h> compiled with wrong (version of IAR) compiler" It is probably related to the wrong __TID__ setting, but I have been unable to figure out what the correct one is. This is for an Atmel AT91SAM9261. Scott