Forums

PIC 16f877 and MPLAB compatibilty

Started by Bhanu Samarth August 10, 2004
Hi all, 
   I am working on a data acquistion part from a sensor to PC. I am
using a PIC 16f877 and I have MPLAB IDE v5.61 and the ICD flash
module.
I wanted to know if there is anyway I could use the latest version
which is MPLAB 6.6 with the ICD flash module. or would i need the
ICD2(hockey puck thing) if i need to use the v6.6.
   Please let me know your experiences.

thanks,
Bhanu
>Hi all, > I am working on a data acquistion part from a sensor to PC. I am >using a PIC 16f877 and I have MPLAB IDE v5.61 and the ICD flash >module. >I wanted to know if there is anyway I could use the latest version >which is MPLAB 6.6 with the ICD flash module. or would i need the >ICD2(hockey puck thing) if i need to use the v6.6. > Please let me know your experiences. > >thanks, >Bhanu
The original ICD will not work with 6.x versions of MPLAB and the ICD2 will not work with 5.x versions of MPLAB. I was forced to upgrade to ICD2 when my new C compiler upgrade demanded MPLAB 6.x. If you have a combination of ICD / MPLAB that does what you need, I would be inclined to keep using it. However the ICD2 is a nice bit of kit and is a good price. It also has a USB interface in addition to the standard RS232. It also supports loads more devices than the original ICD.
Hi, 
  Thanks for the clarification. I think i will proceed with the
original ICD and Mplab v5. But I dont have the 5pin cable connecting
the ICD module to the demo board. Can you tell me what it is called so
that I can purchase it.
Thank you again.

Bhanu

ppelectron@aol.com (Ppelectron) wrote in message news:<20040811043042.14599.00001488@mb-m29.aol.com>...
> >Hi all, > > I am working on a data acquistion part from a sensor to PC. I am > >using a PIC 16f877 and I have MPLAB IDE v5.61 and the ICD flash > >module. > >I wanted to know if there is anyway I could use the latest version > >which is MPLAB 6.6 with the ICD flash module. or would i need the > >ICD2(hockey puck thing) if i need to use the v6.6. > > Please let me know your experiences. > > > >thanks, > >Bhanu > > The original ICD will not work with 6.x versions of MPLAB and the ICD2 will not > work with 5.x versions of MPLAB. I was forced to upgrade to ICD2 when my new C > compiler upgrade demanded MPLAB 6.x. > > If you have a combination of ICD / MPLAB that does what you need, I would be > inclined to keep using it. However the ICD2 is a nice bit of kit and is a good > price. It also has a USB interface in addition to the standard RS232. It also > supports loads more devices than the original ICD.
>Hi, > Thanks for the clarification. I think i will proceed with the >original ICD and Mplab v5. But I dont have the 5pin cable connecting >the ICD module to the demo board. Can you tell me what it is called so >that I can purchase it. >Thank you again. > >Bhanu >
I have emailed you the relevant part number. Alternatively just solder wires across. Use no more than a 9" length and take care to get the connections right! Phil