Forums

LPC2131 Does not run when not debugging with IAR Jlink

Started by davidkiryat8 April 19, 2007
I have read several threads where new ARM programmers like myself have
encountered a problem where their code (custom board) only runs when
using the debugger. I have yet to find my problem. I have programmed
two other ARM boards using the LPC2101 chip with problems. This board
using the LPC2131 is somehow different.
The JTAG interface has pulldown and pullup resistors.
The emulator selection jumper (RTCLK) is left open.
We have tried manually reseting after power up. the main crystal is
oscillating.
P0.31 has a pullup resistor.

My cstartup.s79 and lpc213x.xcl look correct and should create a
correct crc. How can I check? what are the correct values for the LPC2131?

Any other suggestion?

I would like to isolate whether this is a software or hardware problem.
Does anyone have a zipped IAR LPC213x dummy project (including
lpc213x.xcl,cstartup.s79 files) that I could just change an output to
see if it runs without the emulator?

An Engineer's Guide to the LPC2100 Series

--- In l..., "davidkiryat8" wrote:
>
> I have read several threads where new ARM programmers like myself have
> encountered a problem where their code (custom board) only runs when
> using the debugger. I have yet to find my problem. I have programmed
> two other ARM boards using the LPC2101 chip with problems. This board
> using the LPC2131 is somehow different.
> The JTAG interface has pulldown and pullup resistors.
> The emulator selection jumper (RTCLK) is left open.
> We have tried manually reseting after power up. the main crystal is
> oscillating.
> P0.31 has a pullup resistor.
>
> My cstartup.s79 and lpc213x.xcl look correct and should create a
> correct crc. How can I check? what are the correct values for the
LPC2131?
>
> Any other suggestion?
>
> I would like to isolate whether this is a software or hardware problem.
> Does anyone have a zipped IAR LPC213x dummy project (including
> lpc213x.xcl,cstartup.s79 files) that I could just change an output to
> see if it runs without the emulator?
>

Hello,

If you just want to know if your hardware is working, *and* you are
prepared to use the ISP interface (as different to JTAG interface),
then simply try install and run SILL on your board.

You can find SILL here at:

http://www.cse.unsw.edu.au/~jayas/esdk/sill.html
Good luck.

Jaya