Forums

LPC2378 KIT JTAG OLIMEX Problem

Started by otomeran August 7, 2009
Hi all,

I have Olimex LPC-2378-STK and OLIMEX ARM-USB-OCD.

When i tried debug simple program(blinking LED), first everythings worked fine, but suddenly board stopped to response.

I cant download program with eclipse. Console report:
Error: embeddedice.c:191 embeddedice_build_reg_cache(): unknown EmbeddedICE version (comms ctrl: 0x00000000)
Error: jtag.c:1351 jtag_examine_chain(): JTAG communication failure, check connection, JTAG interface, target power etc.
Error: jtag.c:1556 jtag_init_inner(): trying to validate configured JTAG chain anyway...
Warning: jtag.c:1211 jtag_check_value(): value captured during scan didn't pass the requested check: captured: 0x00 check_value: 0x01 check_mask: 0x0f
Warning: jtag.c:1171 jtag_read_buffer(): in_handler reported a failed check
User: target.c:436 target_process_reset(): Timed out waiting for halt after reset
I must erase flash with ISP. when i do it, i can download program to procesor, but when i start Debug, error occur.
Execution is suspended because of error.
continue
Warning:
Cannot insert hardware breakpoint 1.
Could not insert hardware breakpoints:
You may have requested too many hardware breakpoints/watchpoints.
It seems like MCU is locked someway.
I have no idea, how it could happened :(

Thank you for you suggestions.

An Engineer's Guide to the LPC2100 Series

The error seems to suggest that you may have too many hardware breakpoints?

Perhaps deleting all the HW breakpoints may help?

Also, make sure you have not enabled SLEEP mode or WATCHDOG because they can
both cause problems while debugging through JTAG.

Tech Support

TTE Systems

www.tte-systems.com
Thank you for reply.

I deleted all breakpoints. result is still same.
i think, that Blinking Led project dont set any watchdog or sleep processor mode.

Another strange thing: when i download program trought ISP, and set go, program dont running.

Thank for another suggestions