ODDBALL BEHAVIOUR FROM IAR

Started by OneStone July 26, 2009
Hi guys, I have a strange one from IAR, or at least it seems like IAR,
but may be a combination. I was using slac050r version of Kickstart on
an MSP430F2132 design. Every time I tried a download it reported that
the device detected was an MSP430F21X1 not an MSP430F2132 and asked if I
wanted to continue, so i just carried on as I didn't want to disturb any
of the other projects under that workbook by updating, as I thought that
was all the problem was. Then I needed to use a bit more RAM than i had
previously done, just to run a data test, so I allocated a 256 byte
buffer at the start of RAM, and recompiled and attempted to download,
same error message, but this time the download aborted part way through
saying it failed to write memory at 0X0325, which of course should eb a
RAM location. Strange. So I bit the bullet and decided to update,
downloaded the very latest Kickstart, which is Slac050u, I thick IAr
4.0.2 or similar. Of course the interface has changed, but this time it
still reports the wrong device type only now instead of reporting the
failure to write memory it simply hangs and I have to close IAR and
restart it. So far I have found no work around. It isn't just this part.
I've tried several boards from 2 batches.

Any ideas would be muchly appreciated.

Cheers

Al

Beginning Microcontrollers with the MSP430