Forums

MSP430 IAR error

Started by Hithesh March 18, 2010
Hi group, I am just getting started on MSP430. I am using or trying to use
the IAR kickstart for coding. I don't have any hardware connected yet.
I am trying to use IAR in the simulation mode. But I am getting couple of
errors.
The program is an example code by TI in assembly.
Here are the steps I am following:
Create new project--then add existing file(the assembly file)--project
options -- simulation -- select msp430F2274.

I click project -- make -- debug without download.

When I try to step in to the code, I get " illegal operator main in col1"
and then "illegal opcode found at 0x00"

Screenshot attached.
Any help would he great.


Beginning Microcontrollers with the MSP430

You use "debug without download". So you are debugging what was in the Flash Memory, which was not the code you made and was an "illegal operator".

--- In m..., Hithesh wrote:
>
> Hi group, I am just getting started on MSP430. I am using or trying to use
> the IAR kickstart for coding. I don't have any hardware connected yet.
> I am trying to use IAR in the simulation mode. But I am getting couple of
> errors.
> The program is an example code by TI in assembly.
> Here are the steps I am following:
> Create new project--then add existing file(the assembly file)--project
> options -- simulation -- select msp430F2274.
>
> I click project -- make -- debug without download.
>
> When I try to step in to the code, I get " illegal operator main in col1"
> and then "illegal opcode found at 0x00"
>
> Screenshot attached.
> Any help would he great.
>
>