thanx for replies Re: 12f675. help still needed!!!!

Started by shaunundergrad August 9, 2003
hi guys,
yes you're all quite right i misunderstood conditional assembly
directives. now i know no wonder it would not work....full 14 hrs on
it aswell. i can't output the a/d result on the pins as 12f675 only
has 4 available outputs, as gpio,3 input only and gpio,0 as analog,
maybe i could bit check the 4 lsb's, then output to gpio? i'll give
it a go. one other question, i've connected a 1k pot to battery +ive
rail then to gpio,0 from gpio,0 to another 1k pot, then to -ive
battery rail, is this correct? or should i just go from the +rail to
a pot to the pin and the pic sinks it?

regards

shaun





Connect 1 end of the pot to +i, the other end to - and the center tap
to the A/D pin

--- In , "shaunundergrad" <electromechy1@a...>
wrote:
> hi guys,
> yes you're all quite right i misunderstood conditional assembly
> directives. now i know no wonder it would not work....full 14 hrs
on
> it aswell. i can't output the a/d result on the pins as 12f675 only
> has 4 available outputs, as gpio,3 input only and gpio,0 as analog,
> maybe i could bit check the 4 lsb's, then output to gpio? i'll give
> it a go. one other question, i've connected a 1k pot to battery
+ive
> rail then to gpio,0 from gpio,0 to another 1k pot, then to -ive
> battery rail, is this correct? or should i just go from the +rail
to
> a pot to the pin and the pic sinks it?
>
> regards
>
> shaun




hi guys,
many thanx for help, i've actually got it working, i was using pots correctly, but program was a mile out. now i can see register value on 4 leds, obviously msb's but its enough. what a thrill, n


Attachment (not stored)
Sixties Sunflowers .jpg
Type: image/jpeg