Need help with MPLAB

Started by v_clerc_fr August 16, 2004
Hello,

I have installed MPLAB v6.60. I did a very standard installation.
Changed no destination folder, or so...

Here is what I get when following the "MPLAB getting started"...

====================================================================

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
lst" /e"f452temp.err" /o"f452temp.o"
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
/o"test.cof"
MPLINK 3.80, Linker
Copyright (c) 2004 Microchip Technology Inc.
Error - section '.org_3' can not fit the absolute section.
Section '.org_3' start=0x00000018, length=0x0000001c
Errors : 1

BUILD FAILED: Mon Aug 16 20:29:16 2004

====================================================================

I've run this getting started on my home computer and on my office
computer !!!

Same result....

I use the Project wizard, add .asm then add .lkr then "build all".

Is there any known issu with MPLAB and linker!!!
I am considering to use the pic as microcontroller on all my
project. I can not imagine that no one in the world as never
encountered what I describe !!!!

I can even think that no one use MPLAB !!!???

Any guru or people of good will in this group able to help ????

Thanks in advance !
Vincent



First thought, is the asm program a stand alone module/relocatable? If
it is not, don't need linker.

Chad

--- v_clerc_fr <> wrote:

> Hello,
>
> I have installed MPLAB v6.60. I did a very standard installation.
> Changed no destination folder, or so...
>
> Here is what I get when following the "MPLAB getting started"...
>
> ====================================================================
>
> Clean: Deleting intermediary and output files.
> Clean: Done.
> Executing: "C:\Program Files\MPLAB
> IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
> lst" /e"f452temp.err" /o"f452temp.o"
> Executing: "C:\Program Files\MPLAB
> IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
> /o"test.cof"
> MPLINK 3.80, Linker
> Copyright (c) 2004 Microchip Technology Inc.
> Error - section '.org_3' can not fit the absolute section.
> Section '.org_3' start=0x00000018, length=0x0000001c
> Errors : 1
>
> BUILD FAILED: Mon Aug 16 20:29:16 2004
>
> ====================================================================
>
> I've run this getting started on my home computer and on my office
> computer !!!
>
> Same result....
>
> I use the Project wizard, add .asm then add .lkr then "build all".
>
> Is there any known issu with MPLAB and linker!!!
> I am considering to use the pic as microcontroller on all my
> project. I can not imagine that no one in the world as never
> encountered what I describe !!!!
>
> I can even think that no one use MPLAB !!!???
>
> Any guru or people of good will in this group able to help ????
>
> Thanks in advance !
> Vincent >


=====
My software has no bugs, only undocumented features.
__________________________________




Message
Hi Chad,
 
Thanks for reply.
 
The asm program is given in the template directory of MPLABTools.
It's a very small basic example, but the "getting started" ask to add a linker script to the project.
The two files added to the project are located in "MPLAB IDE/MCHIP Tools/TEMPLATES/Code/f452temp.asm" and "MPLAB IDE/MCHIP Tools/LKR/18f452.lkr".
 
 
This leads to the following error :
Error - section '.org_3' can not fit the absolute section.
Section '.org_3' start=0x00000018, length=0x0000001c
 
Am I the only one trying to follow the "getting started" section of the documentation ????
 
I don't understand how such a big community can work with MPLAB while a beginner can not even compile the very first, most straight forward example !!!
 
I'm probably doing something wrong, but where to go know !!
 
Any input would be great !!!
 
Vincent
 
-----Original Message-----
From: Chad Russel [mailto:c...@yahoo.com]
Sent: mardi 17 ao 2004 01:53
To: p...@yahoogroups.com
Subject: Re: [piclist] Need help with MPLAB

First thought, is the asm program a stand alone module/relocatable?  If
it is not, don't need linker.

Chad

--- v_clerc_fr <v...@idtect.com> wrote:

> Hello,
>
> I have installed MPLAB v6.60. I did a very standard installation.
> Changed no destination folder, or so...
>
> Here is what I get when following the "MPLAB getting started"...

>  ====================================================================

> Clean: Deleting intermediary and output files.
> Clean: Done.
> Executing: "C:\Program Files\MPLAB
> IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
> lst" /e"f452temp.err" /o"f452temp.o"
> Executing: "C:\Program Files\MPLAB
> IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
> /o"test.cof"
> MPLINK 3.80, Linker
> Copyright (c) 2004 Microchip Technology Inc.
> Error - section '.org_3' can not fit the absolute section.
> Section '.org_3' start=0x00000018, length=0x0000001c
> Errors    : 1

> BUILD FAILED: Mon Aug 16 20:29:16 2004
>
> ====================================================================

> I've run this getting started on my home computer and on my office
> computer !!!

> Same result....

> I use the Project wizard, add .asm then add .lkr then "build all".

> Is there any known issu with MPLAB and linker!!!
> I am considering to use the pic as microcontroller on all my
> project. I can not imagine that no one in the world as never
> encountered what I describe !!!!
>
> I can even think that no one use MPLAB !!!???

> Any guru or people of good will in this group able to help ????

> Thanks in advance !
> Vincent=====
My software has no bugs, only undocumented features.           
__________________________________to unsubscribe, go to http://www.yahoogroups.com and follow the instructions


Vincent-

I examined the output from my project with only one .asm file in it
and I see no link step involved. I am not sure what the .lkr file
does for the project since I have never had the need to use them. I
would suggest that you don't add any files to your project except a
copy of f542temp.asm and see if that helps you out any.

Good luck,

Trent --- In , "Vincent" <vincent.clerc@i...> wrote:
> Hi Chad,
>
> Thanks for reply.
>
> The asm program is given in the template directory of MPLABTools.
> It's a very small basic example, but the "getting started" ask to
add a
> linker script to the project.
> The two files added to the project are located in "MPLAB IDE/MCHIP
> Tools/TEMPLATES/Code/f452temp.asm" and "MPLAB IDE/MCHIP
> Tools/LKR/18f452.lkr". > This leads to the following error :
> Error - section '.org_3' can not fit the absolute section.
> Section '.org_3' start=0x00000018, length=0x0000001c
>
> Am I the only one trying to follow the "getting started" section of
the
> documentation ????
>
> I don't understand how such a big community can work with MPLAB
while a
> beginner can not even compile the very first, most straight forward
> example !!!
>
> I'm probably doing something wrong, but where to go know !!
>
> Any input would be great !!!
>
> Vincent > -----Original Message-----
> From: Chad Russel [mailto:chadrussel@y...]
> Sent: mardi 17 ao 2004 01:53
> To:
> Subject: Re: [piclist] Need help with MPLAB > First thought, is the asm program a stand alone module/relocatable?
If
> it is not, don't need linker.
>
> Chad
>
> --- v_clerc_fr <vincent.clerc@i...> wrote:
>
> > Hello,
> >
> > I have installed MPLAB v6.60. I did a very standard installation.
> > Changed no destination folder, or so...
> >
> > Here is what I get when following the "MPLAB getting started"...
> >
> > =============================================
=======================
> >
> > Clean: Deleting intermediary and output files.
> > Clean: Done.
> > Executing: "C:\Program Files\MPLAB
> > IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm"
/l"f452temp.
> > lst" /e"f452temp.err" /o"f452temp.o"
> > Executing: "C:\Program Files\MPLAB
> > IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\W
UTemp\test\f452temp.o"
> > /o"test.cof"
> > MPLINK 3.80, Linker
> > Copyright (c) 2004 Microchip Technology Inc.
> > Error - section '.org_3' can not fit the absolute section.
> > Section '.org_3' start=0x00000018, length=0x0000001c
> > Errors : 1
> >
> > BUILD FAILED: Mon Aug 16 20:29:16 2004
> >
> > ==============================================
======================
> >
> > I've run this getting started on my home computer and on my
office
> > computer !!!
> >
> > Same result....
> >
> > I use the Project wizard, add .asm then add .lkr then "build all".
> >
> > Is there any known issu with MPLAB and linker!!!
> > I am considering to use the pic as microcontroller on all my
> > project. I can not imagine that no one in the world as never
> > encountered what I describe !!!!
> >
> > I can even think that no one use MPLAB !!!???
> >
> > Any guru or people of good will in this group able to help ????
> >
> > Thanks in advance !
> > Vincent
> >
> >
> > =====
> My software has no bugs, only undocumented features. >
> __________________________________ > to unsubscribe, go to http://www.yahoogroups.com and follow the
> instructions > <http://us.ard.yahoo.com/SIG9mipalh/M)8184.
5285298.6392945.3001176/
> D=groups/S06554205:HM/EXP92786768/A!6433
1/R=0/SIGeaelai9/*htt
> p://www.netflix.com/Default?mqso`183351> click here
>
> <http://us.adserver.yahoo.com/l?M)8184.5285298
.6392945.3001176/D=group
> s/S=:HM/A!64331/randf1285136 > _____
>
> > .





Message
Hello Trent,
 
You were right !! I just removed the .lkr and have no problem at all...
 
Thanks a lot for the helping hand.
 
Actually, I don't understand the "getting started" goal. Why use the linker with a single asm involved.
 
... This is not clear !!
 
Any comment from the community is welcome !!!
 
Thanks a lot !!!
 
Vince
 
 
 -----Original Message-----
From: Trent [mailto:s...@yahoo.com]
Sent: mardi 17 ao 2004 10:55
To: p...@yahoogroups.com
Subject: [piclist] Re: Need help with MPLAB

Vincent-

I examined the output from my project with only one .asm file in it
and I see no link step involved.  I am not sure what the .lkr file
does for the project since I have never had the need to use them.  I
would suggest that you don't add any files to your project except a
copy of f542temp.asm and see if that helps you out any.

Good luck,

Trent--- In p...@yahoogroups.com, "Vincent" <vincent.clerc@i...> wrote:
> Hi Chad,

> Thanks for reply.

> The asm program is given in the template directory of MPLABTools.
> It's a very small basic example, but the "getting started" ask to
add a
> linker script to the project.
> The two files added to the project are located in "MPLAB IDE/MCHIP
> Tools/TEMPLATES/Code/f452temp.asm" and "MPLAB IDE/MCHIP
> Tools/LKR/18f452.lkr".


> This leads to the following error :
> Error - section '.org_3' can not fit the absolute section.
> Section '.org_3' start=0x00000018, length=0x0000001c

> Am I the only one trying to follow the "getting started" section of
the
> documentation ????

> I don't understand how such a big community can work with MPLAB
while a
> beginner can not even compile the very first, most straight forward
> example !!!

> I'm probably doing something wrong, but where to go know !!

> Any input would be great !!!

> Vincent

>
> -----Original Message-----
> From: Chad Russel [mailto:chadrussel@y...]
> Sent: mardi 17 ao 2004 01:53
> To: p...@yahoogroups.com
> Subject: Re: [piclist] Need help with MPLAB> First thought, is the asm program a stand alone module/relocatable?
If
> it is not, don't need linker.
>
> Chad
>
> --- v_clerc_fr <vincent.clerc@i...> wrote:
>
> > Hello,
> >
> > I have installed MPLAB v6.60. I did a very standard installation.
> > Changed no destination folder, or so...
> >
> > Here is what I get when following the "MPLAB getting started"...
> > 
> >  =============================================
=======================
> > 
> > Clean: Deleting intermediary and output files.
> > Clean: Done.
> > Executing: "C:\Program Files\MPLAB
> > IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm"
/l"f452temp.
> > lst" /e"f452temp.err" /o"f452temp.o"
> > Executing: "C:\Program Files\MPLAB
> > IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\W
UTemp\test\f452temp.o"
> > /o"test.cof"
> > MPLINK 3.80, Linker
> > Copyright (c) 2004 Microchip Technology Inc.
> > Error - section '.org_3' can not fit the absolute section.
> > Section '.org_3' start=0x00000018, length=0x0000001c
> > Errors    : 1
> > 
> > BUILD FAILED: Mon Aug 16 20:29:16 2004
> >
> > ==============================================
======================
> > 
> > I've run this getting started on my home computer and on my
office
> > computer !!!
> > 
> > Same result....
> > 
> > I use the Project wizard, add .asm then add .lkr then "build all".
> > 
> > Is there any known issu with MPLAB and linker!!!
> > I am considering to use the pic as microcontroller on all my
> > project. I can not imagine that no one in the world as never
> > encountered what I describe !!!!
> >
> > I can even think that no one use MPLAB !!!???
> > 
> > Any guru or people of good will in this group able to help ????
> > 
> > Thanks in advance !
> > Vincent
> >
> >
> > =====
> My software has no bugs, only undocumented features.>            
> __________________________________> to unsubscribe, go to http://www.yahoogroups.com and follow the
> instructions>
>

> <http://us.ard.yahoo.com/SIG9mipalh/M)8184.
5285298.6392945.3001176/
> D=groups/S06554205:HM/EXP92786768/A!6433
1/R=0/SIGeaelai9/*htt
> p://www.netflix.com/Default?mqso`183351> click here     

> <http://us.adserver.yahoo.com/l?M)8184.5285298
.6392945.3001176/D=group
> s/S=:HM/A!64331/randf1285136>      >   _____ 
>
> > .



to unsubscribe, go to http://www.yahoogroups.com and follow the instructions


Microchip’s documentation sucks, their MPLAB sucks, etc.

 

I have been using Microchip for about 2 years now and have no idea why they are so popular. The tools for Microchip really suck as compared to real development tools. I guess people accept the poor quality when it is free…

 

Regards,

Trampas

 

 

-----Original Message-----
From: v_clerc_fr [mailto:v...@idtect.com]
Sent:
Monday, August 16, 2004 5:55 PM
To: p...@yahoogroups.com
Subject: [piclist] Need help with MPLAB

 

Hello,

I have installed MPLAB v6.60. I did a very standard installation.
Changed no destination folder, or so...

Here is what I get when following the "MPLAB getting started"...

====================================================================

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
lst" /e"f452temp.err" /o"f452temp.o"
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
/o"test.cof"
MPLINK 3.80, Linker
Copyright (c) 2004 Microchip Technology Inc.
Error - section '.org_3' can not fit the absolute section.
Section '.org_3' start=0x00000018, length=0x0000001c
Errors    : 1

BUILD FAILED: Mon Aug 16
20:29:16 2004

====================================================================

I've run this getting started on my home computer and on my office
computer !!!

Same result....

I use the Project wizard, add .asm then add .lkr then "build all".

Is there any known issu with MPLAB and linker!!!
I am considering to use the pic as microcontroller on all my
project. I can not imagine that no one in the world as never
encountered what I describe !!!!

I can even think that no one use MPLAB !!!???

Any guru or people of good will in this group able to help ????

Thanks in advance !
Vincent


to unsubscribe, go to http://www.yahoogroups.com and follow the instructions




Hi

 

A manufacturer of a very competitive product doesn’t get to sell more chips than anyone else if it’s not a good product.  If you have that attitude then maybe you should have started using something else long time ago.  Apart from 16 years of Microchip experience I also work with ARM, ATMEL and Motorola but I tell you that Microchip have a fantastic line of products.  Open source, Linux and many other fantastic technologies have one thing in common with Microchip – a huge happy user base!!

 

Regards

Martin

 

PS: I make a living from embedded developing and only use genuine Microchip products.

 

 

 

 

From: Trampas [mailto:t...@nc.rr.com]
Sent: Wednesday, 18 August 2004 0:00
To: p...@yahoogroups.com
Subject: RE: [piclist] Need help with MPLAB

 

Microchip’s documentation sucks, their MPLAB sucks, etc.

 

I have been using Microchip for about 2 years now and have no idea why they are so popular. The tools for Microchip really suck as compared to real development tools. I guess people accept the poor quality when it is free…

 

Regards,

Trampas

 

 

-----Original Message-----
From: v_clerc_fr [mailto:v...@idtect.com]
Sent: Monday, August 16, 2004 5:55 PM
To: p...@yahoogroups.com
Subject: [piclist] Need help with MPLAB

 

Hello,

I have installed MPLAB v6.60. I did a very standard installation.
Changed no destination folder, or so...

Here is what I get when following the "MPLAB getting started"...

====================================================================

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
lst" /e"f452temp.err" /o"f452temp.o"
Executing: "C:\Program Files\MPLAB
IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
/o"test.cof"
MPLINK 3.80, Linker
Copyright (c) 2004 Microchip Technology Inc.
Error - section '.org_3' can not fit the absolute section.
Section '.org_3' start=0x00000018, length=0x0000001c
Errors    : 1

BUILD FAILED: Mon Aug 16 20:29:16 2004

====================================================================

I've run this getting started on my home computer and on my office
computer !!!

Same result....

I use the Project wizard, add .asm then add .lkr then "build all".

Is there any known issu with MPLAB and linker!!!
I am considering to use the pic as microcontroller on all my
project. I can not imagine that no one in the world as never
encountered what I describe !!!!

I can even think that no one use MPLAB !!!???

Any guru or people of good will in this group able to help ????

Thanks in advance !
Vincent


to unsubscribe, go to http://www.yahoogroups.com and follow the instructions




to unsubscribe, go to http://www.yahoogroups.com and follow the instructions



--- In , "Trampas" <tstern@n...> wrote:
> Microchip's documentation sucks, their MPLAB sucks, etc. >
> I have been using Microchip for about 2 years now and have no idea
why they
> are so popular. The tools for Microchip really suck as compared to real
> development tools. I guess people accept the poor quality when it is
free.
> Regards,
>
> Trampas
>
<<< snip >>>

I see the problem this way:
1. The advanced user does not check out the tutorial samples.
2. The new user does, but does not know enough to tell Microchip they
have a problem.
3. Perhaps in a group like this, where the two users meet, some
constructive critisism can be generated for Microchip, other than
"your software sucks."

Chad


I am fairly critical of Microchip in a number of places but I totally
disagree with your sentiment. Sure, they have room to improve -
klunky architecture and performance, for examples. However, I think
there is a fantastic amount of support (not just datasheets but tons
of ap notes, 3rd party circuits, this forum, books,...), they (and
3rd parties) have an EXTENSIVE array of development tools (many free,
almost all the rest are low cost) and a great attitude towards the
small developer (and even hobbiest). Let us also not forget really
amazing prices. There is no other chip line that is as broadly
supported as PIC. period.

Lets not froget that these are microcontrollers, not computers.
Perhaps you are trying to do things with the product line that simply
aren't appropriate. If your ap needs lots of memory, for example,
forget PICs. But for an incredible number of applications, there's a
PIC that's a great fit.

Personally, I like the Atmel architecture better but that doesn't
diminish my respect for the PIC line and Microchip, the company.

--- In , "Trampas" <tstern@n...> wrote:
> Microchip's documentation sucks, their MPLAB sucks, etc. >
> I have been using Microchip for about 2 years now and have no idea
why they
> are so popular. The tools for Microchip really suck as compared to
real
> development tools. I guess people accept the poor quality when it
is free.
> Regards,
>
> Trampas > -----Original Message-----
> From: v_clerc_fr [mailto:vincent.clerc@i...]
> Sent: Monday, August 16, 2004 5:55 PM
> To:
> Subject: [piclist] Need help with MPLAB >
> Hello,
>
> I have installed MPLAB v6.60. I did a very standard installation.
> Changed no destination folder, or so...
>
> Here is what I get when following the "MPLAB getting started"...
>
> ====================================================================
>
> Clean: Deleting intermediary and output files.
> Clean: Done.
> Executing: "C:\Program Files\MPLAB
>
IDE\MCHIP_Tools\mpasmwin.exe" /q /p18F452 "f452temp.asm" /l"f452temp.
> lst" /e"f452temp.err" /o"f452temp.o"
> Executing: "C:\Program Files\MPLAB
>
IDE\MCHIP_Tools\mplink.exe" "18f452.lkr" "C:\WUTemp\test\f452temp.o"
> /o"test.cof"
> MPLINK 3.80, Linker
> Copyright (c) 2004 Microchip Technology Inc.
> Error - section '.org_3' can not fit the absolute section.
> Section '.org_3' start=0x00000018, length=0x0000001c
> Errors : 1
>
> BUILD FAILED: Mon Aug 16 20:29:16 2004
>
> ====================================================================
>
> I've run this getting started on my home computer and on my office
> computer !!!
>
> Same result....
>
> I use the Project wizard, add .asm then add .lkr then "build all".
>
> Is there any known issu with MPLAB and linker!!!
> I am considering to use the pic as microcontroller on all my
> project. I can not imagine that no one in the world as never
> encountered what I describe !!!!
>
> I can even think that no one use MPLAB !!!???
>
> Any guru or people of good will in this group able to help ????
>
> Thanks in advance !
> Vincent >
>
> to unsubscribe, go to http://www.yahoogroups.com and follow the
instructions
>
<http://us.ard.yahoo.com/SIG9d2huob/M)8184.5285298.6392945.300117
6/D=gr
>
oups/S06554205:HM/EXP92779686/A!64330/R=0/SIGeamf8g4/*http:
/www.n
> etflix.com/Default?mqso`183350> click here >
> <http://us.adserver.yahoo.com/l?
M)8184.5285298.6392945.3001176/D=groups/S=
> :HM/A!64330/randY2936972 >
> _____
>
> > Service.




Great! I'm glad I could be of some help. I have not studied the
Getting Started section of the manuals recently but it does sound like
their example is mis-leading. I am not going to bash the company too
much for it but I have noticed several people in this group mention
from time to time that Microchip's documentation sometimes has errors
in it that they don't go back and correct. Sometimes they will
silently put put an errata document that corrects some of the original
errors but it can be hard to track the information down sometimes.
That's the great thing about groups like this which have helped me
over and over again.

Have fun,
Trent --- In , "Vincent" <vincent.clerc@i...> wrote:
> Hello Trent,
>
> You were right !! I just removed the .lkr and have no problem at
all...
>
> Thanks a lot for the helping hand.
>
> Actually, I don't understand the "getting started" goal. Why use the
> linker with a single asm involved.
>
> ... This is not clear !!
>
> Any comment from the community is welcome !!!
>
> Thanks a lot !!!
>
> Vince
> <http://www.idtect.com/>
>