Problem in linking with metrowerks V1.0

Started by Florent VERRIERE May 27, 2003
We use Metrowerks V1.0 to develop on a mc9s12dp256 and need to copy a project in a new one with a new directory name.

After have create a new project , files and copy of sources, it is impossible to
link our application
In fact, compilation of different library is done without problem but for linking we have:

First message:

L4004: Linking (path)MC9S12DP256_BANKED.PRM as ELF/DWARF format link parameter file

And after for each file :

L1923: File (path)start12.c.o has no DWARF debug info

after :

Link Error : L1700: File start12.c.o should contain DWARF information

L1823 : External object oBjetctName in (path)fileName.c.o created by default

and some message:

Link Error : L11822: Symbol ... is undefined Thank you for your help.
Florent VERRIERE.

J.SAURON S.A. / Micro Plus




Hi!

Check Access Paths of your project from the 'Target Settings panels'.
It seems that your linker cannot find some of the project files.

Juuso Kaitalo
Honeywell, Industrial Automation & Control
-----Original Message-----
From: Florent VERRIERE [mailto:]
Sent: 27. toukokuuta 2003 15:55
To:
Subject: [68HC12] Problem in linking with metrowerks V1.0 We use Metrowerks V1.0 to develop on a mc9s12dp256 and need to copy a
project in a new one with a new directory name.

After have create a new project , files and copy of sources, it is
impossible to
link our application
In fact, compilation of different library is done without problem but for
linking we have:

First message:

L4004: Linking (path)MC9S12DP256_BANKED.PRM as ELF/DWARF
format link parameter file

And after for each file :

L1923: File (path)start12.c.o has no DWARF debug info

after :

Link Error : L1700: File start12.c.o should contain DWARF
information

L1823 : External object oBjetctName in (path)fileName.c.o
created by default

and some message:

Link Error : L11822: Symbol ... is undefined Thank you for your help.
Florent VERRIERE.

J.SAURON S.A. / Micro Plus --------------------
">http://docs.yahoo.com/info/terms/



The "L1923: File (path)start12.c.o has no DWARF debug info" message means that the
generate debug info mark is not set in the project window.
You can enable the debug info by clicking in the last column in the project window in the files tab.
There should be a black dot beside every *.c file. Alternatively you can set the "Debug Info" option also
in the Project Inspector, which is launched by the last button in the toolbar of the Project window.

The "Link Error : L11822: Symbol ... is undefined" message means that you are using "..." somewhere, but you do not define it.
Without knowing what actually appears for "...", I can't help much. If it is something unfamiliar starting with an underscore, then
you probably need to add the runtime support
to your project. The runtime support is provided as part of the ANSI library. As tip check one of the stationaries how its done
there.

Bye

Daniel > -----Original Message-----
> From: Kaitalo, Juuso (FI06) [mailto:]
> Sent: Tuesday, May 27, 2003 15:04
> To:
> Subject: RE: [68HC12] Problem in linking with metrowerks V1.0 > Hi!
>
> Check Access Paths of your project from the 'Target Settings panels'.
> It seems that your linker cannot find some of the project files.
>
> Juuso Kaitalo
> Honeywell, Industrial Automation & Control >
> -----Original Message-----
> From: Florent VERRIERE [mailto:]
> Sent: 27. toukokuuta 2003 15:55
> To:
> Subject: [68HC12] Problem in linking with metrowerks V1.0 > We use Metrowerks V1.0 to develop on a mc9s12dp256 and need to copy a
> project in a new one with a new directory name.
>
> After have create a new project , files and copy of sources, it is
> impossible to
> link our application
> In fact, compilation of different library is done without problem but for
> linking we have:
>
> First message:
>
> L4004: Linking (path)MC9S12DP256_BANKED.PRM as ELF/DWARF
> format link parameter file
>
> And after for each file :
>
> L1923: File (path)start12.c.o has no DWARF debug info
>
> after :
>
> Link Error : L1700: File start12.c.o should contain DWARF
> information
>
> L1823 : External object oBjetctName in (path)fileName.c.o
> created by default
>
> and some message:
>
> Link Error : L11822: Symbol ... is undefined > Thank you for your help.
> Florent VERRIERE.
>
> J.SAURON S.A. / Micro Plus > -------------------- >
> ">http://docs.yahoo.com/info/terms/ >
> -------------------- >
> ">http://docs.yahoo.com/info/terms/




Thank you Daniel, it works.

Best regards,
Florent.
----- Original Message -----
From: "Daniel Friederich" <>
To: <>
Sent: Tuesday, May 27, 2003 4:19 PM
Subject: RE: [68HC12] Problem in linking with metrowerks V1.0 > The "L1923: File (path)start12.c.o has no DWARF debug info" message means
that the
> generate debug info mark is not set in the project window.
> You can enable the debug info by clicking in the last column in the
project window in the files tab.
> There should be a black dot beside every *.c file. Alternatively you can
set the "Debug Info" option also
> in the Project Inspector, which is launched by the last button in the
toolbar of the Project window.
>
> The "Link Error : L11822: Symbol ... is undefined" message means that you
are using "..." somewhere, but you do not define it.
> Without knowing what actually appears for "...", I can't help much. If it
is something unfamiliar starting with an underscore, then
> you probably need to add the runtime support
> to your project. The runtime support is provided as part of the ANSI
library. As tip check one of the stationaries how its done
> there.
>
> Bye
>
> Daniel > > -----Original Message-----
> > From: Kaitalo, Juuso (FI06) [mailto:]
> > Sent: Tuesday, May 27, 2003 15:04
> > To:
> > Subject: RE: [68HC12] Problem in linking with metrowerks V1.0
> >
> >
> > Hi!
> >
> > Check Access Paths of your project from the 'Target Settings panels'.
> > It seems that your linker cannot find some of the project files.
> >
> > Juuso Kaitalo
> > Honeywell, Industrial Automation & Control
> >
> >
> >
> > -----Original Message-----
> > From: Florent VERRIERE [mailto:]
> > Sent: 27. toukokuuta 2003 15:55
> > To:
> > Subject: [68HC12] Problem in linking with metrowerks V1.0
> >
> >
> > We use Metrowerks V1.0 to develop on a mc9s12dp256 and need to copy a
> > project in a new one with a new directory name.
> >
> > After have create a new project , files and copy of sources, it is
> > impossible to
> > link our application
> > In fact, compilation of different library is done without problem but
for
> > linking we have:
> >
> > First message:
> >
> > L4004: Linking (path)MC9S12DP256_BANKED.PRM as ELF/DWARF
> > format link parameter file
> >
> > And after for each file :
> >
> > L1923: File (path)start12.c.o has no DWARF debug info
> >
> > after :
> >
> > Link Error : L1700: File start12.c.o should contain
DWARF
> > information
> >
> > L1823 : External object oBjetctName in
(path)fileName.c.o
> > created by default
> >
> > and some message:
> >
> > Link Error : L11822: Symbol ... is undefined
> >
> >
> > Thank you for your help.
> > Florent VERRIERE.
> >
> > J.SAURON S.A. / Micro Plus
> >
> >
> >
> >
> >
> >
> >
> >
> > --------------------
> >
> >
> >
> > ">http://docs.yahoo.com/info/terms/
> >
> >
> >
> > --------------------
> >
> >
> >
> > ">http://docs.yahoo.com/info/terms/
> >
> >
> -------------------- >
> ">http://docs.yahoo.com/info/terms/ >