Forums

Problem with comms beween board and PC

Started by pickleza March 7, 2005

Hi all,

I am having a couple of problems getting my BDM interface working.

I am using Metrowerks codeWarrior (2, I think) with a P&E BDM
Multilink Programmer on a 68HC12SD64, but am having some problems
with the connections.

I get a BDM speed problem when connecting to the board (Frequency
Change Detected, Could Not Reconnect!). When I try and automatically
detect the frequency, the returned value changes every time.

I get the same thing when I try to connect to my evaluation board
(MC9S12DP256EVB), but only some of the time. But there is another
problem with the evaluation board. I get a "No Programming Voltage"
error when trying to load a program into memory. Also, communication
is lost fairly often.

I was hoping someone here may be of some help.

Thanks
Nicholas




Re: Problem with comms beween board and PC


Hi Nicholas,

I had a problem like that, two years back, for me is was
the CLKSW in BDM control register, see the reply from
Gilles Blanquin at Metrowerks below.

Darren Moore

-----------------------------------
Hi Darren.

If your application changes (even only once) the bus speed via PLL:
-make sure a PLL Loop Filter is installed.
-check the "set CLKSW bit in BDM control register (MC9S12 only)" checkbox
in the "Communication Device Specification" dialog (menu: "ICD-12" then
"Connect...").

If you open a "Command" component, speed variation detections by the cable
should be reported there.

Darren, could you indicate your Metrowerks CodeWarrior version: Typing
"ver" in the "Command" window gives directly a list of DLL versions.

Thanks.

Regards,
Gilles
-----------------------------------

> -----Original Message-----
> From: pickleza [mailto:]
> Sent: Tuesday, 8 March 2005 08:25
> To:
> Subject: [68HC12] Problem with comms beween board and PC >
>
> Hi all,
>
> I am having a couple of problems getting my BDM interface working.
>
> I am using Metrowerks codeWarrior (2, I think) with a P&E BDM
> Multilink Programmer on a 68HC12SD64, but am having some problems
> with the connections.
>
> I get a BDM speed problem when connecting to the board (Frequency
> Change Detected, Could Not Reconnect!). When I try and automatically
> detect the frequency, the returned value changes every time.
>
> I get the same thing when I try to connect to my evaluation board
> (MC9S12DP256EVB), but only some of the time. But there is another
> problem with the evaluation board. I get a "No Programming Voltage"
> error when trying to load a program into memory. Also, communication
> is lost fairly often.
>
> I was hoping someone here may be of some help.
>
> Thanks
> Nicholas >
> Yahoo! Groups Links





Hi Darren,

The "set CLKSW bit in BDM control register (MC9S12 only)" is on. I
see in the datasheet that the PLLSEL Bit also has to be set to switch
to the PLL Clock. How do I do that with BDM?

Nicholas

--- In , "Darren" <djmoore@t...> wrote:
>
>
> Hi Nicholas,
>
> I had a problem like that, two years back, for me is was
> the CLKSW in BDM control register, see the reply from
> Gilles Blanquin at Metrowerks below.
>
> Darren Moore
>
> --------------------------------
---
> Hi Darren.
>
> If your application changes (even only once) the bus speed via PLL:
> -make sure a PLL Loop Filter is installed.
> -check the "set CLKSW bit in BDM control register (MC9S12 only)"
checkbox
> in the "Communication Device Specification" dialog (menu: "ICD-12"
then
> "Connect...").
>
> If you open a "Command" component, speed variation detections by
the cable
> should be reported there.
>
> Darren, could you indicate your Metrowerks CodeWarrior version:
Typing
> "ver" in the "Command" window gives directly a list of DLL versions.
>
> Thanks.
>
> Regards,
> Gilles
> --------------------------------