Memfault Beyond the Launch

uImage not workin

Started by pratibha_275 July 15, 2009

I am making my own uImage by compiling my Angstrom linux but whenever i am copying this image in my at91sam9260 board, it is giving me an error message while booting and working:
No filesystem could mount root, tried: jffs2
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

Can anybody help?
Anybody who is willing to help will probably need these information:

1) What is your command line arguments? (bootargs variable in u-boot)
2) Where are you trying to get your file system, nand? nfs? ramdisk?
3) Your kernel boot log
4) Do you have support for your file system in your kernel config?

Following is the whole information required:



U-Boot 1.3.4 (Dec 12 2008 - 12:13:47)

NAND: 256 MiB
Nb pages: 8192
Page Size: 1056
Size= 8650752 bytes
Logical address: 0xD0000000
Area 0: D0000000 to D00041FF (RO) Bootstrap
Area 1: D0004200 to D00083FF Environment
Area 2: D0008400 to D0041FFF (RO) U-Boot
Area 3: D0042000 to D0251FFF Kernel
Area 4: D0252000 to D083FFFF FS
In: serial
Out: serial
Err: serial
Net: macb0
macb0: Starting autonegotiation...
macb0: Autonegotiation timed out (status=0x7849)
macb0: link down (status: 0x7849)
Hit any key to stop autoboot: 3 2 1 0

NAND read: device 0 offset 0x200000, size 0x172b80
1518464 bytes read: OK
## Booting kernel from Legacy Image at 22200000 ...
Image Name: linux-2.6
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 1518400 Bytes = 1.4 MB
Load Address: 20008000
Entry Point: 20008000
Verifying Checksum ... OK
Loading Kernel Image ... OK

Starting kernel ...

Uncompressing Linux.................................................................................................. done, booting the kernel.
Linux version 2.6.27 (p...@localhost.localdomain) (gcc version 4.2.0 20070413 (prerelease) (CodeSourcery Sourcery G++ Lite 2007q1-10)) #2 Wed Jul 15 15:06:58 IST 2009
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr053177
Machine: Atmel AT91SAM9260-EK
Memory policy: ECC disabled, Data cache writeback
Clocks: CPU 198 MHz, master 99 MHz, main 18.432 MHz
CPU0: D VIVT write-back cache
CPU0: I cache: 8192 bytes, associativity 4, 32 byte lines, 64 sets
CPU0: D cache: 8192 bytes, associativity 4, 32 byte lines, 64 sets
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
Kernel command line: memdM console=ttyS0,115200 root=/dev/mtdblock1 rw rootfstype=jffs2
AT91: 96 gpio irqs in 3 banks
PID hash table entries: 256 (order: 8, 1024 bytes)
Console: colour dummy device 80x30
console [ttyS0] enabled
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 61736KB available (2784K code, 221K data, 120K init)
Calibrating delay loop... 99.12 BogoMIPS (lpjI5616)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
net_namespace: 288 bytes
NET: Registered protocol family 16
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
NetWinder Floating Point Emulator V0.97 (double precision)
JFFS2 version 2.2. (NAND) (SUMMARY) 2001-2006 Red Hat, Inc.
JFS: nTxBlock = 482, nTxLock = 3862
msgmni has been set to 120
io scheduler noop registered
io scheduler anticipatory registered (default)
atmel_usart.0: ttyS0 at MMIO 0xfefff200 (irq = 1) is a ATMEL_SERIAL
atmel_usart.1: ttyS1 at MMIO 0xfffb0000 (irq = 6) is a ATMEL_SERIAL
atmel_usart.2: ttyS2 at MMIO 0xfffb4000 (irq = 7) is a ATMEL_SERIAL
brd: module loaded
loop: module loaded
MACB_mii_bus: probed
eth0: Atmel MACB at 0xfffc4000 irq 21 (3a:1f:34:08:54:54)
eth0: attached PHY driver [Davicom DM9161A] (mii_bus:phy_addrffffff:00, irq=-1)
Driver 'sd' needs updating - please use bus_type methods
usbmon: debugfs is not available
at91_ohci at91_ohci: AT91 OHCI
at91_ohci at91_ohci: new USB bus registered, assigned bus number 1
at91_ohci at91_ohci: irq 20, io mem 0x00500000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
udc: at91_udc version 3 May 2006
mice: PS/2 mouse device common for all mice
i2c /dev entries driver
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
Advanced Linux Sound Architecture Driver Version 1.0.17.
ALSA device list:
No soundcards found.
TCP cubic registered
NET: Registered protocol family 17
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
List of all partitions:
No filesystem could mount root, tried: jffs2
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
On Wednesday 15 July 2009 13:35:54 pratibha_275 wrote:
> Following is the whole information required:

You don't have mtd and nand selected in your kernel configuration. Also your
file system should reside in mtdblock4 not mtdblock1.

Make sure your bootargs are correct. Please give printenv command at u-boot
and send the output.


Can you please send the complete boot log so that it becomes easy to
identify the problem.
Also can you do a printenv at the u-boot prompt and send that output also.
Also, make sure you have your block layer set right - config = MTD2BLOCK.
That was my mistake the first time I did this on buildroot...

B rgds
It was not a big issue. i was trying to program dataflash but i as nor initialising it.
Actually, i had selected the type of dataflash i am using...but i cudnot find the option to initialize in menuconfig. When i was just looking at the .config file i saw dataflash had not been set there so i just initialised it there only and got the prblen solved.

RegardsPratibha SharmaAEM,Noida

Memfault Beyond the Launch