Forums

AT91sam9261 - linux does not execute an elf file.

Started by Paulo Carvalho Silva June 13, 2011
Hi,

I have the following problem:

The at91sam9261ek kit, Atmel does not send the sources in CD, I hate this.
So I download and compile, the bootstrap, u-boot and kernel, the kernel
is booting ok, but I neew graphical interface, as I am a newbie to
graphical interface I realise that will be easy if I copy all files that
belongs to graphica interface from filesystem that Atmel mount when the
kit goes online, I did that withou a problem, but when I try to execute
anyone executable that I copied, I receive the message:

/usr/bin/gpe-confd: not found
/usr/bin/Xfbdev: not found

I think I copied all files that this executables needs, to /etc and
/lib, from Atmel filesystem, all of them are with executable flags, my
kernel are running elf that I compile without problem.
I tried to use ldd from my pc to view the depency of these files, but it
does not recognizes them, obviosly.
My kernel has all options tu runs executables turned on.
Except a.out and ECOFF.

Compiler: arm-none-eabi-gcc from codesourcery.
kernel 2.6.33.

If you need more info please let me know
So I ask, do someone have an ideia why I am having this problem.

Best regards

Paulo










Guys,



Now seems to be obvious, that the problem is the method of
compilation of busybox and application.

Is this correct?



cheers



Paulo



On 13-06-2011 11:11, Paulo Carvalho Silva wrote:
type="cite">
 


Hi,



I have the following problem:



The at91sam9261ek kit, Atmel does not send the sources in
CD, I hate this.

So I download and compile, the bootstrap, u-boot and
kernel, the kernel

is booting ok, but I neew graphical interface, as I am a
newbie to

graphical interface I realise that will be easy if I copy
all files that

belongs to graphica interface from filesystem that Atmel
mount when the

kit goes online, I did that withou a problem, but when I
try to execute

anyone executable that I copied, I receive the message:



/usr/bin/gpe-confd: not found

/usr/bin/Xfbdev: not found



I think I copied all files that this executables needs, to
/etc and

/lib, from Atmel filesystem, all of them are with
executable flags, my

kernel are running elf that I compile without problem.

I tried to use ldd from my pc to view the depency of these
files, but it

does not recognizes them, obviosly.

My kernel has all options tu runs executables turned on.

Except a.out and ECOFF.



Compiler: arm-none-eabi-gcc from codesourcery.

kernel 2.6.33.



If you need more info please let me know

So I ask, do someone have an ideia why I am having this
problem.



Best regards



Paulo




















__._,_.___
Hi Paul,

Please copy the executables to /bin or /usr/bin and the executables should
execute.

If they are not getting executed,please try with a different compiler
version.

Just check if a simple "Hello world" program built with that compiler is
working or not.

Regards
TVRPrasad

On Mon, Jun 13, 2011 at 7:41 PM, Paulo Carvalho Silva <
p...@opensoftware-br.com> wrote:

> Hi,
>
> I have the following problem:
>
> The at91sam9261ek kit, Atmel does not send the sources in CD, I hate this.
> So I download and compile, the bootstrap, u-boot and kernel, the kernel
> is booting ok, but I neew graphical interface, as I am a newbie to
> graphical interface I realise that will be easy if I copy all files that
> belongs to graphica interface from filesystem that Atmel mount when the
> kit goes online, I did that withou a problem, but when I try to execute
> anyone executable that I copied, I receive the message:
>
> /usr/bin/gpe-confd: not found
> /usr/bin/Xfbdev: not found
>
> I think I copied all files that this executables needs, to /etc and
> /lib, from Atmel filesystem, all of them are with executable flags, my
> kernel are running elf that I compile without problem.
> I tried to use ldd from my pc to view the depency of these files, but it
> does not recognizes them, obviosly.
> My kernel has all options tu runs executables turned on.
> Except a.out and ECOFF.
>
> Compiler: arm-none-eabi-gcc from codesourcery.
> kernel 2.6.33.
>
> If you need more info please let me know
> So I ask, do someone have an ideia why I am having this problem.
>
> Best regards
>
> Paulo
>
>
>









Hi TVRPrasad



As you can see in post, the executables are already there.



/usr/bin/gpe-confd: not found

/usr/bin/Xfbdev: not found



Regards



Paulo



On 13-06-2011 21:35, vishnu Tadepalli wrote:
cite="mid:BANLkTi=A...@mail.gmail.com"
type="cite">



Hi Paul,



Please copy the executables to /bin or /usr/bin and the
executables should execute.



If they are not getting executed,please try with a
different compiler version.



Just check if a simple "Hello world" program built with
that compiler is working or not.



Regards

TVRPrasad




On Mon, Jun 13, 2011 at 7:41 PM,
Paulo Carvalho Silva < moz-do-not-send="true"
href="mailto:p...@opensoftware-br.com">p...@opensoftware-br.com>

wrote:







Hi,



I have the following problem:



The at91sam9261ek kit, Atmel does not send the
sources in CD, I hate this.

So I download and compile, the bootstrap,
u-boot and kernel, the kernel

is booting ok, but I neew graphical interface,
as I am a newbie to

graphical interface I realise that will be
easy if I copy all files that

belongs to graphica interface from filesystem
that Atmel mount when the

kit goes online, I did that withou a problem,
but when I try to execute

anyone executable that I copied, I receive the
message:



/usr/bin/gpe-confd: not found

/usr/bin/Xfbdev: not found



I think I copied all files that this
executables needs, to /etc and

/lib, from Atmel filesystem, all of them are
with executable flags, my

kernel are running elf that I compile without
problem.

I tried to use ldd from my pc to view the
depency of these files, but it

does not recognizes them, obviosly.

My kernel has all options tu runs executables
turned on.

Except a.out and ECOFF.



Compiler: arm-none-eabi-gcc from codesourcery.

kernel 2.6.33.



If you need more info please let me know

So I ask, do someone have an ideia why I am
having this problem.



Best regards



Paulo




























__._,_.___