Having Issue with OPenocd + gdb+eclipse+ARM922T when Cache is enabled

Started by vinithakv January 14, 2010

 I am new to OPenocd development environment.I am trying to debug x264
application in a targetboard with ARM922T r0v1.Without enableing cache
everything is fine.I am bale to debug the code,getting output correctly.
But when cache is enabled, a iam not able to run/debug the code.The GDB
load works fine and the code breaks at main.At some point of code i am
enableing I-cache using a swi routine.Then at the end of the code i am
disabling cache and 
put a breakpoint at the end of the code.But the code runs forever.It
does'nt stop at the breakpoint.The same code/elf with I-cache enabled works
fine in Realview debugger.For small routines Cache enabling works.But for a
bigger code like h264 decoder/x264 there seems to be an issue with enabling

My environment:

Centos 5.0
OPenocd r717
x264 application

I am pasting my config file for openocd

#define our ports
telnet_port 4444
gdb_port 3333
gdb_memory_map enable

commands specific to the Olimex ARM-USB-OCD
interface ft2232
ft2232_device_desc "Olimex OpenOCD JTAG"
ft2232_layout "olimex-jtag"

ft2232_vid_pid 0x15ba 0x0003
#ft2232_latency 10

jtag_speed 0	#?
jtag_nsrst_delay 200	#?
jtag_ntrst_delay 200	#?

#jtag_device <IR length> <IR capture> <IR mask> <IDCODE instruction>
jtag_device 4 0x1 0xf 0xe

#daemon_startup <'attach'|'reset'>
daemon_startup reset

#target <type> <endianess> <reset_mode> <jtag#> [variant]
target arm9tdmi little run_and_init 0 arm922t_r0v1

#run_and_halt_time <target#> <time_in_ms>
run_and_halt_time 0 30	#?

#working_area <target#> <address> <size> <'backup'|'nobackup'>
#working_area 0 0x40000000 0x4000 nobackup

Have anyone worked with ARM920t/ARM922t (cache enabled) with openocd +
If anyone have a config file specific to ARM922T please post/send it to


This message was sent using the comp.arch.embedded web interface on