MSP430 JTAG ISO firmware problem

Started by brOS September 16, 2010
Hi all...
I have following problem. When I wanted to debug my project written in IAR
4.2 using Olimex's JTAG ISO, a message popped up saying something like
Olimex firmware version is not supported and it offered me to update
firmware. I said no, but I could not download my project. I tryed again but
this time I said yes when he asked for firmware update. After that I still
can not download my project....But the thing is that now I can not download
using IAR 4.1. Fortunately, I can download projects on my board using IAR
3.x but, when I start debug he keeps asking me If I want to update
firmware. I am afraid if I say yes my FET will be lost, even for IAR

What should I do? I think I have downloaded some kind of firmware into
Olimex's JTAG ISO and now it doesn't work like it should. It used to work
well until that firmware update happened, at least it worked with IAR 4.1.
I am not sure if ever tried it with IAR4.2 before ......

Please help....Thanks in advance !	   
Posted through http://www.EmbeddedRelated.com