Problems Booting TMS320VC5509A from serial EEPROM

Started by Felix Collins April 6, 2004
Hi All,
I am having difficulties getting my TMS320VC5509A to boot from serial 
eeprom. I can successfully boot from USB. I can write and read the 
EEPROM and it appears that the data is being stored in it correctly. I 
can use the same boot table to boot from USB.

When I try to boot from the EEPROM the application does not start 
properly. Using a Flexds JTAG emulator I have read out part of the code 
memory and found that the contents are corrupted. I tend to get bit 
errors periodically through the data. I've tried two different serial 
EEPROMS (16bit addr and 24 bit addr.) but no luck.

In some places the errors come a regular intervals of about 1024 bytes 
but sometimes 1008.  It looks like the Bootloader may be getting 
interupted during the load.

Here is a snippet of the comparison between the USB boot, which works, 
and the EEPROM that doesn't work.

0x0099 0x0099
0x4E07 0x4E07
0x4161 0xC061 <---- error
0x9A48 0x9A48
0x0420 0x0420
0x7600 0x7600

I have tried putting -register_config into the hex55 command file (for 
building the boot table) to set the serial port up the same as we are 
using it to write but not luck here either.

Anyone have any other ideas or similar experiences?

Because the errors are infrequent it is possible for small programs to 
start and run sometimes.

Any comments welcomed.

Felix Collins wrote:
> Hi All, > I am having difficulties getting my TMS320VC5509A to boot from serial
> Cheers, > Felix
Sorry I don't have a quick fix for you but you should also post your message to the C55x group on yahoo. It is dedicated to the TI C55xx DSPs. http://groups.yahoo.com/group/c55x/ -- Scott ExoTech R&D, Inc.