Forums

MSP430 / IAR /CSPY - can't single step execution?

Started by Rob September 11, 2005
I'm running theIAR kickstart samples.

I can compile, build & download to the target ok (MSP430F1121) but can't
single step execution.

The buttons & menu options for STEP / STEP INTO / GO OUT & AUTOSTEP are
greyed out (inactive) as are the same functions when accessed via the
pulldown menus.

The GO execute control works fine. Any ideas what's going on is it a
configuration issue????

thanks
rob


Rob wrote:
> I'm running theIAR kickstart samples. > > I can compile, build & download to the target ok (MSP430F1121) but can't > single step execution. > > The buttons & menu options for STEP / STEP INTO / GO OUT & AUTOSTEP are > greyed out (inactive) as are the same functions when accessed via the > pulldown menus.
Which JTAG adapter are you using? Are you building the Release or Debug configuration in IAR? I.e. does the linker output file format contain debug info? To rule out probs with IAR or JTAG you could also try the NoICE 430 JTAG flasher and debugger (30 day eval): http://www.noicedebugger.com/download/noice_84_MSP430.exe - Jan
"Jan Wagner" <no_spam@thanks.net> wrote in message
news:dg1cld$63u$1@nyytiset.pp.htv.fi...
> Rob wrote: > > I'm running theIAR kickstart samples. > > > > I can compile, build & download to the target ok (MSP430F1121) but can't > > single step execution. > > > > The buttons & menu options for STEP / STEP INTO / GO OUT & AUTOSTEP are > > greyed out (inactive) as are the same functions when accessed via the > > pulldown menus. > > Which JTAG adapter are you using? Are you building the Release or > Debug configuration in IAR? I.e. does the linker output file format > contain debug info? To rule out probs with IAR or JTAG you could > also try the NoICE 430 JTAG flasher and debugger (30 day eval): > http://www.noicedebugger.com/download/noice_84_MSP430.exe > > - Jan
Jan, I'm using a home brew version of the Olimex JTAG hooked to a test board fitted with an 'F149, I've also got a MSP-FET-430x11x board. Both behave the same way when loaded with the corresponding example code. Under <PROJECTS> -> <TARGET> the target is set to debug. I've also checked the CSPY device description files pointed to from <TOOLS> <OPTIONS> CSPY SETUP tab and these are correct. I've got access to a another machine with IAR installed, I might try it on that machine. Thanks for the pointer to NoIce s/w. regards rob
In article <4323f66a$0$27875$5a62ac22@per-qv1-newsreader-
01.iinet.net.au>, rdsfal@yahoo.com.au says...
> I'm running theIAR kickstart samples. > > I can compile, build & download to the target ok (MSP430F1121) but can't > single step execution. > > The buttons & menu options for STEP / STEP INTO / GO OUT & AUTOSTEP are > greyed out (inactive) as are the same functions when accessed via the > pulldown menus. > > The GO execute control works fine. Any ideas what's going on is it a > configuration issue???? > > thanks > rob
Check that you built with the DEBUG configuration, as opposed to the RELEASE configuration under project options. --Gene