Forums

Renesas R8C Start up problem

Started by icegray October 14, 2005
Hi,
I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is
only pull-up.
CPU doesn't start up right. External oscillator doesn't run when I turn
on  power. If I reset the CPU externaly everthing is OK.
Can you recommend something?

On 14 Oct, in article
     <1129293695.675760.124940@g14g2000cwa.googlegroups.com>
     usrdr@yahoo.co.uk "icegray" wrote:

>Hi, >I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is >only pull-up.
What no cap?
>CPU doesn't start up right. External oscillator doesn't run when I turn >on power. If I reset the CPU externaly everthing is OK. >Can you recommend something?
Put a cap between pull up and ground. Are all parts (pull-up, cpu and external oscillator) on the SAME power rail. -- Paul Carpenter | paul@pcserviceselectronics.co.uk <http://www.pcserviceselectronics.co.uk/> PC Services <http://www.gnuh8.org.uk/> GNU H8 & mailing list info <http://www.badweb.org.uk/> For those web sites you hate
icegray wrote:
> Hi, > I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is > only pull-up. > CPU doesn't start up right. External oscillator doesn't run when I turn > on power. If I reset the CPU externaly everthing is OK. > Can you recommend something?
At least in R8C/1x series the external osc is not supposed to start when you reset the CPU. It must be started by firmware. Also, the built-in reset circuit in R8C/11 and /13 is designed to operate at +5V - check is parameters in the data sheet. For 3V operation an external RC circuit is needed.
there is a capacitor between reset pin and gnd, also there are 10uF and
some 100nF between Vcc and GND. all component power line is same.
Xout pin -one pin of oscillator- connected to CPLD.

What a stupid problem.

Thanks

Problem is values of resistor and capacitor on the reset circuit. 22K
and 100nF are true values

"icegray" <usrdr@yahoo.co.uk> wrote in message
news:1129374479.298473.33730@o13g2000cwo.googlegroups.com...
> there is a capacitor between reset pin and gnd, also there are 10uF
and
> some 100nF between Vcc and GND. all component power line is same. > Xout pin -one pin of oscillator- connected to CPLD. > > What a stupid problem.
Maybe the problem is not with the Reset pull-up, but with Vcc ramping up too slow. 10uF is not extremely large, but if power leads are long the LC combination may make Vcc ramp up too slow when you apply power. I've had problems with this when tinkering around and using long, skinny clip leads to connect power. Also perhaps not enough capacitance on external osc to start reliably.
>Hi, >I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is >only pull-up. >CPU doesn't start up right. External oscillator doesn't run when I turn >on power. If I reset the CPU externaly everthing is OK. >Can you recommend something? > >
Hi The damn thing giving me the same problem. there is a pull up resistor 5k from reset pin to vcc. vcc 5v manual grounding of reset is not working , power on reset not working some times it resets but rarely. is there a desing problem in the renesas ? Narender
narender64 wrote:
>> Hi, >> I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is >> only pull-up. >> CPU doesn't start up right. External oscillator doesn't run when I turn >> on power. If I reset the CPU externaly everthing is OK. >> Can you recommend something? >> >> > > Hi The damn thing giving me the same problem. > there is a pull up resistor 5k from reset pin to vcc. vcc 5v > manual grounding of reset is not working , power on reset not working > some times it resets but rarely. > is there a desing problem in the renesas ? > Narender
Which R8C variant do you use? Some (like /12) don't provide internal reset at all. Some may use reset ONLY if supplied from 5V. Only the new ones from /2x family provide internal reset at lower suply voltages and only if the rising time condition is met.
"narender64" <narender@saineni.net> wrote in message 
news:1-ednZ6Au8-M29TbnZ2dnUVZ_oipnZ2d@giganews.com...
> >Hi, >>I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset circuit is >>only pull-up. >>CPU doesn't start up right. External oscillator doesn't run when I turn >>on power. If I reset the CPU externaly everthing is OK. >>Can you recommend something? >> >> > > Hi The damn thing giving me the same problem. > there is a pull up resistor 5k from reset pin to vcc. vcc 5v > manual grounding of reset is not working , power on reset not working > some times it resets but rarely. > is there a desing problem in the renesas ? > Narender
Perhaps you need an RC on reset pin. Add a 1uf cap from RESET to GND and see if that helps.
narender64 wrote:
> >> I have used LM1086-3.3 lowdrop regulator and R8C cpu. Reset >> circuit is only pull-up. CPU doesn't start up right. External >> oscillator doesn't run when I turn on power. If I reset the CPU >> externaly everthing is OK. > > Hi The damn thing giving me the same problem. there is a pull up > resistor 5k from reset pin to vcc. vcc 5v manual grounding of > reset is not working , power on reset not working some times it > resets but rarely. is there a desing problem in the renesas ?
What is a 'desing problem'? -- <http://www.cs.auckland.ac.nz/~pgut001/pubs/vista_cost.txt> <http://www.securityfocus.com/columnists/423> <http://www.aaxnet.com/editor/edit043.html> <http://kadaitcha.cx/vista/dogsbreakfast/index.html> cbfalconer at maineline dot net -- Posted via a free Usenet account from http://www.teranews.com