LPC 2387 with LPC 2368 settings.

Started by don_diego_1635 April 2, 2008
Hi All,

I soldered and wrapped a LPC 2387, then I connected Flash Magic 4.18
on the UART0 and I saw the flash display memory, tried a fill and it
worked.

I compiled a known program with a LPC 2368 setting in Keil MDK-ARM 3.2
instead of LPC 2387 because the device is not the project options of
the Keil toolchain or IAR KickStart, then I downloaded the hex file in
the chip and tried to run the program.

Nothing, the program doesn't work and after when I wanted to return
into the device with Flash Magic I obtained the following message :

Operation Failed. (failed to autobaud - step 1).

I can't connect to the chip.

I thought if I took a very close relative of the LPC 2387, like the
LPC 2368, I will not have problems because there are very similar in
flash size, addresses modes and so on.

Now I saw it doesn't work at all.

I have made a mistake with this assumption.

Did I lost my chip ?

I would like to know if it is possible to recover my chip with Flash
Magic and then wait for a version of Keil or IAR that supports the LPC
2387.
Regards.

An Engineer's Guide to the LPC2100 Series