Forums

Wiggler with WinXP

Started by Thomas Motz November 27, 2004
Hi all,

I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD 
Commander.

Under Win2K it works fine. On my new PC under WinXP it fails.
Commander gives the message "Adapter not connected"
A parallel printer works fine on this LPT Port.

Macraigor wrote that the Commander works with Win XP.
Has anybody used this combination? Do I need special drivers
for LPT Port under WinXP?

Thanks and Regards
Thomas
thomas dot motz at gmx dot net



"Thomas Motz" <thomas.motz@gmx.net> wrote in message 
news:co9ocv$ljb$1@ngspool-d02.news.aol.com...
> Hi all, > > I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD > Commander. > > Under Win2K it works fine. On my new PC under WinXP it fails. > Commander gives the message "Adapter not connected" > A parallel printer works fine on this LPT Port. > > Macraigor wrote that the Commander works with Win XP. > Has anybody used this combination? Do I need special drivers > for LPT Port under WinXP?
I use both a genuine Wiggler and my own design I/F without any problems under WinXP. You must have the printer port set for 'EPP', that is the most likely cause of your problem. Leon -- Leon Heller, G1HSM http://www.geocities.com/leon_heller http://www.kasamba.com/viewExpert.asp?conMemID=105725&Catid=1111&banID=2100
"Leon Heller" <leon_heller@hotmail.com> schrieb im Newsbeitrag 
news:41a8691e$0$19159$cc9e4d1f@news-text.dial.pipex.com...
> "Thomas Motz" <thomas.motz@gmx.net> wrote in message > news:co9ocv$ljb$1@ngspool-d02.news.aol.com... >> Hi all, >> >> I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD >> Commander. >> >> Under Win2K it works fine. On my new PC under WinXP it fails.
> I use both a genuine Wiggler and my own design I/F without any problems > under WinXP. You must have the printer port set for 'EPP', that is the > most likely cause of your problem. > > Leon > --
Dear Leon, thanks for your reply. A lot of reboots later I tested all possible configurations for the LPT Port. Unfortunateley the Fail-Message was constant. Your own I/F replaces the OCD Commander I think, so the Problem possibly depends on the Commander Software. Thomas
"Thomas Motz" <thomas.motz@gmx.net> wrote in message 
news:coa2tu$8j9$1@ngspool-d02.news.aol.com...
> > "Leon Heller" <leon_heller@hotmail.com> schrieb im Newsbeitrag > news:41a8691e$0$19159$cc9e4d1f@news-text.dial.pipex.com... >> "Thomas Motz" <thomas.motz@gmx.net> wrote in message >> news:co9ocv$ljb$1@ngspool-d02.news.aol.com... >>> Hi all, >>> >>> I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD >>> Commander. >>> >>> Under Win2K it works fine. On my new PC under WinXP it fails. > >> I use both a genuine Wiggler and my own design I/F without any problems >> under WinXP. You must have the printer port set for 'EPP', that is the >> most likely cause of your problem. >> >> Leon >> -- > Dear Leon, > thanks for your reply. > > A lot of reboots later I tested all possible configurations for the LPT > Port. > Unfortunateley the Fail-Message was constant. > > Your own I/F replaces the OCD Commander I think, so the Problem possibly > depends on the Commander Software.
No, I meant my own hardware I/F, which works like the Wiggler. The Commander software works fine for me. What ARM hardware are you using? Leon
"Leon Heller" <leon_heller@hotmail.com> schrieb im Newsbeitrag 
news:41a895e1$0$16590$cc9e4d1f@news-text.dial.pipex.com...
> "Thomas Motz" <thomas.motz@gmx.net> wrote in message
> No, I meant my own hardware I/F, which works like the Wiggler. The > Commander software works fine for me. > > What ARM hardware are you using? > > Leon
I tested with several ARM Boards: AT91EB40a, Olimex LPC-P212X, Cirrus EP7312. With all these Boards I had no problems under Win2K, but this was on my old PC and I cast suspicion on the LPT Hardware now. (The commander works fine for you so in all probability I have a Hardware problem with my new PC. Onboard LPT Port from ASUS P4P800S-E) I will google for some Test Software for XP and Monday I will buy another LPT Hardware. Regards Thomas
> I will google for some Test Software for XP and Monday I will buy another > LPT Hardware. >
we use XP and never have had whatsoever problem with our ARM-JTAG check LPT port settings, and if your computer which run XP is faster than other one where our JTAG "works" do some adjustments on SPEED parameter Best regards Tsvetan --- PCB prototypes for $26 at http://run.to/pcb (http://www.olimex.com/pcb) PCB any volume assembly (http://www.olimex.com/pcb/protoa.html) Development boards for ARM, AVR, PIC, and MSP430 (http://www.olimex.com/dev)
Thomas Motz wrote:
> "Leon Heller" <leon_heller@hotmail.com> schrieb im Newsbeitrag > news:41a895e1$0$16590$cc9e4d1f@news-text.dial.pipex.com... > >>"Thomas Motz" <thomas.motz@gmx.net> wrote in message > > >>No, I meant my own hardware I/F, which works like the Wiggler. The >>Commander software works fine for me. >> >>What ARM hardware are you using? >> >>Leon > > > I tested with several ARM Boards: AT91EB40a, Olimex LPC-P212X, Cirrus > EP7312. > With all these Boards I had no problems under Win2K, but this was on my old > PC and > I cast suspicion on the LPT Hardware now. (The commander works fine for you > so in all > probability I have a Hardware problem with my new PC. Onboard LPT Port from > ASUS > P4P800S-E) > > I will google for some Test Software for XP and Monday I will buy another > LPT Hardware. > > Regards > Thomas > >
I managed to damage onboard LPT on my system. Then we bought I/O LPT card (PCI version) and we thought this will solve the problem. Printers communicating with legacy drivers worked normaly but other software not. Try before buy if you'll buy IO card. BR, Slawc
Thomas Motz wrote:
> > Hi all, > > I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD > Commander. > > Under Win2K it works fine. On my new PC under WinXP it fails. > Commander gives the message "Adapter not connected" > A parallel printer works fine on this LPT Port. > > Macraigor wrote that the Commander works with Win XP. > Has anybody used this combination? Do I need special drivers > for LPT Port under WinXP?
I can't get my Olimex arm-jtag to run with OCD commander either. I've tested just about every possible combination of bios setting, LPT port, communications delay, and target jumper configuration (Olimex LPC-P2106 and LPC-WEB). Swapped out the xtal on the '2106 board as a test too. Even tried a couple of older versions of OCD commander--no go. I'm running under win2k, and the very same installation of OCD commander works fine with BDM wigglers to my CPU32 hardware. The Olimex arm-jtag clone did work for me under Rowley Crossworks. newell
"Thomas Motz" <thomas.motz@gmx.net> wrote in message
news:co9ocv$ljb$1@ngspool-d02.news.aol.com...
> Hi all, > > I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD > Commander. > > Under Win2K it works fine. On my new PC under WinXP it fails. > Commander gives the message "Adapter not connected" > A parallel printer works fine on this LPT Port. > > Macraigor wrote that the Commander works with Win XP. > Has anybody used this combination? Do I need special drivers > for LPT Port under WinXP?
Works fine on my XP Home. Try changing the speed parameter. I've used Wiggler, Raven, and the Amontec. So far the Amontec seems to have the least quirky operation.
> I tried to use the Wiggler compatible JTAG Adapter from Olimex with OCD > Commander. > > Under Win2K it works fine. On my new PC under WinXP it fails. > Commander gives the message "Adapter not connected" > A parallel printer works fine on this LPT Port. > > Macraigor wrote that the Commander works with Win XP.
AAARGH! Under Win2K I used OCD Commander Version V2.2.5 . This Version works both under Win2K and WinXP. Under WinXP I got the new Version 2.4.0 from OCD Commander and this Version does n o t work with my WinXP. Now I'm using V2.2.5 and it works fine on my new PC with WinXP. Thomas