CCE pragma no epilog

Started by curlinou in MSP4309 years ago 3 replies
IAR

Hello ALL I juste migrate from IAR to CCE (Trial over, CCE wins the match) #pragma no_epilogue is not recognized in CCE ? Does anyone...

Hello ALL I juste migrate from IAR to CCE (Trial over, CCE wins the match) #pragma no_epilogue is not recognized in CCE ? Does anyone know the correct syntax ? Thanks for All. ------------------------------------


CCE V2.0.4.2 Function Lookup Table

Started by Colin Garland in MSP43010 years ago 8 replies

First posting to this news group... I'm migrating to MSP430F2618 from MSP430F149 to take advantage of extended Flash area (120k) and RAM (8K)....

First posting to this news group... I'm migrating to MSP430F2618 from MSP430F149 to take advantage of extended Flash area (120k) and RAM (8K). Unfortunately as GNU didn't support 20Bit address mapping so I've had to use resort to either IAR or CCE compiler. I like the feel and cost of CCE but for this one issue that might put me back to using IAR. I have a CCE compile bug which I can't solv...


Upgrading CCE 2.0 to CCE 3.0

Started by "paddu.koti" in MSP4309 years ago 1 reply

Hi all, Where can I find documents about upgrading CCE 2.0 to CCE 3.0.. thankyou and regards.. ------------------------------------

Hi all, Where can I find documents about upgrading CCE 2.0 to CCE 3.0.. thankyou and regards.. ------------------------------------


Regarding CCE 2.0

Started by "paddu.koti" in MSP43010 years ago 6 replies
IAR

Hi, I am new to the development tool CCE from TI. I was using IAR, recently I installed CCE 2.0 and tried debugging the source code in CCE...

Hi, I am new to the development tool CCE from TI. I was using IAR, recently I installed CCE 2.0 and tried debugging the source code in CCE 2.0(source code previously witten in IAR). I am able to compile the code, but when I try to Debug I am getting following error. ------------------------------------------------------ Error creating session Target Server Open failed GDB outpu...


??CCE Code Examples??

Started by twincircuits in MSP4309 years ago
IAR

Does anyone know where to get any AP to ED type CCE example code for the ez430-RF2500 devices? For some reason the SimplicTI code is not in...

Does anyone know where to get any AP to ED type CCE example code for the ez430-RF2500 devices? For some reason the SimplicTI code is not in CCE it is only in the IAR workbench. If I had one that I could would link to at least 2 ED's I would be light years ahead of where I am now. Thanks in advance for pointing me in the right direction. Joe J. ------------------------------------ ...


CCE3.0 Settings

Started by "paddu.koti" in MSP4309 years ago 1 reply
SPI

Hi, Where do I change the JTAG protocol(4 Wire JATG/Spi-Bi-Wire) in CCE 3.0. In CCE 2.0 there was an option in Debug Properties, but it seems...

Hi, Where do I change the JTAG protocol(4 Wire JATG/Spi-Bi-Wire) in CCE 3.0. In CCE 2.0 there was an option in Debug Properties, but it seems CCE 3.0 has changed a lot and I couldn't find that settings. And also can anybody tell me what are the major changes in this new version. Thankyou.... ------------------------------------


Fixes to use C++ with Code Composer Essentials

Started by John Heenan in MSP43010 years ago

No one took me up on my offer to post information on using C++ with CCE. Here they are anyway. The interrupt macros with CCE V2.0 as shipped...

No one took me up on my offer to post information on using C++ with CCE. Here they are anyway. The interrupt macros with CCE V2.0 as shipped don't work in C++ files. Also C++ global class instances with constructors will cause failure without a JTAG debugger with CCE V2.0 as shipped. Also using C++ template classes causes a warning about a missing .template section. Below are the ...


Interrupts CCE error

Started by dphannad in MSP43011 years ago 7 replies

Hi John, Thanks for your reply. I am enabling general interrupts using the CCE function _enable_interrupts() which I can see does the job of...

Hi John, Thanks for your reply. I am enabling general interrupts using the CCE function _enable_interrupts() which I can see does the job of setting the GEI bit. I am just looking into the rest of my code again this morning to make sure I am setting the peripherals correctly. My main complaint though is that while I am following the guidelines of defining the interrupt function, CCE in its...


[CCE] Raw Binary Output

Started by Pierre Audenard in MSP4309 years ago

Hi ! I'm trying to generate a raw binary Output With CCE. (Copy of Flash Memory Content) With IAR it was very easy (extra ouput - raw binary...

Hi ! I'm trying to generate a raw binary Output With CCE. (Copy of Flash Memory Content) With IAR it was very easy (extra ouput - raw binary format) . With CCE, It seems that I should use hex430 (and)/or other build tools. Has anyone already done this ? Thanks for your help. ------------------------------------


Target programming with CCE

Started by jreif in MSP43011 years ago

I am using an MSP430F169 in my target circuit and I am trying to program it. I am using CCE 2 downloaded from the TI website along with the...

I am using an MSP430F169 in my target circuit and I am trying to program it. I am using CCE 2 downloaded from the TI website along with the USB interface MSP-FET430UIF. I can debug the system just fine but I can't seem to be able to write a permanent program on the target. As soon as I exit debug mode the part appears blank again. I searched all menu options on CCE and can't find anythin...


Upgrade path from CCE v1.0 to CCE v3.0

Started by owaiscareer in MSP4309 years ago

Hey guys, I need your help resolving this issue. I bought CCE v1.0 PRO a couple years ago and subsequently was able to upgrade to V2.x over the...

Hey guys, I need your help resolving this issue. I bought CCE v1.0 PRO a couple years ago and subsequently was able to upgrade to V2.x over the internet. Recently I got another msp430 project and found that V3 was the current version. I was unable to successfully install this version and through TI websupport was asked to uninstall my MSp430 V2.x version, do a registry clean and then rein...


CCE critical sections

Started by rockstardrums in MSP43011 years ago 4 replies

I am a new user to CCE for MSP430 developement (I was useing AQ430 before) and I wanted to know anyone knew of support for critical sections or...

I am a new user to CCE for MSP430 developement (I was useing AQ430 before) and I wanted to know anyone knew of support for critical sections or monitor functions in CCE. Porting code with critical sections has become quite a problem for me. I would prefer to avoid using inline assembly directives if possible. Even a response stating definitively that there is no support for critical sectio...


IAR vs CCE Inline Assembly

Started by Richard in MSP4308 years ago 6 replies

I am appealing to the MSP gcc experts on this one. I am porting code written for IAR to CCE. There is a line of inline assembly: asm("mov.w...

I am appealing to the MSP gcc experts on this one. I am porting code written for IAR to CCE. There is a line of inline assembly: asm("mov.w #HostCommands,10(SP)"); This produces a compiler error of "illegal mnemonic". I assume that CCE (gcc) wants inline assembly in a different format. Thanks for the help. Rich ------------------------------------


the problem in CCE

Started by in MSP43011 years ago 2 replies

hi all, i am a new one in using msp430 and it is the first time i use ti cce, i found i can lauch program correctly,include simple...

hi all, i am a new one in using msp430 and it is the first time i use ti cce, i found i can lauch program correctly,include simple program,that is not related to test board. where is the problem? i can not use cce to simulate?? i must be use a test board to debug c/c++ program??


CCE error

Started by "paddu.koti" in MSP4309 years ago

Hi All, I have developed a project using CCE 2.0,now I am trying to run that project in CCE 3.0 and I am getting the following...

Hi All, I have developed a project using CCE 2.0,now I am trying to run that project in CCE 3.0 and I am getting the following error. ---------------------------------------------------------------------- The Managed Make project file could not be read because of the following error: project type com.ti.ccsstudio.managebuild.ui.programTargetID not found Managed Make functionality wi...


scanf with CCE 3.2

Started by aes430 in MSP4309 years ago

Hi Anyone have tried to use the scanf function with CCE 3.2?. The printf function works fine after enable the CIO function use and specify...

Hi Anyone have tried to use the scanf function with CCE 3.2?. The printf function works fine after enable the CIO function use and specify the heap size to 400. The level of printf support was chosen as full. With IAR the IO console have two different spaces: one for output; the other for input. In CCE the input and output share the same space (with different colours). The scanf functio...


how to create project in CCE 3.1

Started by diptipanchal in MSP4309 years ago

i am new to CCE. i have installed the CCE 3.1 on Windows XP & also installed JAva (TM)6 update 11. i could create the project & add files but...

i am new to CCE. i have installed the CCE 3.1 on Windows XP & also installed JAva (TM)6 update 11. i could create the project & add files but not able to save it. Am not sure where to define the MSP430 type, debugger interface type. We have MSP-FET430UIF debug interface. I have read "slau132c-MSP430 Optimizing C_C++ Compiler v 3.1.pdf". This document is not sufficient for the new user to us...


CCE: How to point stdin and stdout to UART?

Started by jhilory33 in MSP4309 years ago 2 replies

With CCE, I have been unable to write my own putchar routine and have it replace the one in the library. IAR allowed this, and works as...

With CCE, I have been unable to write my own putchar routine and have it replace the one in the library. IAR allowed this, and works as expected, but CCE gives me the following error at link: error: symbol "putchar" redefined: first defined in "./TestIO.obj"; redefined in "C:/Program Files/Texas Instruments/CC Essentials v3.1/tools/compiler/MSP430/lib/rts430x.lib " I am us


Target Programming with CCE

Started by jreif in MSP43011 years ago 2 replies

Is there any way to program a target with CCE and the USB programmer without haing to go into "debug" mode? Thanks.

Is there any way to program a target with CCE and the USB programmer without haing to go into "debug" mode? Thanks.


CCE 3.0 Compiler crash

Started by pascalmarchetti in MSP4309 years ago 5 replies

Hi CCE 3.0 C/C++ compiler is sometimes crashing when building a project. Is there anyone facing the same...

Hi CCE 3.0 C/C++ compiler is sometimes crashing when building a project. Is there anyone facing the same issue? Pascal ------------------------------------