EmbeddedRelated.com
Forums

Why doesn't svn update command work ?

Started by learn 7 years ago5 replieslatest reply 7 years ago2311 views

I'm using svn, version 1.9.5-SlikSvn (SlikSvn/1.9.5)

                   
C:\> cd Projects \ my_workspace

I had entered following command:
C:\Projects\my_workspace> svn checkout http://abcd.efg.com/svn/repository/my_project/trun... my_working_copy

Checkout was successful.
 
I tried updating as follows:
C:\Projects\my_working_copy> svn update

response from svn update command is as follows:

Updating ' . ' :

svn:  E720003 : Unable to create pristine install stream

svn:  E720003:  The system cannot find the path specified


 Why doesn't svn update work?

[ - ]
Reply by Tim WescottJanuary 13, 2017

Shouldn't you be updating from C:\Projects\my_workspace\my_working_copy ?

Forgive me if you're ahead of me, but -- have you googled on the error messages?  For most open source packages and most problems that usually gets you an answer to the same question you're asking pretty quickly, or it at least gives you other questions to ask.

[ - ]
Reply by learnJanuary 13, 2017

I tried updating from C:\Projects\my_workspace\my_working_copy  but same error.


I was able to find exact error message in google but that was for svn tortoise client and I'm using SlikSvn Client.  The solution didn't apply to me.

Is there a way to debug this problem ?

I looked at my working copy. There is a path:  ..\my_working_copy \ .svn \ pristine\*.*     There are so many folders under pristine folder.  Each of these folders has file type(s) SVN-BASE File

I don't know what the error means.  Do I need to delete bunch of folders under pristine folder?


[ - ]
Reply by Tim WescottJanuary 13, 2017

I can't help you.  I use plain old svn in Linux, or if I'm forced to use a Windows machine I use plain old svn in Cygwin.  I can't say that it's been trouble-free, but it's been better than some other version control systems than I've used, and no worse than most.

FWIW, that looks like a core SVN error, and not something specific to a client.  But I could be wrong on that.

Best of luck -- I hope someone can help.

[ - ]
Reply by learnJanuary 13, 2017

Actually above solution that I had found in google is solution to my problem.

I manually created tmp folder under .svn folder.  Then, svn update was successful.

I'll report this to SlikSvn.

[ - ]
Reply by Tim WescottJanuary 13, 2017

Given that it's all open source, there's a good chance that Tortise and SlikSvn are using the same underlying code with the same underlying bug.  There seem to be a bazillion different SVN clients.

(I started using some nice Linux SVN client, but what I found was common with every other version control system I've used: the GUI client can do all the routine stuff, but they always leave out the hard or complicated stuff, and that you have to do with a command line.  If you're working in a group that has some official or unofficial designated guru who can fix things when you GUI yourself into a corner, then you're fine.  But if you're working on your own you may be happy with a GUI for a while, but eventually you're going to want to figure out the command line.)