Power supply for router.

Started by casperPro 5 years ago6 replieslatest reply 5 years ago182 views


       I am trying to power an AR9331 router using a power supply I have made. The AR9331 requires a 3.3V supply. 

My power supply takes 12V as input, then converts it into 5V using a LM2576 step down voltage regulator and then a LM1117 regulator to convert 5V to 3.3V.

The output is at the desired 3.3V level and is ripple free. I have verified this  using a scope.  The problem is that if I use this power supply the AR9331 boots and then hangs.

If I try booting the same AR9331 with a lab power supply set at 3.3 V it boots perfectly.

Any power supply design specialist can shed a light? 


[ - ]
Reply by matthewbarrSeptember 26, 2017

Assuming your LM1117 is good to 800 mA, try setting the lab supply current limit to 800 mA and see how things go. If you then see a hang with the lab supply, perhaps 800 mA is not sufficient.

Use a scope to have a look at the 3.3V supply rail when it comes up, compare this to the working lab supply behavior. Look for a difference in dV/dt (ramp rate) as the supply comes up, and/or a momentary drop in voltage.

A POR circuit in the router could be sensitive to supply rail ramp-up rate. A momentary drop in voltage associated with a start-up current spike could cause a crash (hang) with no subsequent POR.

[ - ]
Reply by jmford94September 26, 2017

I would look at the power supply with the scope while it is booting, with a trigger set on an excursion from 3.3 volts.  You may not have enough capacitance or heat sinking on the LDO to handle startup transients.  Also, look at the wiring/traces between the LDO and the load.

The chip requires 1.2 volts as well.  Is that staying OK?

[ - ]
Reply by BVRameshSeptember 26, 2017

Introduce 10 m sec delay in 12 to 5 V supply. Use proper decoupling for both regulators.

If you are using Adj type of regulators, use capacitors across Resistor which goes to ground.

All the best.

[ - ]
Reply by casperProSeptember 27, 2017


    Thanks for the valuable suggestions @matthewbarr @jmford94 and @BVRamesh.I will try these. After my last post I learned about inrush current and tried to measure it using the following setup,


Since the resistor is 1 ohm the potential across it equals the current. The next figure shows the potential across the 1 ohm resistor,

Inrush CurrentinrushCurrent2.png

The inrush current is about 1A, whereas the normal operating  current is 250mA.

I tried two solutions,

1. Tried a current limiting resistor between my 12V lab supply and the LM2576       input. This works. The router boots perfectly.

2. Tried lowering the lab supply to 9V and connecting it to the LM2576 input.       without any current limiting resistor. This also works.

I suspect the problem is inrush current. Any suggestions?


[ - ]
Reply by jmford94September 28, 2017

Do you need the 3.3 V linear regulator in there for some reason, or can you go straight to 3.3 from 12?  The 2576 is available in a 3.3 V and an adjustable version.

Anyway, you probably should monitor the voltage before the 2576, between the 2576 and the LDO, and after the LDO when you start it up in both the successful and unsuccessful cases you mention above.  This will let you figure out which regulator isn't regulating as needed, although from your current measurement clearly you are overloading the LDO at startup.  A current limiting resistor in the 12V line isn't crazy, but also not optimal as it wastes input power.



[ - ]
Reply by casperProSeptember 30, 2017

One interesting observation is that if I power my power supply with 9V or even down to 5.5V the router boots just fine. This has been happening repeatedly during my experiments. This is confusing me completely since the LM2576 is designed for input voltages well above 12V.