12f675 serial

Started by meri...@yahoo.com in Piclist11 years ago 1 reply

Trying to have a 12f675 send serial data to another 12f675 using SEROUT2, with disastrous results. Does anybody have sample code that is known...

Trying to have a 12f675 send serial data to another 12f675 using SEROUT2, with disastrous results. Does anybody have sample code that is known to work? I'm using PBPro. Michael ------------------------------------


WIsp628 + 12F675 -> unable to "go" or erase

Started by GUILLAUME SAUPIN in Piclist16 years ago 2 replies

Hello, I do not manage anymore to "go" or erase one of my 12F675 since I have configured the gp0 pin as an output. The chip...

Hello, I do not manage anymore to "go" or erase one of my 12F675 since I have configured the gp0 pin as an output. The chip still works, but there is no way to erase it, or read its content, ... I'm using a wisp628 (which work with another 12F675).


AD with 12F675 fluctuations

Started by d1camero in Piclist16 years ago 21 replies

I am trying to measure 10-15volts to 0.01 volt accuracy. I am using the built-in 10bit ADC on the 12F675 with 1% tolerance ...

I am trying to measure 10-15volts to 0.01 volt accuracy. I am using the built-in 10bit ADC on the 12F675 with 1% tolerance resistor voltage divider. I find that the values fluctuate way more than expected, +/- 0.03 volts. The voltage is coming from a regulated power supply


I don't programming that 18F458 and 12F675

Started by cnt in Piclist17 years ago 7 replies

Hello, I've a problem with my programmer! I'm using a jdm programmer and ic-prog v1.05A. I can programming 16F84 and 16F877 without any...

Hello, I've a problem with my programmer! I'm using a jdm programmer and ic-prog v1.05A. I can programming 16F84 and 16F877 without any problem. I try to programming 18F458 and 12F675 but I don't programming them :( could you tell me what I am doing now? thanks for your advices sory for my english CNT TEK.


Re: 12F675 Startup Problems

Started by starutopy in Piclist12 years ago

Hi, you may try to bypass VDD & VSS by an 100nF capacitor as close as possible to pin 1 & 8. Then don't connect directly pin 1 to 4, but put a...

Hi, you may try to bypass VDD & VSS by an 100nF capacitor as close as possible to pin 1 & 8. Then don't connect directly pin 1 to 4, but put a resistor 100K from pin 1(VDD) to pin 4 (MCLR) and a capacitor 100nF from pin 4 to pin 8 (VSS). Best regards --- In p...@yahoogroups.com, "kg4pid" wrote: > > I'm using a serial routine on a 12F675 and started by sending out the > wor


HELP!!!!!!!!!! A/D 12F675

Started by shaunundergrad in Piclist17 years ago 4 replies

hi guys, please have a look at my code. what i am trying to achieve is to take an analogue signal (2 pots,1k each, across + and -...

hi guys, please have a look at my code. what i am trying to achieve is to take an analogue signal (2 pots,1k each, across + and - rails with wire to AN0) turn the pots up and down and switch 2 led's on, 1 when above preset level and the other when below (1 at a time). i know i cou


Re: 12F675 Startup Problems

Started by Eirik Karlsen in Piclist12 years ago 2 replies

Well...as I've said before serial coms should always be done with x-tal or maybe resonator osc. Trying to get a RC osc to run within 5 - 10% in...

Well...as I've said before serial coms should always be done with x-tal or maybe resonator osc. Trying to get a RC osc to run within 5 - 10% in accuracy and stability just isn't possible in practice...you might get it to work but when temperature changes, or a wire gets too close to chip or tracks, or whatever that can pull the osc happends you'll get tagged. kg4pid wrote: > To make it wo


HELP- PIC LED flasher

Started by asha_2108 in Piclist15 years ago 4 replies

Hi, does anyone have any source codes for flashing an RGB(tricolour) LED using a PIC 12F675 or similar PIC?? I'm doing a...

Hi, does anyone have any source codes for flashing an RGB(tricolour) LED using a PIC 12F675 or similar PIC?? I'm doing a project on it, and need some help with the coding. Have to use assembler, but even C would do. trying to program it by using different hex


12F675/629 question

Started by Phil in Piclist16 years ago 2 replies

I'm trying to use the MCLR pin for I/O on this device. The data sheet claims to do so you clear the MCLRE config bit. When I do ...

I'm trying to use the MCLR pin for I/O on this device. The data sheet claims to do so you clear the MCLRE config bit. When I do this the device behaves very oddly (output pins go to Vdd) and it almost looks like a reset that only half happened but not exactly. I'm using INTOSC (w


Re: help!!!!! with pic 12f675

Started by Paul James E. in Piclist16 years ago 6 replies

electromechy1, Make sure you change the ADCON register to make the AD inputs Digital I/O's instead of the analog inputs. ...

electromechy1, Make sure you change the ADCON register to make the AD inputs Digital I/O's instead of the analog inputs. Regards, Jim > hi guys, > just wtitten 1st prog as per data sheet,builds ok, problem is when i


12F675 GPIO

Started by noodles123x in Piclist16 years ago 6 replies

Hi I'm a newbie trying to program the PIC12F675 using Hi-Techs PICLite C software. I'm having trouble setting the outputs...

Hi I'm a newbie trying to program the PIC12F675 using Hi-Techs PICLite C software. I'm having trouble setting the outputs when addressing them directly. If I do the following "GPIO = 0b00000110" It will turn on two outputs But, If I


Re: 12F675 Startup Problems

Started by "Sandeepa.D.Khale" in Piclist12 years ago

I had a similar problem when i first used serial communication.I was using PIC16F877A, and the hardware serial port.External 8MHz crystal. Every...

I had a similar problem when i first used serial communication.I was using PIC16F877A, and the hardware serial port.External 8MHz crystal. Every code i tried,(even the tested ones i got from others from the group) nothing would be transferred.But as I would power off the circuit, some gibberish would be transferred. It was solved when, i changed the config word.The crystal settings were init...


Putting a PIC to sleep.

Started by holopoint.rm in Piclist16 years ago 4 replies

Hey all. I'm building a PIC Based Timer. I want my 12F675 to perform a simple action every few seconds. I also want to preserve...

Hey all. I'm building a PIC Based Timer. I want my 12F675 to perform a simple action every few seconds. I also want to preserve battery life so I want it to sleep between actions. Precision timing is not important. Do I need a watchdog here ? Will this be a reliable solut


Re: 12F675 Startup Problems

Started by Dennis Clark in Piclist12 years ago

One of the best ways to avoid the "Hyperterminal sickness" is to get a shareware program "Teraterm". It works better, is more reliable,...

One of the best ways to avoid the "Hyperterminal sickness" is to get a shareware program "Teraterm". It works better, is more reliable, more flexible and it can do data logging and scripting. You won't regret it. DLC > Hello- > > I've had some similar problems with hyperterminal in regards to > startup problems myself. Watch what your initial "power up" > conditions will look like


Re: 12F675 Startup Problems

Started by Eirik Karlsen in Piclist12 years ago 1 reply

Use xtal osc. One byte is typically 10bits and that means a max drift of +/-5% if the last bit is to be detected correctly (assuming sampeling...

Use xtal osc. One byte is typically 10bits and that means a max drift of +/-5% if the last bit is to be detected correctly (assuming sampeling in the middle of the bit). The practical requirement is more like -/+1% for reliable operation. Only a xtal or maybe resonator can achieve that type of accuracy. kg4pid wrote: > To make it work I had to change the the value that gets moved into >


Re: 12F675 Startup Problems

Started by Eirik Karlsen in Piclist12 years ago

This may be a baudrate problem, baudrate accidentally coming within spec while the power is on the downslope. Hyperterminal will usually filter...

This may be a baudrate problem, baudrate accidentally coming within spec while the power is on the downslope. Hyperterminal will usually filter out anything that isn't readable. Try RS232 Hex Com Tool instead its much better, it'll show you ASCII or HEX, and if you're getting garbage it'll show you that too. < http://www.rs232pro.com/ > kg4pid wrote: > I'm using a serial routine on a 12F67


have a look at my pwm motor controller on 12f675

Started by shaunundergrad in Piclist17 years ago

hi guys, just completed my pwm motor control program, please have look and see if there is any obvious mistakes, it was written...

hi guys, just completed my pwm motor control program, please have look and see if there is any obvious mistakes, it was written on mplab uses special instruction mnemonics so probably only looks correct in mplab. it works ok but the frequency a bit low. gives reasonable out


[PIC]: 12F675 interrupt on change, a lost sunday...

Started by Vasile Surducan in Piclist17 years ago 3 replies

Hi groups ! I have spend a whole sunday trying to understand why interrupt of change are not working for me. I have played...

Hi groups ! I have spend a whole sunday trying to understand why interrupt of change are not working for me. I have played with those on PIC16F877 and works ok there. According to DS41190A datasheet, using interrupt of change means: In the main program: - en


Re: 12F675 Startup Problems

Started by rj_satterlee in Piclist12 years ago

Hello- I've had some similar problems with hyperterminal in regards to startup problems myself. Watch what your initial "power...

Hello- I've had some similar problems with hyperterminal in regards to startup problems myself. Watch what your initial "power up" conditions will look like to hyperterminal. If it sees a high (voltage level) to it's interface, it will assume that there is a break condition. I have found with bit banging interfaces with the 675, I have had times where the change from the high impedance ...


Re: 12F675 Startup Problems

Started by kg4pid in Piclist12 years ago

To make it work I had to change the the value that gets moved into OSCCAL. Since the serial routine that I used had been around awhile I can...

To make it work I had to change the the value that gets moved into OSCCAL. Since the serial routine that I used had been around awhile I can only assume that the problem is in the Pic oscilator. Don't know what to do to fix it though as I don't want to have to calibrate each pic chip. Max --- In p...@yahoogroups.com, "kg4pid" wrote: > > I'm using a serial routine on a